free hit
counters
EliteEV - The Lotus Forums #ForTheOwners Jump to content


EliteEV

Basic Account
  • Posts

    47
  • Joined

  • Last visited

About EliteEV

  • Birthday 28/10/1954

More Info

  • Name
    Scott Petersen
  • Car
    1974 Elite
  • Modifications
    Converted to electric, recently upgraded batteries to 28kW of LiFePO4; minor body modifications.
  • Location
    Anacortes, WA, USA

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

EliteEV's Achievements

Newbie

Newbie (1/14)

  • Five Years In Rare
  • Ten Years In Rare

Recent Badges

2

Reputation

  1. I believe you are correct, eclat22. Very tough to install, but will summon my inner pretzel and give it a go.
  2. I didn't see the printed conversion instructions in the above thread, so will post them here. Yes, very worthwhile project...no more winking Elite! I made the brackets out of composite (foam core wrapped with fiberglass cloth and epoxy resin). Hope this helps. Scott Headlight pod conversion (2020_01_03 04_40_18 UTC).docx
  3. Hi All, I am beginning to install a Coverdale carpet set and am puzzled where some of them should be affixed. Attached is a diagram with the puzzling pieces of pile circled. Any help would be greatly appreciated! Scott
  4. Sorry for the late post to your replies. Everything slows down in a pandemic! Thanks for setting me straight on the Ford/Burman rack, Pete. As some of you have noted, it's about 170 lbs (77 kg) over stock weight. The distribution is vastly different, though. Front/rear is 47/53, so it does understeer a bit compared to the pronounced oversteer of stock (so I am told). Still fun on the twisties, but I rarely drive it aggressively. Hope you all are doing well over there. Scott
  5. Methinks that all the Federal models (and maybe European) had the Herald rack. I'm guessing because they had a LHD unit and the Burman did not. At any rate I like the idea of a slurry; thin enough to bathe the rack but thick enough that it doesn't leak out. Thanks for the reply. Scott http://www.evalbum.com/4524
  6. Engine oil, gear oil, or grease? Just renewed boots and gaskets for the Triumph Herald box, and would appreciate knowing the recommended slippery stuff! Thanks.
  7. EliteEV

    EliteEV

  8. Thanks for uploading these, Mike! They are very useful. Scott
  9. Today I noticed a loud creaking sound while moving, both under power and coasting. It kind of sounded like the wheels working against loose lug nuts, but they were all tight. When I got home I jacked up the rear and spun the wheels. The noise occurred in the left rear, but I couldn't be certain if it was from the hub or the differential. Off with the half-shaft and brake drum, and it's clearly coming from the diff. A creaking sound, with the occasional squeak. Also some binding when I turn the stub. None of this happens when I turn the right rear wheel. I am hoping some of you can identify the symptoms and give me a clue on how to fix this problem. My Elite 502 shows 68K miles, but given the whine from the gearbox, the total lack of synchros in 1st and 3rd gear, and the fact that the engine was replaced before I got it, I suppose it's possible it could have turned over. I have no history on the car. I shudder to think I need to rebuild the differential; I've heard they are very robust. I dropped it during the restoration to replace the outer seals, and remember that was a real job. I'm hoping the collective wisdom at this site will give me guidance on how to proceed. I'm in the US, so shipping 100+ lbs of steel to the UK for a rebuild is not an attractive option. Thank you, Scott
  10. Do you have an update on this, Mike? I'm considering doing this next winter. First and third synchros are gone and it whines badly. Thanks, Scott
  11. Hadn't thought about the advantage of two relays, Michael. I'll stick with your plan. The wires on my motors have different color coding than yours...either a different year or because it's from a Federal car. I'm only fabricating and testing one bracket for now. If it breaks or flexes too much I'll beef up the next one in the necessary places. My car had a bolt head as a bump stop (the rubber is long gone), so I've ground that round and glued a rubber cane foot to it. Thank you! Scott
  12. That is just fantastic, Michael! I've already procured the motors and am building this brackets...out of composite, since I have no welding skills. A few questions: - What is the length of the M6 rod? From the picture it looks to be ~170mm - Are you confident in the angle for the bump stop? In test fitting the bracket it seems closer to 35 degrees from vertical than 65 - Any idea of the amperage draw of the motors? It seems to me that one relay could be used for both motors Thanks very much, Scott
  13. The heat traces in the rear window have long stopped functioning, and I'd like to remove them entirely. Has anyone tried and succeeded in doing this? So far I've tried acetone and gently scraping with a razor blade, and neither had any observable effect. I suspect they are baked into the glass, but hope not. Thanks for any help or advice. Scott
×
×
  • Create New...