free hit
counters
benjamincalleja - The Lotus Forums Jump to content

benjamincalleja

Basic Account
  • Content Count

    422
  • Joined

  • Last visited

Community Reputation

2 Neutral

About benjamincalleja

  • Rank
    LOTUS

Profile Information

  • Gender
    Male
  • Interests
    exploring the brilliant suspension!!

More Info

  • Name
    Benjamin
  • Car
    1989 Lotus Esprit Turbo
  • Modifications
    none
  • Location
    Sydney

Recent Profile Visitors

5,615 profile views
  1. hi neil, thanks will do - it has always done the jerky shunting on cold and ive had it five years. the car drives perfectly when warm? ill check and see. Steve Taylor at Lotus Marques said this, do you concur? Hi Ben I am currently visiting the UK and return to Oz on 10/7/2016 Unfortunately you have not mentioned the year of manufacture - maybe its 1988 If you have a turbo Esprit with Dellorto carbs then you car will be a private import (exactly the same as Vinko's) From what you describe this appears to be a cold start ignition problem I recommend you grab your workshop manual and check all the small rubber hose connections on the distributor and inlet manifold Next check the ignition timing per the section in the workshop manual here - http://lotusmarques.com/info/technical/30-lotus-esprit/936-lotus-esprit-87-hc-ignition-timing-part-2 If the rubber hoses are connected correctly and the distributor plus static ignition timing is correct, the idle rpm should be at about 1500 - 1800 rpm The high idle should drop down to 950 rpm when the TIV valve located in the inlet manifold operates at about 75 degrees NOTE - an increase in idle speed is achieved via the idle jack located on the front carburettor when the air-conditioning unit is turned on Please check your workshop manual as I dont have mine with me:-) Kind regards, Steve
  2. bump*.... old thread but still the same...
  3. i had a look it was stuck so its idling ok now and correctly jacks up idle speed with aircon on etc but i still have the issue where: 1) cold starting results in the car jerking about violently when driving - the driveline jerks about shunting me back and forth until it warms up, after which it suddenly is totally fine and smooth. Symptoms are thus: The car starts eventually without choke but will start and result in a violent lumpy idle for 5 mins until it reaches 50/60 degrees coolant temp at which point it snaps to a kitten smooth idle. Driving it like this, cold without choke, is violent with shunting. Starting it with choke from cold results in instant starting but also with violent shunting until coolant temp 50/60 degrees, at which point it snaps to kitten smooth idle. So basically, no matter how i start the car, if the coolant temp is below about 60 degrees the driveline shunts me back and forth. above 60 ish the car is perfect in every way. ??
  4. hey guys, my domestic 89 carb turbo starts perfectly but until warm the whole car jerks about when driving quite violently sometimes? Totally fine when warm, very smooth but also idles at 1200-1400rpm? if you start the car and dont drive it anywhere it will idle at 900-1000rpm all day but as soon as you drive anywhere the idle wont settle back down to 1000rpm?
  5. actually wait, because my car has an Autowatch alarm system/key lock fob does this mean that the original CDL module is long gone and that the Autowatch system sends the pulses to the motors when i press the fob? in which case i dont need to spend 66 quid with SJsportscars buying an original CDL module but should rather get a new Autowatch one? or does the autowatch system route into the original CDL module?
  6. i will try and replace the central locking control module because it must be that? If it gets enough power to go down ok the doors earths must be ok, it must be the controller?
  7. hey maybe you guys can help, im trying to install a new drivers side central locking motor (universal) and ive made a bracket which works with the original but im getting this really weird thing where it locks (plunges down) with full 5kg advertised force but when it gets the unlock signal it pushes up with almost no force at all, not enough to even move my finger...can anyone think how or why it could get enough power to go down so strongly but not go up strongly?!
  8. yes, now owned by Vinko - my mate - in Prospect, sydney (round the corner from me!)
  9. sweet good to hear! i just changed my interior lamp as a side note, was always unhappy with its light output but didn't realise the PO put in a 3W glove when the manual states 10W! now much much better and so easy to change...
  10. I've fixed it but before I put it back 100% I tested it but I can't feel air being pulled or pushed anywhere. I didn't glue the fan to the spindle and I think that's the issue, the torque rating on these Maplins is much higher and they also have a higher spin rate than the oem part. I think without glue the force is enough to make the motor shaft spin inside the fan blade hole given its just a pressure fit - I will glue it to the shaft and try again. Luckily I had sealed the outer casing with duct tape and not glue!!! I do not recommend sealing with glue you may need access again one day!
  11. Such an old thread but just fixed mine with the Maplin part, it needs to be wired so it sucks through the plenum as the flexible PP exhaust routes near the drivers side wheel arch. Otherwise it's exhausting into the turbo intake, which to be honest probably doesn't matter if it sucks or pushes type thing the direction really shouldn't matter logically but best kept as per original design (pushing back through pushes fuel fumes from the plenum into the turbo routing). Lots of people remove their purge pumps on the carb turbo given more throttle will start the car but if you let it do its job it's a nifty solution to hot starting. Just make sure the purge pump temp switch next to the otter switch is replaced every so often so it doesn't stick, otherwise the purge pump will not stop running after ignition off and will drain your battery! (Stuck PP coolant sensor = can't sense when coolant is <60c)
  12. Hey Dan ask Steve from lotus marques he does up a real beauty custom for the esprit, more charging power but less load (more efficient) and better sized than the Bosch.
×
×
  • Create New...