free hit
counters
marcbria's Content - The Lotus Forums #ForTheOwners Jump to content


marcbria

Basic Account
  • Posts

    324
  • Joined

  • Last visited

Everything posted by marcbria

  1. I did see that kit and contemplated it. Did it come with instructions? I may yet get it as my repair was definitely not the proper way to do it but I didn't want to have the car off the road any longer. Can you tell me, did you lubricate the rack with oil or grease? Cheers,
  2. That is very snappy, nicely done. Maybe I need to investigate the relay mod. I didn't bother trying to tap it right off the batter after I got this done as it was such a huge improvement. Does it move even faster when you've got the car running?
  3. Hey Everyone, So when I went to get 250h safety inspected here in Canada the tech noticed some play on the steering rack. They graciously passed it anyways. I finally got around to pulling the front passenger side wheel (Left hand drive) and getting of proper look. I discovered the bush on the end of the rack had disintegrated into tiny bits, not sure how this happened. Any ideas? Seems a few others have had this happen as well. SJ has the bush part SJ978. Unfortunately to get the bush on requires drilling out a metal slug pounded into the side of the inner tie rod which is not easily done in situ. So I decided to cut the bush down one side and see if I could get it on that way. I cut it through the middle of one of the position bumps, hopefully that keeps it in place. I'll report back after I've put some miles on it to let everyone know how its holding up. Video of missing bush https://photos.app.goo.gl/9ie6cdYmtt1zH49q7
  4. Yeah, I was nervous about tweaking the window frame and cracking something. I found a bit of new foam and glued it in there. Thanks for the help everyone.
  5. If its any comfort, I have stromberg carbs on my S1 with a relatively new pump and its always ticked every ~10 seconds once the carbs are full if its not running and it doesn't flood the carbs and otherwise seems happy. I just assumed that this was normal as long as no fuel was leaking anywhere. Cheers,
  6. Hey, So turns out it was an adjustment issue. I loosened all the nuts holding the window frame and track on and pushed the window up and down over and over carefully watching where it was getting sticky then added washers to some of them. It now moves fairly smoothly. Is this how smooth it should be: https://photos.app.goo.gl/bBjHyaqjvaSEh2KS7 Is this block of foam at the bottom of the guide standard? Seems a little improvised. Cheers,
  7. Humm didn't really notice, which makes me think it probably wasn't notably stiff. How did you lubricate it once you got it clean?
  8. Hi Everyone, Its been a few years since I've posted. 250H had a cracked windscreen which caused a failed safety inspection when I move from Quebec to Ontario, so the cars been sleeping for the past 5 years. It would seem French speaking Canadians don't mind a few cracks in their glass and the English speaking do, go figures. Would a cracked windscreen pass a MOT in the UK? maybe that's where it comes from, they are quite a bit fonder of the Queen in this part of the country. Regardless new glass was sourced, shipped and installed, quite the nerve wracking experience. The car is back on the road all safetied, registered and insured. I've started working on little annoyances and have turned my attention to the driver side window lift motor. So far I've cleaned all the tracks and pulleys and re-greased them. I've pulled the motor, cleaned and re-greased it inside and out. Can anyone confirm if this is the correct motor, it fits and works but its got some sort of black coating all over it. Had tons of carbon bits all over the inside from the brushes I assume so cleaned that all out. I reassembled it all and I think its now worse than before. See the video, the cars not running but I've got a 25amp charger on it, should have plenty of juice. So next steps would be appreciated. I'm going to try powering it directly from the battery to see if relays are in order. I'm inclined to think the window frame needs adjusting but how? Cheers, Brian Video after refitting motor: https://photos.app.goo.gl/xzXLh7LirKc8m9E1A
  9. marcbria

    marcbria

  10. Doesn't do too much, on some cars they just hang them out the bottom under the engine. The idea is to capture fumes from within the engine and duct it into the air intake some that they are burned off during combustion. Some engines breath more than others so you may not notice it letting out fumes, on my S1 if I take it off the hose it looks like its steam powered train letting out littles puffs of smoke. Brian
  11. Edge, Do you mean bolted instead of studs? or just the fact its hanging on the back of it?
  12. Any time you go under the dash do yourself a favor and take out the seat. Assuming your carpets have some pile left its not completely uncomfortable like that = )
  13. Hi Dixie, May still be burned out bulbs, although sounding less like it. The normal headlights are dual filament, flashing turns on the high beam part of the low beam bulb as well as the high beam bulb. Brian
  14. Don't see how oil getting past the seal in your distributor could be your problem but maybe I'm missing something. When my distributors oil seal failed it resulted in an occasional hiccup where it wouldn't fire because the contacts in the distributor cap were oiled up. Brian
  15. Stupid question but have you checked the bulbs. On my daily driver I had 4 tail lights all burn out at the same time, so that may be the place to start.
  16. Both the 43D and 45D had weights and springs. The only difference is that the 43D didn't have a vacuum advance.
  17. If you think about the design on the Esprit's heater box, it wouldn't be difficult to have made the heater matrix slide into the heater box through a panel on the side of it from the passenger foot well. John looks like I've got the same style heater box on my Esprit with the single blower, but my matrix exists through the ends of the matrix not at 90 degrees like your.
  18. Is it possible there is some sort of external box doing the advance or maybe something internal like the 123 ignition? What type of distributor is it?
  19. Keep at it you'll figure it out. You may want to checkout the yahoo lotus group think there are more American owners over there who may know this setup better. Brian
  20. Ok, few, I thought you couldn't get it open at all! That would have been a trouble. You can easily take the door card off from the inside and see whats going on.
  21. Hi Andy, You mean the speaker hole under your elbows in the fire wall. Thats kinda strange my S1 has a cavity cast in fiberglass to hold the rear of the speakers. Looks original on my car. Maybe someone cut out the back part of the speaker recesses on your car to install larger speakers? Brian
  22. Could be the hinges... could also be shot door latch mechanism. You don't need to turn and pull though. Just unlock and then pull. Do try lifting a bit. Mine opens much easier due to worn hinges when you lift the door a bit.
  23. Does the interior look replaced or is it just me?
  24. My S1 has a resistor, it melted the wiring. I had to cut a big chunk of the harness out and replace the resistor with one embedded in a heat sink.
×
×
  • Create New...