free hit
counters
dalepearson's Content - Page 4 - The Lotus Forums #ForTheOwners Jump to content


dalepearson

Basic Account
  • Posts

    369
  • Joined

  • Last visited

Everything posted by dalepearson

  1. Just been and filled up and do some more testing. If you do a gradual acceleration all is fine, its only if you come off the throttle and then go back on the throttle hard. I also just pulled over and rev'd it at idle and I am pretty sure its either throttle or air flow related, as its as if it coughs then suddenly goes oh yeah I am supposed to be doing something, then it does it.
  2. I am sure its totally unrelated but I drove my car for the first time today since its 2nd year service and its not a happy bunny. Only issue I had post service was when leaving the garage I had a spanner light on the dash, so the technician came and cleared it, but then the car wouldn't start, and they tried and also no start and the dials were not zeroing out, they then disconnected the battery and reconnected with a jump pack and all was right again. When pulling away from standstill it is very hesitant and jerking (like new driver kangarooing). When coasting and coming back on throttle its similar, hesitant and jerking into acceleration. if you keep it flawed and accelerate hard and move quick through the gears there is no issue at all, but even pulling back into my road and heading to the drive its mega jerky. Before I get it booked in at a garage and travel, has anyone else had similar? I assume its not clutch related based on it being ok when pushing hard, so its not slippage, so I think it might be a maf or fueling issue potentially. Only thing I did spot when getting home is I am down on fuel (30 miles left), never had similar issues on low fuel but I might just go fill up and see if by magic it clears itself. There are no lights on the dash, penny for your thoughts?
  3. I have used Silverstone before, and no complaints but they have shut up shop and trying to get a service in next week. Newtown can get me in (not check Williams), but worried about the above statement.
  4. As the title really, I dont have any main Lotus dealer nearby, so checking my options out. Looking on the Lotus site, Newtown Lotus is similar distance from me as Silverstone and Williams, so looking at options.
  5. Anyone had their 2 year service on an Evora 400 and able to comment on what was done. Looking online and in the manual its not clear to me. Some say the supercharger belt is changed, some not. I do miss the clarity of A A B A, etc service info
  6. Thoughts after the install? Also how many pictures of the queen for said part?
  7. It might actually be the brake pedal switch. I had this happen on my 2010 NA Evora (common issue apparently), I gave it a clean with an air can and was ok since (bought a spare on eBay just in case but never needed it).
  8. Wife isnt doing to well, so currently on kid duty. May get out later .... what time do you guys think you will be done there?
  9. I used to have Paul Matty service my Evora, and previous Lotus. No complaints from me.
  10. Sorry yeah, I meant "both". In the past I would say coming off the throttle could be abit jerky, now its alot smoother.
  11. Nice to see Lotus maximising on the Evora. I like the new front bumper, not a fan of the spoiler and the rear bumper I am undecided on still.
  12. @DJW like you say its personal taste, its not an overpowering increase at all though.
  13. Once the K&N filter is in here are the improvements: Increased air intake (can hear the air sucking more, like the Radium I had on my S1 Evora) Increased supercharger whine (I like this) More pops from the exhaust, sounds even more animal Increased throttle response, but coming on an off the pedal
  14. So after @JayEmm mentioned he changed his air filter to a K&N in his Evora 400 with positive results, I thought I would do the same. Its not difficult but its not simple either, so thought I would share quick thoughts on the strips to take. Ideally if you have the ability to shrink like Ant-Man this would be the recommended approach, failing that put on some gloves and be ready to lose some skin and assume all sorts of awkward twisting positions. Disconnect the air pipe between the airbox and the engine, un-tighten both ends and remove engine side first, then you can wiggle it off the air box. Its attached so just push up towards the rear window Now unclip the MAF sensor and tuck this down out the way Now top left there is a black plastic cylinder thing (not sure what its called), slide this up and it will come off the mount, again push this up our of the way as its still attache Now there are 3 clips to undo, the first one is easy its on the top right of the box, just under where the pipe was you removed. The next one is top left you can get to this by reaching up and down where the black plastic cylinder was removed. Then finally you have one bottom left which is a right pig to get to, so just carefully squeeze your hand through near the coolant reservoir, or over and down the airbox. Once done the airbox should pull off to the right (you can see the little slot mounts easily) it should move forward around an inch, then you can slowly raise it up and ease the paper filter out. Sometimes the clips rest back down which will stop it sliding, so keep checking those clips and wiggling. If replacing with another paper filter be careful not to crumple it going back in, but if you are using an aftermarket K&N or Green it will manipulate abit easier and slot in Reverse the steps, the hardest bit here is sliding it all back on into the mounts and a nice square fit, doing up the clips is alot easier than undoing, but make sure everything is tight and sealed Reconnect the pipe, hang up the cylinder and reconnect the MAF sensor cable. It will take a little while for the car to adjust as the airflow will change slightly, you can speed this up by disconnecting the battery, but thats probably more hassle so just let it adjust over time. The K&N replacement panel filter is part number K&N 33-2355 and costs around £50 I will add I think these cars are getting hard and harder to work on My Elise I did all the work on, as with the Exige S which was slightly trickier, then on my S1 Evora I fitted the exhaust and a Radium Induction kit. So I am confident in what I am doing, but man some of these things are a ball ache
  15. @JayEmm I am not sure Ant-Man fitted yours, but I just took my old one old in prep for the new one being delivered today, and it was MANY Minutes to get the bugger out and half the skin being removed from my hands.
  16. Cheers @JayEmm couldnt see them on the Hangar111 website.
  17. JayEmm have you got the details / part number for the filter? I assume it was just a panel filter replacement? Assume its the K&N 33-2355
  18. Very nice, can you post a pic of the "black signage" on the back please?
  19. I am thinking about ordering one of these. Are there any example pics of all the different colours? Also are there example pics of no logo, outline logo, colour logo, and embroidered? - Assume outline and coloured are the common ones on here, so mainly the others. Assume all have TLF on the rear in a predefined colour?
  20. As per the above I have had the same a few times. Most recently I picked up my son from school and a friend, we popped to ASDA to grab some food, so I park in the parent and child spot (both kids 5). 2 random people who were not together started ranting about me and cocks who drive flash cars thinking they can park anywhere. Assistant manager appeared from somewhere was about to chime in also, and it was at that point I was moving the seat forward allowing two kids to jump up. Just silence from all .... no apology, just walked off. People really are muppets.
×
×
  • Create New...