free hit
counters
David Parker's Content - The Lotus Forums #ForTheOwners Jump to content


David Parker

Basic Account
  • Posts

    3
  • Joined

  • Last visited

Everything posted by David Parker

  1. My poor 89 Esprit SE is starting to become a bit neglected, all relatively small stuff but time consuming as a whole and time is something in short supply at the moment (poor old me ) The list so far has become:- Windscreen wiper shot off the other day and needs the arm modding Boot release cable snapped (can still open it with pliers but needs replacing) Passengers window has had motor refurb but needs aligning and door card etc putting back on Central locking not working Chargecooler impeller almost definitely kaput, I could fry eggs on it! Getting a misfire sometimes under hard acceleration Both doors need aligning as they just wont shut flush Passengers door interior handle trim broken Front drivers side indicator not working Headlamp surrounds and screws rotted away and need replacing AND The interior leather needs recoloring The last one I want to do myself but not until all of the others are done. As single jobs they are not that much of an issue but in their entirety I just don't have the time, most of my clients are schools so this is my busiest time of year and the kids/work are eating away at my weekends. What I don't want to do is leave it all until I do have the time as by then the optimal driving weather will be gone and she will be garaged again Any suggestions to a decent spanner monkey in the local area or indeed for a suitably experienced forum member that fancies earning a few quid? I used to use Horizon before they disappeared and then used Mike afterwards but after the state I got the car back in the last time that is never, ever going to happen again! I'd take it to Paul Matty's as I did for the last lot of (far more serious) work, but for the relatively "minor" stuff that is listed I don't really want to sell a kidney to pay for it. Any suggestions my fellow petrol heads?
  2. Thanks for the responses so far, very informative. You just may have something there Bibs, I haven't actually looked at the temperature gauge when it has been doing it. i don't ever give her full welly when she is cold, but it could be that I was maybe being a bit "over eager" and hadn't let her warm up to full temperature, I will have a look at that tomorrow. The chargecooler impeller has definitely had it, the top of the box is at the same temperature as the rest of the engine after a run so I know it is doing sweet FA, I have looked around briefly at the electric kits but can't seem to find one that has everything, i.e. the kit, gaskets, blanking plates etc, maybe one of you gents could point me in the direction of a full kit and some instructions. Regards Dave
  3. Hi all, first post here and I have already found loads of useful info so thanks in advance. My 1989 SE is having intermittent turbo issues, sometimes I will get the full on slammed in the seat boost, other times I will be lucky to get 0.5 bar and hardly any boost at all. After reading through the forums I now know that I probably have a knackered chargecooler impeller, the top of the cooler is always hot and from what I have read this is a sure sign that the impeller has gone. However, would this cause an intermittent boost? The other thing I have noticed recently is that the water warning light is constantly on (the orange one at the far top right of the dash) even though the water levels are fine. All of this started after I had a load of repair work done (snapped final drive shaft), got the car back, foolishly didn't check it all out and then garaged her for 6 months. Once I went to drive it again the catalogue of omissions that the "garage" had made was staggering. Handbrake not reconnected, reverse lights not connected, exhaust back pressure valve not connected and the vacuum pipe left trapped between 2 body panels, diff shaft oil leak etc, etc. I have cured all of those but can not get my head around the erratic turbo power, could the soon to be replaced impeller be causing the power drop off and warning light? Best Regards Dave
×
×
  • Create New...