free hit
counters
Devilish's Content - The Lotus Forums #ForTheOwners Jump to content


Devilish

Basic Account
  • Posts

    37
  • Joined

  • Last visited

Everything posted by Devilish

  1. Hey guys, I have a 91 Esprit SE and the right rear shock blew out and is leaking. I need to replace both rears. The suspension is all original and I plan to keep it at the original ride height. I should note I am in Canada, trying to source parts here is a little tough. Anyone make a good shock absorber for the rear?
  2. So new fuel pressure regulator went in...it ran good for the first test drive, now the engine stumbles and has a misfire. i can’t seem to win...also can’t find my original injectors to put in 🤦‍♂️
  3. Whoo Hooo!! lol Thanks guys...had a minor panic attack for a moment
  4. So coolant pissing out of this line when I pull it off is ok? i don’t recall coolant coming out when I removed it?!
  5. I replaced my fuel pressure regulator and now I noticed I have coolant flowing through my vacuum line, I believe going to the map sensor?! It’s the vacuum line on the front of the charge air cooler in front of the two coolant lines. did I hook up the coolant lines wrong??
  6. The pressure loss was when the regulator was removed and tested
  7. Any idea where I can buy a new one? mine is screwed, pumped up to 20 psi and it leaks to 15 within seconds
  8. What is this called exactly? its on the end of the fuel rail, I believe it’s the fuel pressure regulator but can’t find a matching one to buy?!
  9. I put in Five-O injectors. After I installed them they ran great, no issues at all, car had good response and ran like a dream. After sitting in the garage all winter (heated garage) I took it out for the first few runs and it's acting up.
  10. Awesome, I'll check that out!! Thanks for the tip!
  11. Can I remove this air bleed valve or should I relieve pressure first? Never done this before. Is it located on the front of the fuel rail or rear? I've tested all the cylinders for spark, all the wires were also checked, new plugs put in as well. All pugs were burnt, not wet which tells me they're working...however they're all black not a nice brown colour.
  12. The O2 sensor I'm using is a new Bosch (original O2 sensor, part number matches the original) The car stutters at low RPM. Almost like it's missing. If it's in gear it's jerky (Like a kid learning to drive a manual transmission lol) Checked the TPS and checked the Ohms, started at .4 and ran up to 4.4 without any dead spots, so it's good. What is IAC? (Sorry I'm a little new to this. How do I get it to do a relearn cycle? It was burning oil as the crank case breather hose was blowing oil into my air filter, have since put a 3/4 catch can on it and it seems to be good. My dipstick is never low on oil the entire time, so I don't think it burnt much of it. Thanks a lot for the help so far, I appreciate it!
  13. My 91 Esprit won’t pass an e test. Had the test done last year and the limit for CO was 1...my car blew a 7. since then I have replaced injectors, air filter, fuel filter, spark plugs, ECM, coil packs, MAP sensor, O2 sensor, added a 3/4” catch can etc...stupid thing today blew over 10 on the CO test and 1200 on HC!! its dumping fuel and I have no idea why? test results below
  14. Thank you for the tip, I’ll try that. I agree that GT3 lip looks great, maybe I’ll try and find one!
  15. It’s cracked on both sides and needs to be repainted as it’s faded bad (red paint)
  16. Hello Everyone, I'm repainting my car and am having issues removing the rear lip above the tail lights. See pic below, not of my actual car but similar. I removed the 6 bolts from inside and the rear tail lights and the lip is still on the car. Appears it may have been epoxied on the car from the factory? Anyone ever removed one before? Thanks, Kevin
  17. Yeah it's strange that my code comes up as this. i had a sample test card sprayed to match my paint and the calypso red is almost darker then my car. my paint has more white in the paint, even in the door jams where there is no fade.
  18. I found the paint code under the hood but when I try to figure it out online, I get nothing. anyone know what it is? I believe calypso red. thank you.
  19. Hi Jacques, I still have not gotten to the bottom of it yet. I did purchase and install a new ECM, but it's winter here and I can't get the car out to re E-test it. I downloaded freescan to my laptop but can't get a dataport to fit my car. Almost appears that someone changed the ports. I have a case full of every port made (GM, Toyota, Chevrolet, Mazda etc) Tried to hook up under the dash and the rear engine bay, no luck.
  20. I have some manuals for the car, the original owners manual and a service manual...that's it. I downloaded the freescan but need the cable to hook up to my laptop.
  21. I don't know anyone else around me with an Esprit that I could borrow a sensor from. I'll try and take some pics of the injectors tonight and see what I can come up with. Thanks for your help.
  22. I searched on the forum and someone suggested a Bosch o2 sensor that fit perfectly, so I bought that.
  23. I can't seem to get it to download. I keep opening it, just get an error page. Tried to right click and open another tab...get the same thing. Can anyone help me? Thanks
×
×
  • Create New...