free hit
counters
Cads - The Lotus Forums Jump to content

Cads

Basic Account
  • Content Count

    30
  • Joined

  • Last visited

Community Reputation

11 Good

About Cads

  • Rank
    L

More Info

  • Name
    Neil Cad
  • Car
    Exige Sport 350

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Yeah I agree - I’ll give it ago when I can get out in it next... i was worried they were damaged but I don’t think they can be....
  2. Great thanks for the info! Ill try mine again this week, I did sort of do some of that but not as aggressively. The first time around my wheels were covered in rust so I’d like to think I’ll get abit more off! Ill reply back with the results as well I’m case anyone else has the same issue... but yes they know how to stop! . You should give a track day a try... I loved it!
  3. Thanks guys - I’ll try all of that! If the bedding in cycle doesn’t work I’ll take them off and will have a look. Mines going into the dealer in about 3 weeks, so if that doesn’t work I’ll ask them to take a look. You’ll have to let me know what B&C say @RoflOnMyWaffle if you don’t sort yours before...
  4. Hi guys - So due to weather and work and just generally being busy, I’ve had to leave my car stood for about 4 weeks. When I came to move it a couple of weeks ago the brakes were stuck on and it took abit of time to free them up (handbrake was off). I took it for a drive and did some heavy braking, loads of judder initially and loads rust has come off and they look fine from what I can see. After been out today I’ve noticed there is still a slight judder when I’m barking heavily. Any ideas? It might go away but I want to make sure I don’t wreck the discs if I keep going. Or is there anything else I should be doing other than just continuing to drive it (I’ve already done about 50/60 miles)? Thanks in advance!
  5. I think you're right @Colin67 - I'm already looking at dates and cancelling stuff in my diary!
  6. Hi guys - I didnt get chance to post in advance, but I have managed to do my first track day! So thanks to you all for you're advice earlier in the year - however I am well and truly blaming you all for getting me hooked!! I had an awesome day with @david_pittard at Bedford on Monday, I can't recommend him enough. I feel like I learnt so much in one day that I definitely need to book a second session (unless I put you off a second session @david_pittard by trimming the grass with my front splitter ). There was also a great photographer at the track so I managed to bag some great images.... I've posted a few below!
  7. Cads

    Lotus in the Peak 2018

    Brilliant stuff! I’m all signed up and really looking forward to it... sounds like it’ll be a good turnout! See you next week
  8. Thanks @NickEng, I hope that’s all mine is as well... it certainly feels like it. I’ve got the spanner on the dash as well though so I think I have another issue - although potentially not related to the electrics or battery! Do you mind me asking which lithium power pack you went for @NickEng? They sound like they could be useful...
  9. Thanks @Arun_D. I might be interested in that, however @KJD might have a point about something draining the battery. I've read some other threads and asked about abit and it sounds like it might have another issue... I've got it booked in next week, let me see what they say and I'll come back to you if it is just the battery!
  10. I’m assuming its a faulty battery just because I can have it on the CTEC for 5 day’s, but even then it struggles to turn the car over and the dials flick right to left... (like when it’s flat) and there’s small delay in lighting the instrument panel up. If I turn it off I get one or two more starts then it’s dead... Feels to me like it’s not holding it’s charge... Im not sure what else could be draining it?
  11. Hi guys - I've read the previous battery threads, but just wondering if anyone has recently replaced theirs. Ive got a Jan 2017 car and the battery is already knackered, so I need something abit better than the factory spec I think. It's started draining even after a decent run (like today, when I got stranded at Oulton Park!!). I also have a tracker fitted to the car which isnt helping. So far the best I can find is a Bosch S4.... Has anyone got any other reccomedations or ideas?
  12. Cads

    Lotus in the Peak 2018

    I love this video, great job by whoever pulled it together!
  13. Thanks Bibs! I didn’t see that... Great - leave that with me and I’ll get on it!
  14. Hi @deanb - Lotus in the Peak looks awesome, I'd not seen it either but I might try to join you if you don't mind. Those roads are awesome up there. How does it work, would I need to register on MLOC?
  15. I just Googled how long it would take me to get to the Grimselpass from Manchester in the UK. 16 hours and 880 miles! Awesome road and awesome car as well! Hope you enjoy it! I'd love to get mine over there, those roads look awesome...
×
×
  • Create New...