free hit
counters
gingerjimi's Content - The Lotus Forums #ForTheOwners Jump to content


gingerjimi

Basic Account
  • Posts

    19
  • Joined

  • Last visited

Everything posted by gingerjimi

  1. Hi Jon, Cheers for the response. Mine seems to be working great then, on to the next problem. haha. Thanks James
  2. Hi, Does anybody know what the fuel flow rate should be on a 1990 2.2 NA? The service manual lists the rate for a turbo model but not the NA. Thanks James
  3. Hi Jon, Thanks for the reply. I think i might buy one and fit it next winter. It seems it makes it more reliable. Have you had any problems with the bluetooth one? I can just imagine setting the immobiliser and then the bluetooth not working or i lose my phone or something... yikes You have a nice collection of cars
  4. Hey, yeah i've seen his post and it's why i'm asking about them. He knows his stuff and he definitely likes them. I was just trying to see if anyone had a personal experience of them to persuade me to fork out the money. 😛 Cheers for the reply
  5. Hi, does anyone recommend a 123 ignition distributor for the X180 NA? i'm thinking of getting a USB one like this https://www.123ignition.de/123-ignition-en/ignition-distributor-lotus-esprit-s1-s2-s3-usb.aspx Also, mine has the constant energy system if that makes a difference? Thanks James
  6. Hi Steve, Thanks for the response. For two years it's only done it when it got hot. This saturday and sunday she suddenly started doing it randomly. I also realised that in the last two years it was jus the windows and not the radio that stopped working. Over the winter i had changed the radio power feed so that it switched on when the key was in position 1 instead of in position 2. I realised it might be on the wiring from the ignition cylinder. I checked in there and found the lead in the connector block was very slightly loose. Hopefully i'll be able to wind down the windows when it's hot, and also close them when i park! Thanks James
  7. Hi, I have a black x180 NA and the electric windows and radio stop working when it sits in the sun. Is there a common earth for these items, or maybe something in the fuse box? I think it's inside the cabin as they start working after 10-20 mins if driving with the sunroof open. Thanks James
  8. Hi Filip, Thanks for the response. Hopefully i'll get a good coil to fit. Thanks James
  9. Hi, Does a 1990 x180 have a ballast resistor? I've been told by a coil manufacturer that it does. The coil measures 1.2 Ohms, so you'd think it would have a ballast resistor. However, i've done a voltage test across the positive to negative coil terminals and the positive terminal to earth with the negative terminal disconnected and the voltage remains the same so it looks like there isn't one installed. I've then spoken to a Lotus garage and they say there isn't one on the x180 but they currently can't double check. Someone else has said they think it's in the coil? Thanks James
  10. No Worries for the pic. . I'd guess you could get a proper choke cable from https://www.pnmparts.co.uk/ As far as I know it's standard on the x180. Then they had airbags form the S4 onwards, but i've only been in my esprit so it's only from pictures and comments i've seen from other people.
  11. Here’s the location of my starting device cable if it helps @DaKa
  12. Hi, Thanks for the help guys. Mine must be running a bit lean then as I have to keep the revs up for quite a few minutes in spring/autumn mornings before she runs fine. I daren't pull out of a junction if anything is coming until she's fully warm. I use a couple of squirts of the throttle in the summer, then 4-5 in spring/autumn and then the no starting issue in the winter for several minnutes (hopefully this is now sorted), but the plugs look good to me. Not hot/dry or sooty either. Thanks for heads up on the choke/starting device. I even had a carb specialist calling them chokes when he set up the twin dellortos I fitted on my spit (produces great sound). Basically it does the same job of enriching the fuel/air mixture but by doing it the other way around. What should the SI units be for this mixture though? 😛 Thanks James
  13. Hi, Thanks for the replies. I don't think it has a throttle jack. I think they are probably not on the carb cars? I've emailed a couple of websites. 1 isn't sure and I'm waiting for a reply from another. It doesn't have AC though. I have always been told not to use the choke/starting device but to use 4-5 squirts of the throttle. However I had been trying to use the choke when I found it wasn't starting. I've always found the choke to stop solidly so presumed it was opening fully, but i checked the travel today and found it was only opening about 1/4 of the way. I've lubed it up a lot and found it started after a few attempts. 1 minute i think it didn't have enough petrol and the next it was definitely flooded so hopefully i'll get the knack of it and won't need to take the carbs of for a few more years. Thanks James
  14. Hi, I have a 1990 NA esprit which only seems to like the summer. In the summer she starts easily and runs fine but in colder spring or autumn days she sometimes takes a few goes to start and she will also stall if you leave her ticking over for more than about 30 seconds. This seams to happen if I use full, partial or no choke. In the winter she can take several minutes before she even fires, then several more minutes of firing/running for a few seconds before i can actually get her to run continuously, and then i have to keep my foot on the throttle for several minutes. All the spark plugs seem to be the proper colour. I guess I just need to give the carbs a good clean and check over though, or is there something else that I should investigate? Ps, I changed the battery last year and she's stored in a dry but unheated garage? Should I just move to Spain?? Thanks James
  15. Hi Guys, Thanks for the help. I've forwarded all the details on, so hopefully he can get it fixed. James
  16. Hi my friend had his car hit up the backside and he’s looking for a specialist to bond the new panels on. Are there any recommended around Norfolk, Suffolk or Cambridgeshire? thanks
  17. Hi Steve, This was the first thing i did, as this is what had happened a couple of months ago. This time it didn't work though (and i also tested the connection with a voltmeter, tried two different battery charges, a boost pack and jump leads onto some battery charger leads i had cut off). However, I have now managed to unlock the car with a lockout kit (without any damage that i have spotted yet), and found that the battery was flat and everything now works as it should. I am now leaving the battery disconnected till i can get a battery conditioner. Cheers for the help James
  18. Hi Guys, Thanks for the responses I thought the ignition key must have been changed at one point and the door keys thrown away, but according to the handbook the esprits were made with different door and ignition keys for "added security". I'm awaiting a reply from the previous owner. Both the doors are locked, and the alarm light isn't flashing. I've managed to get a wedge in at the top of the door and i've tried to push the unlocking latch with a coat hanger, but it has too much flex to push it. I've now ordered a lockout kit from amazon as most of the locksmiths seem to only be available for emergency call out only due to the virus. I was hoping someone knew of an easy way in before i had to go down that route. Thanks James
  19. Hi, I have a 1990 esprit X180 and the central locking has decided it doesn't wanna work. I also found out that I haven't got a key for the door locks. (i found both of these things out at 4 am when the alarm started going off and I was unable to switch it off or get into the car...... i think my neighbours hate me. The battery is charged so I'm hoping it's just a fuse! Does anyone know of a way I can open the front bonnet to change the fuse, or a way of getting into the passenger compartment without causing damage? Thanks James
×
×
  • Create New...