free hit
counters
Rossybrown's Content - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


Rossybrown

Basic Account
  • Posts

    11
  • Joined

  • Last visited

Everything posted by Rossybrown

  1. Ahhh, the days when I had an acting career…
  2. So, I thought it would be nice to update everyone on this mini project: Cosmetic exterior work: · Removed red pin stripe that was on the diffuser – I just didn’t like it · Removed black plastikote that was used to provide a Sports Racer look (it was peeling) · Wheels refurbed in gloss anthracite (new TPMS’s) with black and silver Lotus centre caps · Matching black and silver nose badge · Door striker plate refurb (what a pain, as I didn’t know there was a captive bracket holding them in place and it dropped - fortunately into the fuse box area on the passenger side) Cosmetic interior work: · The chrome surrounds on the air vents were all pitted so I sanded them down and sprayed them matt black · The gear gaitor was not attached to the centre console so I used some left over weather strip clips from my Elise to re-attach it · New rear view mirror as it didn’t have one (thanks ES Motorsport) · Use of Oyster leather dye on interior marks · Carpet clean etc. · Phone holder · Battery cover trim nuts Mechanical work: · Engine oil & filter change · Gearbox oil change · Brake fluid change · Clutch fluid change · Cleaned MAF sensor · Clutch pipe heat shield · New pollen filter · New spark plugs · Cleaned K&N filter · Brake discs and pads all round · Undertrays bolts replaced with stainless · Front ARB bushes (stopped a low speed clunking) · Gear linkage rose joints (massive difference to the fore-aft and cross gate slack in the gear change) · Trickle charger cables added to boot Jobs not undertaken by myself: · Replaced air-con condenser · New radiator and coolant (the garage noticed the existing radiator was leaking) · Replaced air-con compressor · Air-con recharge The air con fix was lastminute.com - the day before a 2,000 mile shake down journey to the Alps and back, where I discovered it had the close ratio gearbox (maybe it was a press car?). Thoughts from trip: It’s no Elise, but it really does come alive on the right roads, it sounds great (Janspeed exhaust, 3rd cat delete) and the brakes are great. The only real negative was that I feel it is very flat power wise under 4000rpm, but that did seem to get better over the 2000 mile 'Italian tune-up'. Required actions from trip: · There’s a slight shimmy (not vibration) in the steering at speed and under light braking (a front suspension bush?) Further planned actions: · Steering wheel spacer · Stainless steel mudflap brackets · Better Head Unit · A good underbody and wheel arch (suspension) clean up Then maybe I'll decide to keep it and add a CAI and new manifolds, plus in time when the clutch goes a 400 clutch and lightweight flywheel would seem logical. I've attached some images but failed to insert them where I wanted within the text... Ross
  3. Hi all, Just to update; the compressor had seized and following fitment of a new one and all is well. Can’t explain the drop in revs etc. when the a/c button was pressed, but 600 miles to the Alps yesterday and it seems fine. Ross
  4. Thanks Bob, The revs noticeably alter when switching the air con on and off, the gas was filled as per the spec in the service manual (I gave them a copy). Unfortunately however, the expansion valve and drier were not replaced which may come back to bite me... Ross
  5. Yes, to check for leaks - diagnosed as condenser leaking. It did look a mess of bulges and green stains. Now filled with refrigerant as per the service manual.
  6. Thanks, I’ll take a look when I can get under it. The other thing that’s been mentioned to me is the thermal expansion valve (TVX)?
  7. Hi all, I’m after some air con advice… It didn’t work when I bought the car (2009 NA) a month ago so I checked the fuses and relays and cleared all the codes with no success. I therefore took it to my local garage who diagnosed a leaking condenser by filling the system with nitrogen. They fitted a new condenser but still no joy (other than it now holds gas). I’ve cleared the codes again, as the spanner light was on, and now the compressor clicks in and out as requested but no cold air… Any ideas on where to look next? Thanks in advance, Ross
  8. Hi Bob, It is also Quartz silver, so I am guessing it’s one of the other three. There’s one launch edition badge with it, but it’s not attached so I’ll sort that. Ross
  9. Many thanks I'll speak with ES Many thanks. The seats are actually good - looks like they've had some work as there's oyster coloured overspray... The rest of the car is best viewed from around 10 feet
  10. Hi all, So... I've bought a reasonably priced Launch Edition Evora (pics attached) as big brother to my S1 Elise. However, being reasonably priced it does require a fair amount of TLC! Focusing on the mechanicals I will be changing all fluids (Engine, gearbox, coolant, clutch and brake), filters, spark plugs along with gear selector adjustment etc. But in addition to this I do have some stumbling blocks I hope I can get some direction on: - It has no rear view mirror (just the plinth). Any idea where I can get one from as I have drawn a blank with google searches? - The undertray will obviously be coming off for various bits of work, so following my approach with the Elise I want to renew all fixings as I remove them with stainless versions. Is there a kit of undertray fixings? - The aircon doesn't click in and this is in conjunction with the spanner light being lit for about 30 seconds on start up. As a starting point (read - cheapest potential fix) I intend to have the codes read and then cleared, does anybody have experience of fault codes related to air con? Many thanks in advance, Ross
×
×
  • Create New...