free hit
counters
e5pritV8's Content - The Lotus Forums Jump to content


e5pritV8

Basic Account
  • Content Count

    58
  • Joined

  • Last visited

Everything posted by e5pritV8

  1. Yes, there was one that looks like the original, I will order them from Walbro. That way I can get a short and a long one like the stock set up.
  2. Not the in line filter, I'm talking about the filter that hooks under the pump. I found some that fit but they are longer and are very annoying when putting the pump back in the tank.
  3. I placed an order for the hose and the fuel filters, we'll have to wait fo parts again!
  4. According to the SAE site 30R10 is for In-Tank, Low-Pressure, Uncoupled Fuel Hoses.What you are saying depends a lot on what application it is made for. This is what I had in mind: http://www.compperformancegroupstores.com/store/merchant.mvc?Screen=PROD&Store_Code=FS&Product_Code=30342-18&Category_Code= or http://www.gates.com/brochure.cfm?brochure=5091&location_id=541 BTW thanks for the material references, even though the document is in German, I can understand the info, but it takes time thanks again
  5. After a lot of reading about hoses, and for my own peace of mind, I will go for an R10 hose which seems to be more suitable for submersible applications.
  6. I've done lots of search a while back and thanks to Steffen from Ramspott & Brandt, I got my hands on the original pump's specs. The pumps I have installed now are the Walbro GSS340, you can check it out here: http://www.onlyfuelpumps.com/walbro-255lph-fuel-pump-gss340-400-812.html I was too concerned with the pressure specs of the hose and forgot all about the fuel resistance I just got a new hose with the following specs: 5/16" SAE 30R6KX. I'm still looking for the exact specs, I will try to get higher quality if possible (if I found any that is).
  7. Yes, these pumps are Walbro pumps, they have the same output capacity as the originals, but as you can see they don't fit the plastic pockets, and they cost about $100 each.
  8. The pumps are out and the hoses are completely ......melt down. I'm going to buy new hoses and a new fuel filter, just in case the melted parts went in the filter. any suggestions on the type and size of hoses? I'll attach some pics. http://www.thelotusforums.com/forums/gallery/image/2478-20130120-225513/ http://www.thelotusforums.com/forums/gallery/image/2477-20130120-225348/ It goes without saying that these hoses were not made for fuel use.
  9. The regulator is not the problem, I blocked the return line after the regulator and still was reading zero pressure on the rail. gonna have to pull the pumps out again I was really trying to avoid that, as it is not the most fun job to do. The sparks look good, I will give you an update once the pumps are out
  10. After a long business trip, and I got blessed by a new baby girl . I finally had time to work on my Esprit. So, I have spark for sure, but the fuel pressure reads zero on the fuel rails. I dont have the connection to test fuel coming from the pump directly, however, I really doubt the fuel pumps failed or that the filter is blocked! I think I will go ahead and change the regulator, then I we'll take it from there.
  11. Unfortunately, I am in a business trip. I will have to wait till I get back. The car did not fire at all, but now that I think about it, there was fuel smell after a couple of tries!
  12. I'll try that once I'm back, I doubt its the pumps though, They are less than 2 years old with only 1k miles. I pressed it. But the inertia switch should cut-off fuel, I will not hear the pump if it was tripped, am I right??
  13. My Esprit V8 has been parked for about a year, last week I tried to start the car but it is cranking only! It was working fine the last time I started it!!! So anyway, I filled the car with fuel, as I knew it had about quarter tank. I released the pressure from the fuel line, but only had a very weak spit of gas; I would think that if it was pressured properly it will spray quite good? I can hear the fuel pump when I put the ignition on, so it is not a fuse. The only work I was doing on the car was in the dash, I completely removed it, as I wanted to refresh the gauges and change
  14. Thanks, But I was looking for a topic that was started in 2005 by actwon! no worries, I guess it was removed. Thanks again.
  15. I've been away from the forum for a while, can anyone tell me where did the Parts Cross Reference List for the Esprit go??!!
  16. well I'm sure Lotus didn't think of that when making this set up ,any idea if this was fixed in later models??
  17. ok Joel, u will need 2 of the wallbro pump, the first pump is the primary one which works all the time ,the second one works only under high demand ,like full throttle and high speed more than 150 mph. The pump provides up to 140 psi and 255 Litre per hour, which is more than enough for the Esprit, I've used it for more than a year under all conditions and didn't have any problems with it so far. the engine demands from 45-70psi according to the workshop manual ,the flow of the stock pump is 4 Ltr/min which is 240 Ltrs/hr. I would post some pics but they r too big I will e mail them to
  18. About a year ago I was searching for replacement fuel pumps and with some help from Marcus and Brandit I found those Walbro fuel pumps its part number is GSS340 this is a link to some info about the pump http://shopping.lightningmotorsports.com/c...?productid=2031 I installed it with very small modifications to the plastic holder that holds the pumps in place, and I have lots of pics send me a pm and I will mail them cause they r too big to post in here, just make sure to get very high quality hoses and clams
  19. 1997 Esprit V8 (US specs) RED SCCFE33C9VHF65201 Mahmoud Sofrata, Saudi Arabia WHERE WILL THIS LIST BE WHEN IT'S DONE?
  20. we had one hell of a sand storm last week ,so I think that’s why the ABS was kicking fast, and yes I guess I've been too hard on the breaks the past days . now that the weather is back to normal the breaks r good. I'm planning on buying AP breaks and Sport 350 springs and shocks soon but I'll need some cash for the fluid ,I just renewed it . Thanks for the help guys Sofrata
  21. Jonathan, the pads r stock, the tyres r new stock size(Continental Conti sport) ,I did'nt check the geometry recently ,I'll do that as soon as my springs and shocks arrive. working fine! well, kicking in too early I could understand but whats with the burning smell? Sofrata Thanks
  22. Hey guys I was wondering, is there a refresh kit for the factory brake calipers or should I just buy AP ones? cause the sometimes I smell burn when I brake hard and the ABS comes in too early. Thanks
×
×
  • Create New...