free hit
counters
pasha2891's Content - The Lotus Forums - Official Lotus Community Partner Jump to content


pasha2891

Basic Account
  • Posts

    33
  • Joined

  • Last visited

Everything posted by pasha2891

  1. Thanks for the help Rod. I'll talk to JAE about the silicone hoses and go from there.
  2. Thanks, maybe I should just do it myself. I agree that any mechanic should be able to do it, I've just seen many get scared of touching the car and refuse to do any work on it. I'm trying to avoid having to take it to the official chicago land dealership because they're not open on weekends and weren't overly enthusiastic on doing work on the Esprit when I stopped in a couple years ago. I wish Fox Valley Motorcars was still in business. I also know about John Welch and he was great but always booked for months.
  3. Hi everyone, Wanted to take a shot in the dark and see if anyone knew of any shops in the Chicagoland area that would be able to do a inspection of the cooling system on an Esprit V8. I think I might have a small leak somewhere that's hard to nail down. Any help would be appreciated!
  4. Just to give an update, I'll most like go with the high flow cat and centre exhaust kit from http://www.pnmengineering.com/lotus-exhausts-v8.html
  5. Vulcan Grey, Vanya, Redshift thanks for the replies, very helpful. I'll post what I end up doing and how it works out, most likely sometime in the spring. It's winter here for a few more months. Not the best driving weather.
  6. Like the title says. I'm debating if I should replace just the muffler or get a whole new exhaust. I currently have the stock exhaust that came with the 2000 V8s. Maybe there's other options I'm not considering.
  7. Update ********* I still have an issue with the low beam (dip beam). I replaced the low beam (dip beam) relay, main beam (high beam) relay and the headlight switch in the dash but when I push the headlight button (with the high beams off) what happens is 1)interior dash lights turn on 2)headlight pods come up but none of the lights are on. Any ideas why the dip beam lights don't turn on? I'm starting to think that the dip beam relay wasn't the problem but maybe the contacts to it are broken. When I turn on the high beams, all four lights come on. Forgot to add, before the low beam lights stopped working for a couple weeks only one low beam light would turn on.
  8. Thanks for the replies mark and gunter. Haven't had a chance all week to mess with the car, hopefully I'll have some time this weekend. So you guys were right as always. Before swapping the relays: high beam: all lights on(high and low, I have the US spec car) low beam: nothing on As soon I swapped the main beam and dip beam relays. high beam: only high beams are on. low beam: only low beams are on but they are always on, even if the headlight switch on the dash is not pressed and the lights are lowered. So i'm guessing I just need to order a new main beam relay.
  9. Thanks, that's probably what it is since my switches in the dash are all brand new. Do you know where I can find a relay diagram for the v8 so i know which relays to swap. I'll try looking online to see if I can find one. Thanks again.
  10. So my problem is that the low beams don't come on when I turn on the lights but do come on when I put on the high beams when all two pairs of lights come on. Any ideas would be greatly appreciated. I'm thinking it's the headlight switch in the dash.
  11. Thanks for the suggestion Larry. That's exactly what I'm trying to figure out. If it makes more sense to repair or replace.
  12. Lucas, Thanks for the suggestion. I saw john's site I just didn't contract him because the website said he was out this week.
  13. The second gear synchro on my 2000 Esprit V8 needs repair. Wanted to see if anyone could help me find a shop in the chicago land area that would be able to do the work. Thanks for any help in advance.
  14. I'm in the states, in the chicago area. If you guys know any specialists around here I would appreciate it. I know there is a lotus dealer in the area.
  15. Hi everyone, so I'll try to be as specific as possible. With the engine running and normal driving every gear works fine except second gear. With the engine ideling going into second there is a very small crunch but barely noticeable. Once in second gear, starting the car in second from a standstill works fine. If the car is standing and in neutral, clutch engaged(pedal up), I rev up the engine then push down the clutch pedal and try to shift into second then loud crunching noise, I can't even get it into gear(I was too scared to try to force it). Also if I turn off the engine and leave the car in second and try to push it, the car won't move. Lastly downshifting from third to second while in motion causes a loud crunch. From one of the post suggestions here, I tried reversing with the handbrake on to give it some torque incase the second gear synchro was stuck but that did no good. I'm not an expert but from reading the forums I'm thinking that when I'm shifting into second gear the reverse gear might be getting hit. Any help on diagnosing this before I take it to the dealer would be very appreciated. I have a 2000 V8 if that's relevant.
  16. Tried searching the forum, but had a hard time finding any topic. Will any battery do or should I be looking for something specific? Not to be talking to myself, but found my answer in this post. http://www.thelotusforums.com/forums/index.php/topic/25798-battery-guru-please/
  17. Great, thanks a lot, exactly what I was looking for. I'll just order it from the dealer, seems like the easiest route.
  18. Like the title says, anyone know where I can order the clear hose that goes from the header tank by the engine to the reserve to tank in the rear right wheel well? Thanks for any help.
  19. When this happened with my 2000 it was because the hose clamps were not tight enough to form a complete seal.
  20. Yeah I've been working as a software developer for some financial companies around the area since I was 20. So I was able to buy some real estate right before I finished college and make a really good return on it. That's where most of my money for the car came from. If I got to grad school it will be for an mba. I don't think getting a masters in computer science is the way to go for me. Not enough return on the time/money invested. Anyway, no matter which one you get you'll get used to having it. But it will still be fun everytime you take it out.
  21. This thread is a good read. I'm 23. Bought my 2000MY V8 a year ago at an auction in Wisconsin. I paid in cash for the car from working and a good real estate investment. I've spun out once in it, and unfortunately went up on a curb that ripped off the front plastic spoiler and made a small crack in the front bumper by the foglight. I have yet to replace either since they don't seem to be having an effect on the car. I'm sure I'll get around to it by spring. Anyway, it's nice to see there a few people that bought a esprit in their 20's. I think it's a good experience to have a car like this younger so you don't get an urge for it as a midlife crisis . Paul
  22. Thanks, I'll try swapping the switches. It's nice I can afford to take my time with this since winter has started in Chicago and I won't be driving it much till Spring, except the occasional run to keep it from sitting too long. If it was warm out I would be a little more anxious.
  23. Last night when I got home from a nice drive I ran into a little problem with the headlights. When I pushed the headlight button to lower/turn off the lights, the lights turned off but did not lower. Now, when I push the headlight button nothing happens. Only when I push the button and hold it in as far as it goes, do the head lights turn on. But as soon as I let go, they go off again. The button does stay in the on/off position like usual and switches just fine. It's just that the on position does not leave the button as far in as when I hold it in. Hence, why I have to hold the button with my finger for the lights to stay on. Needless to say, it is not practical . My thoughts are that either the contacts or the switch is broken somehow or a fuse blew, but I'm by far not an expert. Has anyone run into this before? Thanks for any help in advance. Paul
  24. Dan, Thanks for the description, that's a lot more detailed than I was able to find anywhere else. I'm probably going to attempt it this weekend after I get my car back from my navigation system install . Nathan, Thant's a good point, I haven't heard of the light going off because of air. I'll keep that in mind incase the light still stays on after cleaning the sensor. Thank you for your help also. Paul
×
×
  • Create New...