free hit
counters
mattthesparks lotus esprit's Content - The Lotus Forums #ForTheOwners Jump to content


mattthesparks lotus esprit

Basic Account
  • Posts

    384
  • Joined

  • Last visited

Posts posted by mattthesparks lotus esprit

  1. Hi Guys and Gals, I'm back. It's been a long time since I've posted (life just got in the way and personal stuff) anyway last year a good friend of mine asked if he could use my Esprit for the beginning of his show on YouTube. So I said yes. Here's the video it starts straight after the recap titles so not long to wait before it starts. His series starts every episode with a different classic car so worth a watch if your board on YouTube one evening. 

     

    Ps my Esprit has a SJ sports cars exhaust fitted so you can hear what it sounds like in the video if your looking for one! 

     

    • Like 2
  2. Saw today a S3 turbo esprit May of not been a turbo one, on trade plates with the split rims with gold centres (Think they are BBS ones)

    The colour was I think vulcan Grey (which I though they only did on the Stevens cars) or a dark green or maybe a dark grey. It was gone in a instance. He was really hammering it ( hope it wasn't a customer's car lol) 

    Anyway sounded really nice and looked very tidy. 

     

    Sorry no pic as was driving. 

  3. If your still having issues the best thing i can recommend is to check if you have the restrictor fitted inline of the pipe to the distributor if not you may be over pressuring the advance timing i think it should be 20º its only for increased driveablity untill warm, if you by pass the pipe from the TIV valve  to the 4 way adaptor as pictured. Then it will only run at 10º BTDC should make the car drive less iffy.

    Good luck. 

    Screenshot_20160801-220100.png

  4. Ok guys thanks for everything. Just thought I'd update you on things iv fixed the issue it was the over boost sensor, the actuator was set to over boost this in turn was tripping out the over boost sensor for a split second cutting the power to the spark so as it reignited the spark the extra fuel that was still In the car backfired out hence the popping and jerking in the car.

    All sorted also on my tinkering day found a vacuum leak in the Y piece from the vac pump onto the hard plastic hose. So replaced this and some of the oversized silicon pipes which were not sealing ok. 

    Now help is required again. Only on cold running before the car is warm do I find that going up any kind of hill the car is popping and appears to have no power what so ever. It seems to jerk like  kangaroo while trying to get up the hill. Any ideas or is this normal while it starts to warm up? 

  5. Thanks red vtec I will have a look iv arranged to meet up with Mike and compaire issues lol. The popping I know you get on over run but I'm getting it when pulling up the lower side of the revs and at motorway crusing speed as the turbo sort of kicking in and out at 70mph on that sort of 2800 revs and 3100 revs . It's like it's being starved of fuel! Ahh bloody annoying! 

  6. Hi Guys help required does anyone live round the Sussex/ Surrey Kent way who knows about dellorto carburetors iv be told so many different things not sure what is the problem or correct. 

     

    4 years ago I bought my carb turbo Stevens car with a rebuilt engine. And the guy told me he didn't know anything about the carbs just unbolted and 're bolted them back on after the rebuild, however I have had problems with over fueling and pops and bangs from day one.

    Now sparky gave it a quick tune up and balanced the carbs and it ran better, however I have since discovered a cracked manifold and a hole in the exhaust but not before the MOT guy fiddled with it to pass emissions and never set it back. Now both been rectified but the carbs are now running worse! 

     

    Recently someone told me that it's running too rich so I tuned it with an gas analyzer which was better but the poppping and jerking was still there, all jets have be cleaned and unblocked but still the popping is there. 

     

    Someone last weeks said I had the o rings crushed on the carb connections to the engine so do I need them to slightly float? If so can someone come over and look to tell me what I'm loooking for and help me balance these carbs if thats also an issue.

     

    Please Help Matt. 

     

    I have also posted on the Stevens page please could you reply to the link to that page. 

    http://www.thelotusforums.com/forums/topic/76141-help-required-on-my-carb-turbo-dellortos/#entry588961

  7. Hi Guys help required does anyone live round the Sussex/ Surrey Kent way who knows about dellorto carburetors iv be told so many different things not sure what is the problem or correct. 

     

    4 years ago I bought my carb turbo Stevens car with a rebuilt engine. And the guy told me he didn't know anything about the carbs just unbolted and 're bolted them back on after the rebuild, however I have had problems with over fueling and pops and bangs from day one.

    Now sparky gave it a quick tune up and balanced the carbs and it ran better, however I have since discovered a cracked manifold and a hole in the exhaust but not before the MOT guy fiddled with it to pass emissions and never set it back. Now both been rectified but the carbs are now running worse! 

     

    Recently someone told me that it's running too rich so I tuned it with an gas analyzer which was better but the poppping and jerking was still there, all jets have be cleaned and unblocked but still the popping is there. 

     

    Someone last weeks said I had the o rings crushed on the carb connections to the engine so do I need them to slightly float? If so can someone come over and look to tell me what I'm loooking for and help me balance these carbs if thats also an issue.

     

    Please Help Matt. 

×
×
  • Create New...