free hit
counters
Finlandese's Content - The Lotus Forums - Official Lotus Community Partner Jump to content


Finlandese

Basic Account
  • Posts

    220
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by Finlandese

  1. Channeling Miami Vice via my Esprit S2. https://youtu.be/3ozSQvOLR_s
  2. Actually, no press was needed. Just locking pliers the ease the stud out.
  3. After using the hacksaw… Still need to press the stud off.
  4. Thank you, that is a very good write up and LEW guides are must read material for diy Esprit owners. Most learning is by trial and error. I much learn from other peoples experiences… First step of any new job is trying to learn from other who have done the job privously.
  5. Turns out I was. The bearing came off easily with the press. The next problem is removing the lower link stud to replace the bushing. The good news is, it is not fused to the hub carrier.
  6. Now returning to the UJ saga. This time with the outer one as the suspect. Funnily enough the drive shaft came off easily. Will I be as lucky with the bearing?
  7. Oil pump is in place, but I sm having an issue with the intake coolant hose running next to it. I decided to change it, but the replcement part from SJ’s is a straight hose, unlike the one that I had on it. Tried to put on anyways, but it kinks pretty badly, so that won’t work.
  8. Fixed with a new shaft and sprocket. No wiggle, nor contact, but the margin seems a bit tight for me ( maybe less than 1mm)…
  9. It seems that I have an Esprit 907 oil pump with an Excel sprocket. The fit to the auxiliary shaft is quite loose. Is that because these parts are mismatched, or due to the wear of loosely fitted sprocket? Does 912 sprocket with to the 907 auxiliary shaft?
  10. The mystery is beginning to unravel… The point of failure beng the dear PO who had not cleaned the sprocket bolt hole and therefore thought that the bolt had been tightened all the way. It was not and the play had started to eat in to the shaft, sprocket and the wedge.
  11. Light knocks with a hammer, and a bit of levering and it came off. The sprocket bolt needs more persuading. Letting it soak on wd40 for the night.
  12. Trying to get the oil pump off. All bolts are off, timing belt, distributor and the oil cooler is off. Why isn´t the pump coming off? More force? After that, the mystery of the coolant lying on the block…
  13. There was a bug with youtube, that left it running on sd indefinatly. I re did the uplaod and then replaced the old links with the new one. Facebook doesn´t want to for get the old one, so it keeps loading up the old (inactive) screenshot link, even though the link is new (and working). Maddening...
  14. Hmmm.. Works fine for me. Is anyone else having problems?
  15. And a little video of a planned larger project:
  16. Still shot from video project I am making
  17. Thank you for your advice. We checked the timing and it was still correct. The cam markings lined up perfectly at the TDC.
  18. Had trouble starting the car and when it started, it had an intermittent jerk while driving, that felt like it was ignition related. Noticed that the distributor cover had come loose. After putting it back on car started normally, but now my friend, who was observing the start in the engine bay, noticed a tapping sound coming from the front of the engine. After a while we noticed the chafing ignition sprocket and shut off the engine. I remember hearing a similiar sound previously. I assumed it was the hydraulic tappets, but of course I should have remebered that the engine does not have them. I added oil and the sound went away.
  19. What the hell is going on over here? The sprocket is loose but the bolt doesn’t move. The washer below the bolt is loose. You can turn the shaft about 20 degrees, even though the sprocet is held in place by the timing belt. Help!
  20. Trying to minimze the engine mount wear. Engine stabilizer based on the Kiyoshi Hamai’s design, with a bit of further simplification.
  21. I got the main beams now. At least for now… And I got the horns working too! In any case, I have never needed them for getting other traffic to make way, since they seem to make way just get a better look of the car anyways! The public loves the Esprit and all reactions are respectful and positive.😊✌️
  22. Finally on top of things. Rear lights had grounding issue. Reverse lights just required a proper (full) selection of the reverse gear. Side indicator had a bodge in the front trunk. Now I just need to get the horn working…
×
×
  • Create New...