free hit
counters
HowardRoark's Content - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


HowardRoark

Full Forum Member (FFM)
  • Posts

    177
  • Joined

  • Last visited

Posts posted by HowardRoark

  1. Hello all, 

    i have a new 2020 Evora GT with 1400 miles on it since July.  In the last 50 miles or so, the clutch started to feel different.  Instead of feeling really smooth when the clutch pedal is depressed, the clutch has a ”grindy” rough feel to it now.  The grind/rough feel is correlated with speed/load.  It feels smooth at idle when simply depressing to shift into 1st gear, but feels rough at higher RPM when depressing the clutch pedal.    I am about to take the car in for my first ever oil change.   Should I be changing the transmission oil a well?   Anything else that would cause this rough clutch feel?

    cheers

  2. 1 hour ago, CarBuff said:

    Dexcool was the original fill. 😣

    Thanks Atwell.  I’ve heard that Lotus USA has recommended DexCool,   Do you know if that is correct?  

    And how do you like the DexCool product, if you are familiar with it?

    Any other recommendations on coolants for the V8?

    Makis - yes I had an upgraded Aluminum Radiator installed when I had the entire engine rebuilt a couple of years ago.  I live in San Diego and my car performs very well in the warm weather.  While driving, it stays right at the 88* mark or a bit under on cooler days.

    Pics of engine rebuild and the old radiator.  I’m happy with the upgraded one.

    cheers

    E98BA898-BC5A-4870-92E2-C040CC96921B.jpeg

    1B31EC71-6815-44EC-92E7-2CEC94956E4E.jpeg

    98FD67E6-A118-44DF-A789-9A2D939F18CC.jpeg

    994926B2-15E4-46D7-999F-F8CCDFB9E2E6.jpeg

    • Like 2
  3. Hi all,

    1999 Esprit V8 in the US, California.   I am going to top up my engine coolant, and I wanted to see what product the V8 owners are using.  I would ask the tech who last serviced my car but he does not work at the shop anymore where I last took the car.

    My coolant in the car looks to be orange in color, I took a bit out of the header tank.  I am guessing this is Zerex, either DexCool or the G05 in the gold container?

    cheers

    F3F32599-FEA6-4B57-8FC4-2F6E71420E44.jpeg

    F8FD5406-5F1C-49A6-97CC-F22B519E15DB.jpeg

  4. On 17/07/2018 at 12:30, Blackngolds3turbo said:

    I need to brighten up the interior in the v8, does anyone have any information about the colours you could have the interior in?

    are there colour names/codes that I can trace?

    planning to recolour various bits, so recommendations on dyes/products would also be useful!

    thanks!

    Here are options but they are from the SE.   My V8 is Magnolia and Monaco White.

    E540474C-EA03-45E4-B43B-32F942FDA150.jpeg

    962A2BC5-76D6-4A0F-8FEB-033E73BE001C.jpeg

  5. Hello all,

    i was watching a video about an 87 HCI Turbo, and the chap pulled on the boot lever, and the boot popped up automatically, I assume because of the strong hydraulic struts.   I have never seen this happen before, because when I pull the lever on my ‘99 V8 (USA) the boot just pops up about 2 inches, and then I manually lift the cover open.

    My question is - did the boot on certain models pop up automatically?  Or is this just a mod with much stronger struts attached?

    I would love to see if this can be done on the V8.

    cheers

    7487AA1C-EF4C-483C-BDBD-6FF32F39EF49.jpeg

  6. Hi all, my tech has checked the exhaust and there doesn’t appear to be any leaks.

    Question  -  would a faulty Waste Gate valve cause some backfiring, by letting too much gas back in the exhaust??  I am wondering if it could help with the issue?  As I understand it, the WG prevents too much boost going back in when you let off of the throttle, and my car does backfire when I do let off of the throttle.  Are these related?

    cheers

  7. Hello all,

    I recently had my 918 engine completely rebuilt, and it has driven very well for about 4,000 miles so far, but it has started to backfire a bit when decelerating.  It normally does it when I take my foot off of the throttle.  It is quite loud and sounds like the crack of a gunshot.  It never backfires when accelerating.  

    When accelerating in 2nd gear, there sometimes is a very slight hesitation in acceleration, but not sure if these two issues are related.   

    Also, when idling, it sounds smooth, but there is sometimes a very faint “poof” sound.  Not a distinct pop, but very faint and intermittent.

    I know some owners will say that the backfire/ popping sounds are normal, but I do not think it is normal, and I think it can be fixed.   Any suggestions on what to check or change?

    cheers!

     

    8E20935F-1D64-4EE4-86CA-455A8CBD6DB1.jpeg

  8. Hi Wayne,

    I have a lot of empathy for you buddy!!   Hang in there.     My Update:  V8 Head Gasket sizing issue.

    I also just had a head gasket fail after 1,000 miles, with coolant leaking.  My tech couldn't believe the failure, because he is a very accomplished Lotus tech here in San Diego, and he has rebuilt hundreds of engines.   He took off the older V8 gaskets and measured them.   He got some new head gaskets from SJ Sportscars (I believe), and I think he said the new ones were perhaps 2 mm difference in size, and that the new ones were in fact the correct size, according to OEM spec. 

    So here is a question for all of the recent V8 head gasket failures - are you sure that your gasket is the OEM size and spec?   My engine is now back together and I have put a couple hundred miles on it, so good so far.   I will keep you updated but the engine is performing well after the switch in gaskets.  I think that SW Lotus Centre is also marketing a new gasket that is done to the original Lotus OEM specs.    Hopefully that is a cure to these failures. 

    Cheers

    IMG_6312.PNG

×
×
  • Create New...