free hit
counters
S4s rolling restoration project - Page 22 - Esprit 'Project & Restoration' Room - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

S4s rolling restoration project


Recommended Posts


Upgrade today to remove Google ads and support TLF.
  • Gold FFM

Not yet Ian, but it's the next thing on the list to do, alongside fitting Dave's suspension kit.

Now the car is running I want to spend some time in the "rolling" state over the summer to just enjoy it, rather than spending more time in the "restoration" state that it's spent the lion's share of its time with me in.

  • Like 2

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

9 hours ago, tomcattom said:

The cars and coffee meets are getting more and more common. There are some during the week, typically in the evenings. Never been to a weekday one myself, they're never close enough for me to make it worth driving to them after work. This one was a Saturday morning and very close by, so was convenient :)

(indeed before I edited my post I was surprised there were cars and coffee meets even during the work week ... that was until I realized you posted about this on Saturday, hence why I edited my post ^^. Anyway, thanks for the explanation since it appears there actually are car meets organized during the work week!)

Edited by Giniw
Link to comment
Share on other sites

Hi Tom,

how satisfied are you with the Nankang tires? I also need a new set of tires soon and I've shortlisted the Nankangs too, but I don't know if they really go with the Esprit!?

Best regards

Stephan

Link to comment
Share on other sites

  • Gold FFM

I can't give a full verdict yet @Chefchen, I've only done 420 miles on them and due to the tracking still not having been done I've not really dared fully push the car yet, but initial impressions so far are positive in dry conditions at any rate. My friend who put me onto them in the first place is impressed with them on his TVR Cerbera too.

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

  • Gold FFM

Another 12 months ticket on the car as of last Thursday, but it wasn't all plain sailing. On the way over to the test centre I noticed it had started to idle at 1500rpm. Luckily when I restarted it at the test centre it was back to normal, until I left and then was idling nearer 2000rpm on the way back. Fortunately I had my laptop with me and Espritmon revealed I was seeing around 10% TPS input without my foot off the throttle.

I spent a bit of time inspecting further with Espritmon today and it was seeing 0% with no throttle, but at full throttle I was barely getting over 80% registered, this despite me setting everything up properly when the new throttle cable was installed in the Spring. I decided to check the throttle cable setup first, I remeasured the clearance at the full throttle abutment on the throttle body and that was measuring the 0.1mm as per the guidance in EMH.3, so clearly the throttle cable is all fine. Luckily I had bought a spare TPS from RockAuto when I imported the new ECM last year so I put that on and immediately everything is reading correctly again and I have full swing from 0 to 100% showing in Espritmon. Nice quick fix thankfully.

Next on my list was the pesky boost situation again. I reinstalled the wastegate actuator solenoid before the cars and coffee meet a couple of weekends ago and on the way there and back I noticed I was getting over 1 bar of boost at barely half throttle again. Checking with Espritmon earlier in the week showed the MAP sensor maxing out at about 50% throttle. I'd previously tested the operation of the wastegate solenoid before I sorted the actuator setup, but clearly between then and me reinstalling it now its gone bad and got stuck bleeding the air off the actuator constantly, resulting in uncontrolled boost (up to a point) :o and this despite Espritmon showing the WGDC triggering. I tested the solenoid with a battery today and no signs of life from it now, so I've got a new one on order from the US. They're about £120+VAT from the usual suspects in the UK, if they have them in stock. Got one from the states for $64; at about half the price I'm prepared to wait the week or so it will take to be shipped here!

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

Thanks for your impression on the Nankangs. Since I'm not planning to drive my Esprit on the track, I'm still wondering if these tires are the right ones for me, since they are a kind of semi slick and therefore may be too "extrem" for the road!?

Concerning your idle problem - had the same behavior on mine. I put my TPS in isopropanol for an hour or so and reinstalled it - everything fine again and no idle problem any more since then (for over one year now). So may be you can do this with your removed TPS and have a workable spare part again 😃

Link to comment
Share on other sites

  • 3 weeks later...
  • Gold FFM

Luckily I haven't thrown the old TPS away, so I'll give the IPA and see what it does @Chefchen.

New wastegate solenoid turned up today so been out and fitted it this evening and gone for a run in the evening sun.

PXL_20220708_171053561.thumb.jpg.17807884d008235cb50d83dc8949a660.jpg

 

I can't be totally sure the new solenoid has fully worked yet, the boost gauge decided to crap out on my while I was out for the run and I failed to take the laptop with me :( That said the boost did feel like it was being delivered in a more controlled manner than it did before. I'll go out for another run over the weekend and see what Espritmon makes of things now.

PXL_20220708_172322950.thumb.jpg.36ba9732347560ff654576922e9f39f8.jpg

  • Love 1

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

  • 3 weeks later...
  • Gold FFM

I hadn't reset the BLM, but I have done so today following the installation of the new IACV.

  • Like 1

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

  • 2 weeks later...
  • Gold FFM

In the last few weeks several new components have been fitted to the engine in the pursuit of resolving recent stall on initial start from cold. You can follow the ongoing progress of that here:

 

After changing a few things, including the injectors, IACV, vacuum hoses and rear non-return valve, today I have fitted a new fuel pressure regulator and the first start has showed encouraging signs, if not convincing me that it's 100% cured, but hopefully a few more cold starts to build confidence will convince me its cured 🤞

PXL_20220809_132604502.thumb.jpg.15731325a18dd5f7eb36fbf6a279dc80.jpg

PXL_20220809_132630293.thumb.jpg.a5277a0c20899adb227e8e82cdfa0bac.jpg

  • Like 2

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...