free hit
counters
Engine MIL lamp on after battery change - Engine & Ancilliaries/Gearbox - The Lotus Forums Jump to content
Whitey

Engine MIL lamp on after battery change

Recommended Posts

Just swapped the old dead Varta out for a new E38 one and fired the car up which started instantly but the spanner light remained on together with the MIL. After 20 secs the spanner light went off leaving just the MIL on. I reset the windows and let the car just tick over for a few mins but the MIL remained on. So is this normal and is it likely to go out after a short run - anybody had this before?  Car sounds fine and everything else seems good.

Thanks,

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

Have you got an OBD reader? If so, read the code, make a record of it then delete it. Start the car again and if the code comes back, investigate further. If it doesn’t, peachy. 

Share this post


Link to post
Share on other sites

Update: started up today (4th start since battery swap) to go for a run and fuel and the light is now off  :)  I do like problems that fix themselves and the car is going superbly well!

Also didn't need to recode the Alpine 920 which was a bonus.

 

Share this post


Link to post
Share on other sites
On 15/06/2019 at 16:40, Whitey said:

Update: started up today (4th start since battery swap) to go for a run and fuel and the light is now off  :)  I do like problems that fix themselves and the car is going superbly well!

Also didn't need to recode the Alpine 920 which was a bonus.

 

If a fault code isn’t thrown again after 3 starts the MIL light goes out.  

Just a note for owners of IPS cars, resetting fault codes with a non lotus OBD reader can lock out the transmission. 

I found this out on Friday morning.  Couldn’t select a geaf and couldn’t remove the key.  Only fix is disconnect battery.  

Share this post


Link to post
Share on other sites

Ive read and reset the codes on my loads of times with vagcom in OBD mode and Torque OBD check on my phone without any issues.

Gav

Share this post


Link to post
Share on other sites

Done mine without issue too and with the blessing of the main dealer

Share this post


Link to post
Share on other sites
17 minutes ago, Colin P said:

Done mine without issue too and with the blessing of the main dealer

Yup.  But occasionally it causes an issue.  

As advised by Lotus. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...