free hit
counters
1. Cold start 2. Speedo 3. Doesnt start - Engine/Ancilliaries - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


1. Cold start 2. Speedo 3. Doesnt start


JanS4s

Recommended Posts

Hello,

have some problems with my s4s. 

1. Cold start 

- when i start - RPM will increase to 2000. Why? 

2. Speedo is working on table but when i put it back to car it doesnt. 

3. Start the car 3 times in an hour but after that want to start it again and nothing.. engine want but seems like no fuel but injection and everything is new..

 

 

thank you guys 

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
  • Gold FFM

I'm still a relative newb to the Esprit but with regard to the idle issue, that might be an effect caused by the throttle Jack and EBPV operating, assuming they're fitted still. Unless someone more knowledgeable wants to correct me on that.
 

I can't offer any thoughts on the other two issues I'm afraid.

 

  • Like 2

Norfolk Mustard S4s #1 :)

Link to comment
Share on other sites

13 hours ago, JanS4s said:

Hello,

have some problems with my s4s. 

2. Speedo is working on table but when i put it back to car it doesnt. 

Sounds like either the generator on the transmission isn't generating a signal or it is but it's not reaching the speedometer because of a short. 

  • Like 1

Cheers,

John W

http://jonwatkins.co.uk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...