free hit
Speedo/tacho constantly sweeping up and down, no other instrument lights - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums #ForTheOwners Jump to content

Speedo/tacho constantly sweeping up and down, no other instrument lights

Recommended Posts


Today I unlocked my Elise S (S3), got in, turned the key, and... lights on the instrument cluster at all. But the Speedo and tacho started swinging from 0 to about the 10 o'clock position and back to 0, about once every 3 seconds. The  odometer display was completely dead. So I started it anyway (suspecting boring would happen and a dead battery was the problem) and it turned over rapidly and sprung into life. I drive a short trip (2 miles) and everything behaved perfectly - except the instruments which remains the same - both needles sweeping and no other lights at all. I got to my destination and switched the engine off... The sweeping needles continued. I got out the car and locked it... Still the needles continued sweeping. Any thoughts on what on earth is going on?

Thanks in advance for any suggestions!

Link to comment
Share on other sites

Upgrade today to remove Google ads and support TLF.

About 4 hours later, I went back to the car, and before I unlocked it thought I'd check if the needles were still doing their dance - they weren't, but the yellow check engine light (cog with a ! in the middle) was illuminated. I unlocked it and started it as normal, but, as expected, none of the instruments illuminated or worked. The lights worked ok and the car ran perfectly - just nothing but the check engine light in the instrument cluster. The tacho/speedo needles did not move at all from their zero positions, and the odometer LED section did not illuminate at all. I drove the ~2 mile trip home very very gently in case there was some major problem that would be exacerbated by anything enthusiastic - not that I'd do enthusiastic driving before the engine warmed up - the 'cold engine' light was not illuminated of course!

The car is under warranty so I'll call the dealer when they open to see what can be done. Just thought it'd be interesting to hear if anyone else has experienced something similar. I've trawled through this forum and elsewhere, but can't find anyone having the same problem.

(It did occur to me that I should shoot some video of the erratic speedo/tacho behaviour; my nephew recently requested that I shoot some video - while driving 😮 - showing the speedo and the rapid acceleration. I declined of course, but thought the speedo going from 0 to 80mph in about 1.5 seconds would make for some interesting viewing for him!)

Edited by Hello Paul
Link to comment
Share on other sites

I had a very similar thing happen in my previous V6 Exige. The needles just swung around the dials, but in my case I had every instrument light illuminated and the lcd display would flash on and off every few seconds. The car started and drove absolutely fine.

Lotus replaced the instrument pack under warranty and the dealer was able to program in the previously recorded mileage.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...