free hit
counters
Low Coolant Level Sensor Probe - Interior/Exterior/Lights/Glass/ICE/HVAC & Other - The Lotus Forums Jump to content
Grizzly

Low Coolant Level Sensor Probe

Recommended Posts

Hello

I want to fit a low coolant level sensor probe (because of bad experience with my Europa S2). SJ have a picture of a probe and grommet that fits into the reservoir tank - looks simple enough to fit if it will. I think this was meant for the two tank reservoirs fitted to Esprits and not to the Elite / Excel reservoir. 

My preferred solution is not to go there anyway but to fit a modern electronic system with the probe fitted in the top radiator hose. Any recommendations or experience of these?

Thanks

 

Brian 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

If you can't find an electronic way to do it the original system does work pretty well.

Pete

Share this post


Link to post
Share on other sites

I'm pleased to know that, Pete. However, the Excel I took my wiring loom from did not have the low coolant level module and probe factory fitted. As I understand it this was only factory fitted for cars destined for hot countries - hence why Australian web sites keep popping up on Google search.To fit the original system I would have to rewire the loom - and drill a hole in my reservoir. I want to leave well alone so I would prefer to fit a modern system with LED or audible alarm

Share this post


Link to post
Share on other sites

I think all late ('89 MY on) Excels had the coolant level sensor fitted.  My car was a 1988 but 1989 MY and it had one fitted.  You need section MH in the wiring diagrams to wire it up.

Pete

Share this post


Link to post
Share on other sites

Just to support Pete's comment above, my '92 SE, with a twin tank has the coolant level sensor fitted.

Share this post


Link to post
Share on other sites

Thanks Pete, Tony,

I've got hold of a twin tank (reservoir and overflow) and it has the coolant level sensor fitted. My Excel had the single tank and that was why the coolant probe was omitted in the wiring loom

As Pete says just follow the wiring diagram to complete

Another problemette solved

 

Brian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...