free hit
counters
Komotec EX460 kit and O2 sensor cables - Engine & Ancillaries/Gearbox - The Lotus Forums Jump to content
TBD

Komotec EX460 kit and O2 sensor cables

Recommended Posts

Since moving to France I've been supporting Daniel in helping several French customers with the Komotes EX460 kit.

Several kit owners here have had serious engine failures following installation of the kit, failures evidently not previously experienced on other Komotec installations  (one particular French dealer seemed to have had a penchant for failed installations) . However, we have meanwhile been able to trace the fault to a simple, but catastrophic installation issue regarding the O2 sensor cables

It is of utter importance that the before-cat O2 sensor cables are correctly connected to the correspondign left and right engine banks!

Interchanging the cables will lead to a rough engine, probable cat failure and potentially burnt pistons. A returning MIL light is a good initial indicator, monitoring the sensors would confirm wrong readings.

Unfortunately it is easy to interchange the cables because the sensors are relocated with the kit and the extension cables are identical.

  • Like 1

If you have the choice between a Stairway to Heaven and a Highway to Hell don't forget the Nomex®!

Captain,  Lotus Airways. We fly lower! 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Screenshot_20191012_155100.jpg

  • Thanks 1

If you have the choice between a Stairway to Heaven and a Highway to Hell don't forget the Nomex®!

Captain,  Lotus Airways. We fly lower! 

Share this post


Link to post
Share on other sites

One of several reasons I believe it's best to go direct to Komo-tec for installation of one of their kits. 

  • Like 2

Share this post


Link to post
Share on other sites
16 minutes ago, GFWilliams said:

One of several reasons I believe it's best to go direct to Komo-tec for installation of one of their kits. 

+ 1 :thumbup:

Share this post


Link to post
Share on other sites

My Exige cup 380 had a complete engine failure at the track after a correct 1500km engine run in and oil change ant the car was all standard except the auto blip module and a k&n panel filter.

It was changed at only 2400 km not under warranty as there was an old record of a mishift to higher rpm peak at 7800 rpm (weeks before the failure)

A complete new oem engine was ordered from Lotus and again correct run in of the engine and oil change.

Some Lotus tuner told me that if used on track the pistons would probably brake...

I then fitted the Komotec 430 kit and the car was working really well and I did a trackday without problems...

some weeks later I went to Komotec and they upgraded it to the 460 kit and even if it was working well it was not really feeling better than before and even a little weaker in the midrange.

They had to replace a faulty oem o2 sensor while there...

I asked about oem pistons to a komotec mechanic and he took a broken oem piston to let me see where they brake and he tought that only a few cars would brake but not depending if oem or with power kit...

After only two trackdays (the car started to slightly smoke black from exhaust just before) one oem piston broke...

I don t tink it s because of the Komotec kit just that the oem pistons on the newer models are bad quality

Now I just had the engine rebuilt with fordged conrods and pistons but the tuner that did the work noticed that both pre cat lambda o2 sensors make an error and should be changed

I did not ask him to look if they were plugged right but as Komotec installed them I would think that they are not switched

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...