free hit
counters
What all went bad on my 2000 V8 - Engine/Ancilliaries - The Lotus Forums Jump to content
v8GTmac1

What all went bad on my 2000 V8

Recommended Posts

 Thought I would make a history and a checklist for me to reference in order of occurrence   

 

 Bought the car with  leaking liners and broken oil pick up pipe  at 42k miles

3 broken exhaust studs on the left head

 Thermostat O-ring stuck inside the head 

1 1/2 yr long engine rebuild later  has all new belts and pulleys along with new Bosch injectors and and FPR

Recharge AC works good so far

Only getting 5 psi a boost

 Axle seals leaking roll pins are stuck 

 Coolant bottle pressure Leaks 

difficulty adjusting throttle cable for WOT

 1/2 of one coil pack dies

At least one coil igniter in the ECU dies

 Alternator stops charging 

 Convert to  A standalone ECU

 Heater appears to not work 

Engine dies when fully warmed up hard time re-starting till it cools off

 Power windows are slow  

 Left headlamp motor gear noisy 

ABS light on

funny noise from behind the Dash

 

 

 

 

Edited by v8GTmac1
  • Like 1

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

How about a collection of mangled bits of steel and ali that used to be pistons, rods and gearbox internals. I bet there's an owner somewhere who has those hanging around, else there will be some soon somewhere.

Share this post


Link to post
Share on other sites
20 hours ago, v8GTmac1 said:

 Thought I would make a history and a checklist for me to reference in order of occurrence   

 

 Bought the car with  leaking liners and broken oil pick up pipe  at 42k miles

3 broken exhaust studs on the left head

 Thermostat O-ring stuck inside the head 

1 1/2 yr long engine rebuild later  has all new belts and pulleys along with new Bosch injectors and and FPR

Recharge AC works good so far

Only getting 5 psi a boost

 Axle seals leaking roll pins are stuck 

 Coolant bottle pressure Leaks 

difficulty adjusting throttle cable for WOT

 1/2 of one coil pack dies

At least one coil igniter in the ECU dies

 Alternator stops charging 

 Convert to  A standalone ECU

 Heater appears to not work 

Engine dies when fully warmed up hard time re-starting till it cools off

 Power windows are slow  

 Left headlamp motor gear noisy 

ABS light on

funny noise from behind the Dash

 

 

 

 

I think I can top that !!

When I bought my car in summer of 2018 I expected to change some things, but apparently everything needed to be replaced !!

The first major service showed that we needed to overhaul the suspension and cosmetically remove signs of rust on springs and suspension components.

We replaced all 4 shock absorbers with new Bilstein as the factory recommended.

We removed all parts of the suspension and springs and sent them to be sand blasted and repainted in the oven. All joints were replaced and everything everything suspension related was brand new !!

We also replaced the steering rack with brand new !!

The rear subframe / chassis was also cleaned from rust with sandpaper and repainted to look brand new !!

The engine was removed and the both turbos were sent for service / refurbishment !! They came back looking brand new !!

The Secondary Airpump was broken and replaced with the rare to find piping.

Water pump was replaced.

Cats removed and decat pipes replaced.

Silencer was removed with straight pipes replaced.

Next I enjoyed my car for 2 months... when it started overheating... Coolant would disappear at alarming rate...

So we fabricated an aluminum header tank !! But this did not solve the issue !!

Next the battery went dead.

But it turned out to be alternator... Rebuilt !!

Next as I was driving the differential ring pinion was torn apart... Some teeth broke... It sounded terrible !!

So I replaced differential with Quaffe locking diff...

Decided to do head gaskets... While there, I replaced all valve guides and did total top end refurbishment... New ARP head bolts too !!

And 2 weeks later disaster struck !!

The oil pressure release valve got stuck open... Low Oil pressure warning.. Rod bearing damage !!!! @@@@@@

Took the car in... Torn it apart...

Decided to buy Carillo Forged Pistons... And the rest of the story is in my thread below...

Also replaced Fuel Pump, MAP sensor and Fuel regulator...

Now waiting for my build to finish and see !!

keep fingers crossed !!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...