free hit
counters
Tacho/speedo Problem - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
SteveSmith

Tacho/speedo Problem

Recommended Posts

Guys

Having got my car back up to full strength, I've discovered that the tachometer & trip computer aren't working.

The speedo works fine but the miles just aren't clocking up - some may say thats a good thing but I like to keep things honest :)

Oddly, if I reverse with some vigour (i.e. off the drive) and brake quite sharply then the tacho starts working for the duration of the journey I go on but when I go on the next trip out, its stopped working again.

Any clues before I start taking the dash apart ??

Failing that, does anyone know a good speedo repairer ??

Cheers


Steve

89 SE Pacific Blue

http://lexi.mantaur.co.uk

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
The speedo works fine but the miles just aren't clocking up

Might be a blessing in disguise.

Worst cast, you can replace the speedo. The PO of mine did it (so it says in the history).

Mark

88 Turbo

Share this post


Link to post
Share on other sites

It's very odd to have both go at once. I know you can get some problems with speedos and tachos if the battery is low but still operational.

I remember a couple of years back where someone had a problem and it was the magnets inside the devices coming adrift and this caused erroneous and intermittent readings. I believe it was quite simple to fix - if you're not afraid of pulling things apart.


Simon  (94 S4)      My Esprit will be for sale in late 2017

Share this post


Link to post
Share on other sites

OK guys - I'm a complete pillock.

I actually meant odometer NOT tachometer.

So to recap, both my ODOMETER and trip computer have stopped working.

Geoff Moat has given some good advice on Yahoo but any further suggestions greatly received.


Steve

89 SE Pacific Blue

http://lexi.mantaur.co.uk

Share this post


Link to post
Share on other sites

Well if its just the tumblers that are causing the problem - it looks as though Geoff is close to the mark. Somethings slipping or has run amock in there.

Looks as though you'll be ripping off the binnacle then. Easy enough to do - someone has a guide for doing this. From memory I think its on the US Esprit website.

www.espritfactfile.com

Edited by s4simon

Simon  (94 S4)      My Esprit will be for sale in late 2017

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...