free hit
counters
Faulty window - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums Jump to content

Recommended Posts

Hi guys , 

I am new to the forum and picked up my 2011 Evora S on Friday ( is there somewhere to introduce myself to the forum ? ) . 3hrs after pick up I found the passenger window was not dropping slightly on door open and not fully closing on the door close . It is now parked up outside with masking tape stopping water ingress , so any help greatly appreciated . 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Think this is a window module issue - I’m sure there’s a reset procedure to try - but failing that it’s a new module


Only here once

Share this post


Link to post
Share on other sites

howdy welcome to the forum. 
 

Reset procedure is to wind the windows down all the way.  Hold the button down for a few seconds till you hear a click. Then wind them up all the way keep holding the button again for a few seconds till you hear another click. 

Share this post


Link to post
Share on other sites

Thank you Barry, much appreciated . Tried all the reset ideas , 5 seconds hold button etc but to no avail . Guess i need the door panel stripped and the module looked at as i noticed in a separate post that water can ingress . If I do need to buy a new one then is there a way of stopping future water and would you get the window of my unaffected door sorted just in case even though its good to go as we speak  . How common is this on the Evora ? 

Thank you for the welcome Jairaj , tried that to no avail with key in the lock firstly without turning engine over and also with engine started . 

Share this post


Link to post
Share on other sites

It does seem common. My Evora after lots of rain - when you open the drivers door it leaks water out of the drain hole towards the front of the car. I’m hoping I don’t get this issue as I’m sure these modules ain’t cheap


Only here once

Share this post


Link to post
Share on other sites

Thing is Barry maybe you ( we ) ought to protect them just in case ? My drivers window is great right now , but after heavy rain ........

Share this post


Link to post
Share on other sites

I had this recently on the driver's door. I sprayed copious amounts of wd40 in to the latch. I kept working the latch in-between sprays to try and free off the micro switch.

It worked and has been fine for months. Worth a try as the latch will be on back order and expensive for what it is.

Share this post


Link to post
Share on other sites

Have you noticed whether the door indicator on the dash functions as it should? If it shows up as open (even if the door is closed) or vice versa, it usually indicates a micro switch fault. If the indicator and courtesy lights work properly, it’s usually the regulator at fault.

Hope this helps,

Steve

Share this post


Link to post
Share on other sites

Hi Steve , 

My dash shows both doors closed and when either door opens the courtesy lights come on . What part should I order as i thought it was just one ( expensive ) piece ? 

Much appreciate everyones help , cheers Tony 

Share this post


Link to post
Share on other sites

Water gets into the electronics and causes a number of issues before the whole regulator fails. If you take the panel off and remove the regulator it’s sometimes possible to open it up, get rid of all the water and clean up the affected contacts. There’s a guide below that shows the disassembly process for a different fault that may help:

https://www.lotustalk.com/threads/evora-window-regulator-cable-repair.431114/

If not, unfortunately you’ll need a new regulator assembly.

Edited by Ledlights

Share this post


Link to post
Share on other sites

Thanks so much guys .

I am actually trying to save the vendor of the car some money so i will take it to the garage , get it stripped and inspected . I only bought the car last week but knowing these issues got him to sign a contract saying that should water enter within 3 weeks he would pay up to £500 for the fix ( 3 weeks would allow me to leave it in rain ) . 2hrs after driving the car away in extremely heavy rain it happened , will be interesting to see if he honours ( if the strip and clean does not work ) or result in me having to take him to small claims court ? 

So appreciate the help , nice to have support esp when this happened so early in my ownership , Tony 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...