free hit
counters
AiM MX2E Elise/Exige specific dash - Page 27 - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums #ForTheOwners Jump to content


AiM MX2E Elise/Exige specific dash


Recommended Posts

18 hours ago, Paul_D said:

I fitted my AIM dash today without any issues. 
 

Despite being 6ft I can see the shift lights fine. Perhaps I’m long legged and short bodied???

I have unfortunately got the same problem that other people had - if I upload my own configuration for shift lights and displays the ‘MODE’ icon for Normal, Sport & Race now shows Error. Everything else works fine. 
 

Did anybody ever find a solution to this?

All sorted. Even though I’d only recently downloaded it, somehow I didn’t have the latest version of Race Studio. Updating that and retransmitting to the AIM has fixed everything. 
 

(although strangely I now get a message on Race Studio when the upload has finished saying that the transmission has generated errors)

Link to comment
Share on other sites

  • 2 weeks later...

Upgrade today to remove Google ads and support TLF.

Sorry, I mean on my car the light comes on at displayed one quarter tank and I believe this is level is accurate. i.e the AiM light comes on very early.

Link to comment
Share on other sites

Mine comes on at the quarter mark so I’d say around 8 litres left in the tank, which is way too soon, and very annoying if you suffer “idiot light ocd” like myself.

 

Link to comment
Share on other sites

  • 2 weeks later...

Still no real world comparisons between the FE version and the aftermarket version?

On Order: 2021 Lotus Elise Cup 250 FE in Isotope Green, Red Alcantara Interior, Carbon Aero Kit, AirCon, Carpets & Mats, NVH pack, Cruise Control, Stereo, Red Calipers.
Now Gone2018 Lotus Elise Sport 220 in Metallic Blue, Alcantara Pack, Forged Wheels, 2piece brakes, AirCon, Hard/Soft Tops, Red Calipers, Stereo, Interior Colour Pack, NVH Pack, Carpets, Mats.
Previously Owned: 2016 Lotus Evora 400, 2010 Lotus Evora NA, 2003 VX220 Supercharged, 2001 VX220 Lightning Yellow
Follow my Lotus journey here: http://www.FaceBook.com/HandmadeInHethel

Link to comment
Share on other sites

SO I finally bit the bullet and bought the MX2E. Very happy and certainly a step up from the GARW that I had previously.

Just one issue: How the hell can you see the turn signal indicators? I'm finding the whole upper section more (the corners) or less (the center) blocked from view behind the steering wheel. 

Anyone found a solution. I'm not really very tall (1.8 meters), so it mus be the same issue for many.

If you have the choice between a Stairway to Heaven and a Highway to Hell don't forget the Nomex®!

Captain,  Lotus Airways. We fly lower! 

Link to comment
Share on other sites

Have a trawl through this thread, there is a way of having the word “on” and “off” light up lower down in the unit when the indicators are working, not ideal but at least it tells you the indicators are in action. I have no idea how you get it to do this but it is possible. I’m 6’1” and had trouble seeing the limit lights and indicators, I dropped the dash down in the binnacle which sorted the problem… I posted up on this thread about it so that may help?

Link to comment
Share on other sites

  • 2 months later...

Is there any reason to think that it wouldn’t just be a plug and play upgrade like the non FE AIM dash? 
 

I’m assuming the connector plug is the same, and also that the information from the ECU isn’t changed on the final editions. 

Link to comment
Share on other sites

On 23/08/2021 at 21:39, Inversed said:

Is there any specific reason why would someone go for FE dash instead of AIM?
FE dash seems to miss quite a bit of features... I would love rear-cam compatiblity or lap-timer.

Assuming they get it right, a seemless interface would win it for me - bug-less and glitch-less experience with indicators put on the right place, fuel range and warning indicator working as it should and layouts changing depending the mode you are in (I know, very gimmicky but I like that).

Laptimer is great if you make use of it, otherwise it is just another option:) the FE one is also cheaper by the looks of it:) price on deroure is £1000 plus vat.

Link to comment
Share on other sites

  • 2 weeks later...

A minor point I haven't seen raised before: the ECU vehicle speed correction (dash Settings / Preferences / Vehicle / Speed) corrects the displayed speed on the dash and the speed recorded on a SmartyCam (if you add ECU vehicle speed to the overlay) but surprisingly it *does not* change the ECU vehicle speed recorded in the dash data file. Seems like an oversight. Easy to see if you add both ECU vehicle speed and GPS vehicle speed to a graph in RS Analysis.

Link to comment
Share on other sites

Hi All,

Has anyone tried to connect two cameras to this dash display?

I have just purchased the double AiM rear camera patch cable with two cameras for this dash, but I can only get the same camera feed for both video 1 and 2 within the settings screen.

I have checked the cable pin continuity which correctly separates the two camera feeds and both cameras work correctly when swapped over. Thinking it may be a firmware issue I have installed the latest version 02.34.66 but this did not fix the problem.

The only thing left is the dash display is not switching between the two camera feeds internally, as video 1 and 2 are using the same feed signal. I have emailed AiM asking if this is a known issue, but in the meantime I was wondering if anyone has got this dash working with two camera feeds.

Also just for info I also have the AiM data hub connected to the exp. input connection with only the GPS module plugged into the data hub, but this should not affect the camera feeds.

Link to comment
Share on other sites

On 07/09/2021 at 14:56, AustinP said:

A minor point I haven't seen raised before: the ECU vehicle speed correction (dash Settings / Preferences / Vehicle / Speed) corrects the displayed speed on the dash and the speed recorded on a SmartyCam (if you add ECU vehicle speed to the overlay) but surprisingly it *does not* change the ECU vehicle speed recorded in the dash data file. Seems like an oversight. Easy to see if you add both ECU vehicle speed and GPS vehicle speed to a graph in RS Analysis.

AiM tech support passed this on for consideration in a future firmware update, I hope it's addressed when they fix the rear view camera bug.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...