free hit
counters
AiM MX2E Elise/Exige specific dash - Page 31 - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

AiM MX2E Elise/Exige specific dash


Recommended Posts

11 hours ago, Toqcars said:

Got the SL (Seriously Lotus) harness bar. However, can confirm the fit, because still waiting for the Schroth harnesses. Few users successfully fitted it into the 380 and 410. 

Thanks, I had the SL V bar in my Exige but was looking for a straight bar for the Elise Cup.  I still have it for sale if anyone is looking for one.

 

IMG_2051.jpeg

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.

There is a new bar coming out for Exige’s with the carbon seats. I’ve had one on order for three months. Hopefully will rock up in a month or so. This gets around the eyelet issue and properly located the harness straps.

cheers

 

Link to comment
Share on other sites

1 hour ago, Toqcars said:

When the new version came out? Is there any distinctive difference that’s easily noticeable between the versions?

New version not shipped out yet. No real difference between them other than the 'V' part has different dimensions to the previous version

Link to comment
Share on other sites

  • 2 weeks later...
On 06/02/2022 at 19:12, Inversed said:

Great, that's nice, my gps module just got delivered few days ago. As far as I understand its should be taped to inside side of top binnacle, correct?

Any updates - is it working for you?  Have you managed to test the GPS/track features?

Edit: Any installation tips?

Edited by TonyKL
Link to comment
Share on other sites

  • 2 weeks later...

Any tricks to get the gps module working?

Installed mine today but it’s like it’s not even connected. Fixed as securely as possible. Wonder if I’ve got a dud. 

Link to comment
Share on other sites

My first attempt to connect the GPS09 module did not work.

But as said here, be sure to properly / fully screw the GPS module connector, otherwise it won't work.
You have to push the connector into the dash, screw it, push again, screw again... until you can't push / screw anymore.
Seems like contact is made almost at the end...
And it worked for me 👍 🙂

  • Like 1
Link to comment
Share on other sites

1 hour ago, Martrack said:

My first attempt to connect the GPS09 module did not work.

But as said here, be sure to properly / fully screw the GPS module connector, otherwise it won't work.
You have to push the connector into the dash, screw it, push again, screw again... until you can't push / screw anymore.
Seems like contact is made almost at the end...
And it worked for me 👍 🙂

Thanks. I did read your post and have secured it as much as I thought possible but I’ll give it another go. 
Once working I guess the track/gps automatically becomes enabled when the dash is switched on?

1 hour ago, Inversed said:

Installing today, will report.

Good luck. 

Link to comment
Share on other sites

1 hour ago, TonyKL said:

Once working I guess the track/gps automatically becomes enabled when the dash is switched on?

Yes, exactly. And you see GPS status indications at the bottom of the main screen (GPS: SEARCH / GOOD...).

  • Thanks 1
Link to comment
Share on other sites

I had to return my dash and GPS that I bought in early Feb to AIM as it had a faulty GPS module...

Also worth noting I tried to fix it by applying the recent v02.34.75 firmware update but there is a bug that stops the mph speed conversion from working. You will get kph ok but mph just stays as zero on the readout. The workaround is to setup a custom field for your ECU speed using Racestudio3. 

AIM are aware of the v02.34.75 mph bug as I ran a few tests with their support team and they confirmed it will need a firmware update again to fix... Hopefully that won't take too long. 

Edited by rmaurer
Link to comment
Share on other sites

I did installation today + I have raised steering wheel for about 1.5cm (3 washers). I needed to sand some of top shroud part off for raise not to rub. It's a lot better.

About GPS module, quite easy install, tricky part is removing binnacle. It just needs a good pull, a bit scary when you are doing it first time.
I tightened up GPS module well with fingers, nothing really dramatic. Plugged it in while everything was still apart, it worked straight away.

Track & GPS menu is selectable, looks like all tracks are already imported, but I'll have to delete most as they don't get sorted by proximity - quite silly. There There is notification about GPS signal quality always on dash. You can also enable Timer on dash, which shows lap number and time. If track is not selected, it still works. It just resets everytime car stops. Haven't tested it on track yet - there is trackday coming up next weekend.

 

 

PXL_20220306_103030080.jpg

PXL_20220306_130402433.jpg

PXL_20220306_103411426.jpg

Edited by Inversed
  • Like 2
Link to comment
Share on other sites

Today I've connected laptop to my Lotus FE dash with GPS fitted via Race Studio app. Process is very simple and works really well. I would suggest changing wifi password or turning wifi off every time you are done, otherwise someone can troll you and lock you out of the system by changing password.

When GPS09 module is connected car is constantly logging data apparently. "Lap" and also dash timer resets everytime car comes to full stop. I've downloaded few logs to check out what info we get.

There is plenty of ECU data which is great, most imporantly:
- rpm
- vehicle speed
- each wheel speed
- current steering angle
- engine temp
- other variables (doors open, light settings, ecu mode, abs light, tc light and much more)
Data from GPS:
- location
- GPS speed
- sensor temperature
- G-forces
- orientation

I didn't find % for throttle/brake application, probably not available.

Here is a screenshot from random city drive today.

AiMRS3-64-ReleaseU_2022-03-08_17-46-23.jpg

Edited by Inversed
Link to comment
Share on other sites

  • Gold FFM

I’m surprised throttle isn’t there. Have a look for ECU PPS. (Pedal position sensor)

Theres no brake %, but there should be a brake switch on/off log if it’s the same as the aftermarket AIM dash. 

Link to comment
Share on other sites

On 06/03/2022 at 18:43, TonyKL said:

Will see if I can exchange it. 

After speaking with AIM (very helpful!) I have a replacement arriving (hopefully) tomorrow so will give an update this weekend.  Fingers crossed!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...