free hit
counters
New head unit - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums Jump to content

Recommended Posts

Hello!

i am considering upgrading the head unit in the Exige 350. I like the look of the attached unit. I don’t think it will obstruct the vents or HAVC controls to much and it has a OEM feel to it. The apple car play really appeals to me. 

Being a complete layman, would this be a simple plug and play? I am confident enough to instal, but not if it’s plug and play. 

Grateful for any insight  

https://www.halfords.com/webapp/wcs/stores/servlet/ProductMobileDisplay?catalogId=10151&categoryId=318419&langId=-1&productId=1559475&storeId=10001

 

 

 

Edited by Edinburgh 111s

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
1 hour ago, Edinburgh 111s said:

Hello!

i am considering upgrading the head unit in the Exige 350. I like the look of the attached unit. I don’t think it will obstruct the vents or HAVC controls to much and it has a OEM feel to it. The apple car play really appeals to me. 

Being a complete layman, would this be a simple plug and play? I am confident enough to instal, but not if it’s plug and play. 

Grateful for any insight  

https://www.halfords.com/webapp/wcs/stores/servlet/ProductMobileDisplay?catalogId=10151&categoryId=318419&langId=-1&productId=1559475&storeId=10001

 

 

 

It should fit, the centre vents may be obstructed, best make up a template to see how for up it comes, but should be ok. Only thing is you can’t adjust the angle I don’t think, and it really needs to be tilted back to see it especially as the screen is quite thick.

Generally it’ll be plug and play, take out old headunit, unplug ISO, plug in new harness, new headunit is now working!  But there will be a few things to do like install DAB splitter, route iPod cable to the shelf as it’s out the back of the head unit, and fit the mic.  All pretty simple and easily done, most important is routing the usb cable. But in general swapping a like for like headunit in the Exige is about as easy as it gets.

Carplay is great works well for maps as well as media, so pretty useful. Depends if you are happy to not have physical volume knob etc as that HU is 100% touch screen.

Share this post


Link to post
Share on other sites
6 minutes ago, MrP_ said:

It should fit, the centre vents may be obstructed, best make up a template to see how for up it comes, but should be ok. Only thing is you can’t adjust the angle I don’t think, and it really needs to be tilted back to see it especially as the screen is quite thick.

Generally it’ll be plug and play, take out old headunit, unplug ISO, plug in new harness, new headunit is now working!  But there will be a few things to do like install DAB splitter, route iPod cable to the shelf as it’s out the back of the head unit, and fit the mic.  All pretty simple and easily done, most important is routing the usb cable. But in general swapping a like for like headunit in the Exige is about as easy as it gets.

Carplay is great works well for maps as well as media, so pretty useful. Depends if you are happy to not have physical volume knob etc as that HU is 100% touch screen.

Super! Th aka for the insight. Will report back once it’s installed 

Share this post


Link to post
Share on other sites

@MrP_

I am about to attempt the install over the next day or two. Any ideas on how to route the usb cable for the iPhone ?

on the DAB splitter, do I simply need to install the attached or would I need a full DAB Ariel?

https://www.dynamicsounds.co.uk/connects2-ct27aa136-universal-dab-dab-smb-aerial-antenna-dab-splitter.html

thanks for your help. 

 

Share this post


Link to post
Share on other sites
12 hours ago, Edinburgh 111s said:

@MrP_

I am about to attempt the install over the next day or two. Any ideas on how to route the usb cable for the iPhone ?

on the DAB splitter, do I simply need to install the attached or would I need a full DAB Ariel?

https://www.dynamicsounds.co.uk/connects2-ct27aa136-universal-dab-dab-smb-aerial-antenna-dab-splitter.html

thanks for your help. 

 

Hey, the simpliest way is to route under the airbag (there is a channel on the front edge of the dash, under the airbag), around the vent pod, and into the dash, follows this route:

 

9WKR0q6.jpg

Or you can go out through the steering column, but then you have to get under the HVAC controls as you need space to lay the phone, so its easier going the  way highlighted above 

Not sure if you get enough USB cable, but it could be worth getting a USB extension cable if in doubt

For the DAB splitter the one you mention would be fine, the normal DAB screen antennas require an earth from the A pillar, which we don't have so then you are trying to run in earths etc. I use the splitter and get DAB signal that beats just about any factory car! Just run the blue power cable to the remote output from the Pioneer loom and it will switch on and off with the headunit not causing a power drain.

Just an FYI for anyone that is putting in a DAB radio for a MY2020 car, you shouldn't need a splitter as Lotus have now put in a DAB antenna, but I presume that means it now ships with a DAB headunit.

Share this post


Link to post
Share on other sites
2 hours ago, MrP_ said:

Hey, the simpliest way is to route under the airbag (there is a channel on the front edge of the dash, under the airbag), around the vent pod, and into the dash, follows this route:

 

9WKR0q6.jpg

Or you can go out through the steering column, but then you have to get under the HVAC controls as you need space to lay the phone, so its easier going the  way highlighted above 

Not sure if you get enough USB cable, but it could be worth getting a USB extension cable if in doubt

For the DAB splitter the one you mention would be fine, the normal DAB screen antennas require an earth from the A pillar, which we don't have so then you are trying to run in earths etc. I use the splitter and get DAB signal that beats just about any factory car! Just run the blue power cable to the remote output from the Pioneer loom and it will switch on and off with the headunit not causing a power drain.

Just an FYI for anyone that is putting in a DAB radio for a MY2020 car, you shouldn't need a splitter as Lotus have now put in a DAB antenna, but I presume that means it now ships with a DAB headunit.

Super helpful as always @MrP_ thank you 😊 

would I need to remove the airbag cover to run the cable ? 

Share this post


Link to post
Share on other sites
34 minutes ago, Edinburgh 111s said:

Super helpful as always @MrP_ thank you 😊 

would I need to remove the airbag cover to run the cable ? 

Nope, you can get to both ends fairly easily and it goes in a channel under the airbag, so if you can thread it through without the cable bunching up you’ll be grand. If you have a bit of twin and earth or other thicker cable that would be easier still then drag the usb through after taping it on, or an old wire coat hanger also works 

  • Like 1

Share this post


Link to post
Share on other sites

@MrP_ impressive how you can advise on all of this, as is your own build thread with all the improvements. Is your background as a spark etc or is this just something you find easy to do.

Edited by TerryCTR

Share this post


Link to post
Share on other sites
15 minutes ago, TerryCTR said:

@MrP_ impressive how you can advise on all of this, as is your own build thread with all the improvements. Is your background as a spark etc or is this just something you find easy to do.

@MrP_ has some great knowledge and has helped me out on a few occasions now 👍

Share this post


Link to post
Share on other sites
4 hours ago, TerryCTR said:

@MrP_ impressive how you can advise on all of this, as is your own build thread with all the improvements. Is your background as a spark etc or is this just something you find easy to do.

Its just working stuff out really, sure plenty of people do it better! I just like pulling stuff apart and finding out why it works that way, just the way my mind works, just break stuff down to simple things, fix the simple thing and build back up, seems to work

 

5 hours ago, Edinburgh 111s said:

@MrP_ has some great knowledge and has helped me out on a few occasions now 👍

Glad its helped, all part of the Lotus community! 

Share this post


Link to post
Share on other sites

@Edinburgh 111s Please do post pics when you've got it sorted. I'm also interested in this unit so would love to see how well it fits.

Cheers

Share this post


Link to post
Share on other sites

In the process of installing it right now.... but the DAB splitter doesn’t seem to be working. 
 

@MrP_ any ideas? I think I have wired it correctly. The blue cable from the splitter I have connected to the remote wire (blue with white stripped. I have connected all up and no DAB signal or FM. I have added some pictures , albeit not very clear. Am I missing something ? 
 

 

447137C0-6CFC-4CC5-B643-2D44CFC77520.jpeg

Share this post


Link to post
Share on other sites

Are you able to test the remote feed is giving out 12v? I’ve looked through and can’t see a setting in the manual to switch it off, so it all looks good!

If you do have a multimeter and it’s giving a 12v feed, then the splitter may be duff.

If you get no voltage, then you could try tapping off the red switched live. It could be a badly terminated harness, or there is a setting turning off the 12v, could be something like antenna power setting.
 

Asuming the remote (blue/white wire) is all good, the it’s either internal tuner or the splitter.

Can you bypass the splitter and go FM direct into the head unit? Just to rule out the splitter or tuner issue.

I’m assuming CarPlay etc works fine?

And you have searched for stations? By default I think it’s just silent with no auto filled stations. I’m sure you already done this. 

If the bypass works, and you have power it’s a dead splitter. PM me your address and I’ll pop one in the post I know does work, 

I’ve just seen the green wire and completely forgot about it, it is the handbrake detect that turns certain functions off I believe (it’s a US thing). Sorry I completely forgot about it. Assuming you have not wired to the handbrake switch, you can use a relay to defeat it. Something like this: 

https://www.amazon.co.uk/dp/B01L6Z1WYA/ref=cm_sw_r_cp_api_i_hT6dEbEDQD7GH

It spoofs the headunit into thinking the handbrake is on, so no functions are blocked. I think it only stops video in motion, so may not be needed.

Share this post


Link to post
Share on other sites

@MrP_

thank you. It appears it must the the actual head unit tuner. I plugged in the normal FM Ariel and it didn’t pick up any stations. It eventually found on FM station when I searched but it then disappeared again. To double check I plugged in the old head unit and there wasn’t a problem. 
 

looks like I will need to return the head unit. I can’t think why it randomly picked up one station and no others and then lost it again?
 

 

Share this post


Link to post
Share on other sites
3 minutes ago, Edinburgh 111s said:

@MrP_

thank you. It appears it must the the actual head unit tuner. I plugged in the normal FM Ariel and it didn’t pick up any stations. It eventually found on FM station when I searched but it then disappeared again. To double check I plugged in the old head unit and there wasn’t a problem. 
 

looks like I will need to return the head unit. I can’t think why it randomly picked up one station and no others and then lost it again?
 

 

That sucks! Not because you’re in the garage or anything is it? 

Share this post


Link to post
Share on other sites
10 minutes ago, MrP_ said:

That sucks! Not because you’re in the garage or anything is it? 

 No, because I plugged the old head unit in and the FM radio worked fine. Really strange as after a while the new head unit picked up a station, but then when I looked for more it disappeared. I am in the garage but the old one worked ok. I don’t think it’s linked to the handbrake switch and I assume the exgie doesn’t have an amplified Ariel?

the only thing I can think off is the head unit must be faulty 😐

Share this post


Link to post
Share on other sites
22 minutes ago, Edinburgh 111s said:

 No, because I plugged the old head unit in and the FM radio worked fine. Really strange as after a while the new head unit picked up a station, but then when I looked for more it disappeared. I am in the garage but the old one worked ok. I don’t think it’s linked to the handbrake switch and I assume the exgie doesn’t have an amplified Ariel?

the only thing I can think off is the head unit must be faulty 😐

Shame, agree sounds like something is wrong. I certainly don’t have any reception issues, the Clarion picked up some but switching to Pioneer it just picked them all up. DAB never drops out. It could just be a dry joint on the antenna to board,  but they should swap no issues. Frustrating when you just want it sorted for the weekend!

Exige antenna is definitely a boggo Dipole, admittedly they’ve never been great, but they do work

Share this post


Link to post
Share on other sites
12 hours ago, MrP_ said:

Shame, agree sounds like something is wrong. I certainly don’t have any reception issues, the Clarion picked up some but switching to Pioneer it just picked them all up. DAB never drops out. It could just be a dry joint on the antenna to board,  but they should swap no issues. Frustrating when you just want it sorted for the weekend!

Exige antenna is definitely a boggo Dipole, admittedly they’ve never been great, but they do work

Weird. Took it back to Halfords and they tested it on their board. The FM worked just fine! Can’t figure it out. I am going to complete the is install just now and try and figure it out afterwards. 
 

the old head unit picked up FM fine. The new one picked up FM fine in Halfords but doesn’t when in my car. Strange. Will investigate later. The main reason for buying the head unit was for car play to open up Spotify / Waze etc. 

Share this post


Link to post
Share on other sites

I tried one of those DAB splitters (metal box) In my old Evora and it didn’t work although had used something similar before in an old Evora. Brought one of these and it worked fine in my Evora and current Elise https://www.amazon.co.uk/dp/B0722JGGSZ/ref=cm_sw_r_cp_api_i_HTheEbDSR31FE

also found radio reception in my garage to be very hit and miss although always manage to pick up something on FM directly but with interference, the metal box splitter got nothing.

https://www.thelotusforums.com/forums/topic/76121-another-pre-my12-ice-replacement/?do=findComment&comment=776352

 

  • Like 1

1982 DeLorean DMC 12 #16327, 1999 Lotus Elise, 1998 Lotus Esprit GT3 #2272, 2011 Lotus Evora S, 2013 Lotus Exige S,2016 Lotus Evora 400

Share this post


Link to post
Share on other sites

Thanks Austen,

That does look like a good fit. Should just be a drop in replacement for my Pioneer HU, which itself was a replacement for the Clarion to give better sound and iPhone bluetooth integration.

I'll keep an eye on Halfords for more sale action, that was a storming price you got.

Share this post


Link to post
Share on other sites
26 minutes ago, MartynB said:

Thanks Austen,

That does look like a good fit. Should just be a drop in replacement for my Pioneer HU, which itself was a replacement for the Clarion to give better sound and iPhone bluetooth integration.

I'll keep an eye on Halfords for more sale action, that was a storming price you got.

Thanks. I really like it. It’s the closet to an OEM look that I have seen with the single din / tablet display. 

yes I got lucky. It was on sale for £365. I was bored on Christmas days with the in-laws at our house so searched for a discount code 😂 the code expired on Christmas Day. I do see various and reputable sellers are selling this same model new and boxed on eBay for £365. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...