free hit
counters
Help please, what am I doing wrong? - Evora Chat - The Lotus Forums Jump to content
Spinney

Help please, what am I doing wrong?

Recommended Posts


Upgrade today to remove Google ads and support TLF.

Be fair, I did use 3/4 of a tank today! 😁
 

I think today was the first time I’ve used the car for a couple of hundred miles and not had a problem, so keeping fingers crossed!🤞

Share this post


Link to post
Share on other sites

Wat 45 liters in 200 miles so 20 miles per gallon you were just enjoying yourself, I cannot see anything wrong there

Share this post


Link to post
Share on other sites

Struggle to get mine to ever do over 24.7mpg - seems about the best I can do locally. Mix in some hooning and it drops even more - in fact there is a direct correlation between the fun and just how low the mpg goes

  • Like 1

Only here once

Share this post


Link to post
Share on other sites
12 hours ago, Barrykearley said:

Struggle to get mine to ever do over 24.7mpg - seems about the best I can do locally. Mix in some hooning and it drops even more - in fact there is a direct correlation between the fun and just how low the mpg goes

You always gotta pay for your pleasure  

  • Haha 1

Share this post


Link to post
Share on other sites
22 hours ago, Spinney said:

I haven't used my Evora for a while, due to holidays and other things getting in the way but decided to take it to Brooklands today for the annual NY Day meeting. I had a brilliant run there and after leaving, went the (very) long way home and had a bloody riot of a time, driving on some lovely, near empty roads, a bit of hooning out of sharp bends, several long sweeping bends and a bit of bouncing off the limiter, used nearly 3/4 of a tank - bloody great!  Now here's the thing, absolutely nothing went wrong, no unusual dash lights, no going into limp mode - it all just worked exactly as it should and I fell in love with the car all over again.

Am I doing it wrong? :P

Over here: The sixth year (2018) of ownership was the first one with the Evora when NO engine light had come on...;-) ........so your car already behaves well I would say...... 

Share this post


Link to post
Share on other sites
7 hours ago, Peegee355 said:

You always gotta pay for your pleasure  

Can we keep this to cars only😜


hindsight: the science that is never wrong

Share this post


Link to post
Share on other sites

On a not unrelated point, and I'm not really sure this is something to be pleased about, but I had an average of 30.3 mpg in my S, on my Xmas Eve drive home from Reading to Essex, with Sport mode on all the way!

100 traffic free miles: M4, M25, A127, I didn't use cruise control and had the radio on but not the AC/heating.

Soon ruined that when I go there though as my brother hadn't seen the car...…...

  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...