free hit
counters
1976 Elite restoration. - Page 33 - Projects & Restorations - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

1976 Elite restoration.


Recommended Posts

Cardboard blank of batteries on internet for the elite. Height includes terminal posts.  Choice of two , both 45ah, but one is 390a the other is 340a.  Both with 4 years warranty. The 340a is £49 ish plus £8 postage. The 390a is out of stock so no price. On a different site the 390a is £62 including delivery. 

6EF3E989-5F4F-4805-BABD-2B85661A8C3C.jpeg

Tony 

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.

My research shows that the Yuasa YBX5057 is the best bet for the Elite, a perfect fit, the correct terminals and orientation and the restraining bar holds it tight without it touching the outer bodywork of the car.  The ratings are 50Ah and CCA of 450A, which is the best I can see online.  I've bought my second one last month from The Battery Shop, just before a 9% price rise, so you now have to pay £68

Yuasa 12v 50Ah 450A Silver Car Battery YBX5057 (HSB057) Buy Online from The Battery Shop 

  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...

http://rdent.com/manuals/elite_and_eclat/seats_and_trim/VD.gif

 

http://rdent.com/manuals/elite_and_eclat/seats_and_trim/VC.gif

 

Hi Tony

  Going by the sill repair i'm doing the void is full of foam anyway so I guess it doesn't need it on the interior just carpet

Roland

Link to comment
Share on other sites

Still fitting carpets, now on driver’s side.  There is a 12mm hole drilled through inner sill in front of the seat mounting. No idea what it’s for. Guess in its past someone decided to mod something.  
Unless you all know something ?

23E850AB-CE81-4274-9527-FEE46FF64393.jpeg

Nearly got it in the photo 

345D47A6-E4B8-4F38-B655-0FA97CA4F3D1.jpeg

Tony 

Link to comment
Share on other sites

My car doesnt have this and can't think what it might be for either!! or alternatively the seat belt mounting point has been drilled well out of position LOL.

Link to comment
Share on other sites

Hi Angus, have been thinking back a year or two, the original battery cable had a join , around that same position. Spurred of the cable was a red probably 6mm cable. Guessing they brought it into car there , saving them disturbing footwell panels.  
I have no idea where it connected, but needed a lot of power.  Unless it’s why the horns don’t work 😂

  • Like 1

Tony 

Link to comment
Share on other sites

Hi Tony    If your car starts and runs then it can't be for the starter or alternator and i cant think what else might use 6mm cable.

If your horns dont work I would connect live and earth separately to them and see what happens?. Mine were a bit temperamental due to a bad earth (corrosion) around the connections on the horns in the recess at the front. Completely rewired them and they now work properly in low and high pitch.

 

  • Thanks 1
Link to comment
Share on other sites

After fitting the carpets for last couple of days ( nearly finished) if given myself gout in right foot, too much kneeling.   Not only that  but at half past midnight the near side indicator decided to start flashing. Had to disconnect the battery.   
 And finally the birds have been using it for target practice.  Crap all over it. 

Tony 

Link to comment
Share on other sites

  • 2 weeks later...

Hopefully this thread is still active as I bought a 1975 Elite last year that had sat under a tarp for at least 10 years. The car is basically sound with only 20K miles on the clock but unfortunately all the interior is a mess. It looks like it spent 20 yrs sitting in a sauna so everything is rusted to hell. I would like to get the car back on the road but don’t want to spend 8 years restoring it as I did with my Elan S2.

So Doris the Dog if you are still working on the car may be we can work together to resolve our unsurmountable problems.

Ivan W

Link to comment
Share on other sites

Well I’m still not fit enough to work on the car. So close to being drivable, but have to wait for hospital call this Saturday , to see if I’m still in remission from the illness that started my time restoring the elite. 

Tony 

Link to comment
Share on other sites

  • 2 weeks later...

Yep it is little git climbed in when I was fiddling with carbs. 
Im a Pratt , had it running months ago, then it wouldn’t start, so I started fiddling with carbs and dizzy, eventually discovered it had no bloody petrol.   Just need to get fitness back as keep having to sit down after doing very little work. 
 

Tony 

Link to comment
Share on other sites

Back to trying to get the elite to fire up after my fiddling.  It appears to be flooding fuel out of carb trumpet nearest bulkhead (4).  
Tried setting it as the brown lotus elite handbook , but I’m sure it wasn’t pumping fuel out there before when I had it running 

Tony 

Link to comment
Share on other sites

Thanks Pete , you don’t really think how the time passes, as it’s sat there all winter and nearly half of 2022.  It’s over two years since I refurbished them , then the empty fuel tank issue. 
Will strip them again.  

Tony 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...