free hit
counters
Warning dash lights - Engine & Ancilliaries/Gearbox - The Lotus Forums Jump to content
Cdm2018

Warning dash lights

Recommended Posts

Right 

got into my NA this afternoon to do school run , not driven the car since last Friday morning when it drove ok no issues other than the windscreen washer levels light

car has been sat on drive way and through last weekend storm ? It started first time of asking but then I was greeted with the engine symbol and I think traction control symbol lights on dash! 

why both ? I have seen traction light once before months ago but that soon went out it was serviced at lotus this time last year I have done about 5-6k 

I haven’t a code reader any ideas should I drive it tomorrow if weather is ok that is ? 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Update

AA man come out and says no misfire but accelerator pedal not responsive and thinks they may be an issue with throttle response in engine ? 
that’s where my mechanical understanding ends now !!! 
 

any suggestions ? 

Share this post


Link to post
Share on other sites

I had a glitch on my engine 2 years ago, driving along and then had a miss fire on one bank.  Stopped the car fired up again and it was fine part from check engine light and traction control.  They went out by them selfs the next morning.  Car went in to Hofmanns Lotus for a check up and they said all was fine.  I think I read here if the problem has gone then cycling the engine (on -> off) 5 times will clear the lights, it may be an urban myth?  Also I'm sure you know but just in case, start - stop - start is not great for the car so let it happen naturally as you use the car.  Don't specially go out to cycle the engine in one sitting.

I think it's quite common to see the both pop up.  Part of the way the car maintains traction is by cutting the torque of the engine when it detects too much wheel slip under acceleration.  I think the brakes are activated to act like a differential under excessive yaw to maintain stability of the car?  So maybe if the engine has detected a fault in it self it may not be able guarantee a reliable and robust traction control system by cutting or maintaining a constant amount or torque in the engine.  That could lead to interesting behaviour so I guess they err on the side of caution and display the traction control warning light?

if the check engine light is on the engine will be limp mode and the throttle response is reduced.

If the throttle response is slow with the error codes cleared then I think you need to get the car to a garage for a check up.

 

Share this post


Link to post
Share on other sites

AA man been and said pedal wire connection was taken out and inserted cleared the codes 

took it for test and noticed the Rev were not going down as fast ? Told AA man he said could be ECU just settling down ? 

Anyway I am going to take it school for run and give it good blast up the carriageway  

Share this post


Link to post
Share on other sites
2 hours ago, Hangar 111 said:

Do you know what the fault code is/was?

Below is pasted from AA man report he emailed 

Hope it makes sense all Greek to me 

How we assisted

Patrol found the following fault code/s:System : Global OBD II - 000 / Global OBD II Status :P0507 - Idle speed control. Error Message : Speed too high. Sporadic faults. Status :P2119 - Throttle valve control internalcontrol module. Error Message : Outside specified range. Sporadic faults. Status :P2104 - Throttle valve control unit. Error Message : Forced idle. Sporadic faults.Loss of power. Engine not responding to throttle pedal. Found fault codes stored for throttle valve. Checked all connections, reset system. All now working ok. Advised if fault returns to take to garage. Member has breakdown repair cover for this vehicle. 

Share this post


Link to post
Share on other sites
59 minutes ago, Cdm2018 said:

Below is pasted from AA man report he emailed 

Hope it makes sense all Greek to me

If that were me, and the car was outside in all that horrible weather, I'd be inspecting the wiring connector on the throttle body for moisture, make sure battery is well charged, clear the codes and see if it comes back.  How did your road test go?

The reason you get both lights on dash is that if the issue affects the stability/traction control system, it will default to off, and let you know this via the light.

Dave

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Dave for a nice and clear explanation as I have limited mechanical understanding 

the road test school run was ok the traction control light came on half way then when I went back to car after stopping at school event the light was out and didn’t appear ? 
do I need to go for service ? As I said only done 6k since last but I do drive like Ms Daisy ?  

Share this post


Link to post
Share on other sites
1 hour ago, Cdm2018 said:

As I said only done 6k since last but I do drive like Ms Daisy ?  

They come alive when the red circles flash 😉


Only here once

Share this post


Link to post
Share on other sites

I see them most gearchanges! The Evora really has a nice bit of extra poke after 4.5k, give it some beans! 


88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Share this post


Link to post
Share on other sites

I have the same issue. In my case it is a throttle correlation issue. Waiting for a new pedal to arrive and hopefully this will sort it.

I clear it by either giving the throttle body connector a wiggle (See link below), or turning he car off, turning the key to second position, pump the throttle pedal, if the traction light comes on repeat, until it clears. You an then start the car and it drives normally. The CEL light will disappear on it's own after a few engine restarts

Fingers crossed you get it sorted mate

https://photos.google.com/share/AF1QipP3G6Vs5VodQgk4TmIVt4finR-7HQ6egX_44qyY_IGYJtU5Q246m_pjVfdMA_3Ggw/photo/AF1QipNvZZHa6slmnOYRYgEr_SFnNOsj5mNp54ySOYrL?key=RUZ5YnNRUm1xWmtOWHBSRkw3TE1XeTBWYVRsdWx3

Share this post


Link to post
Share on other sites

Drove the car today a short few miles to cinema with my daughter then home via shell garage so not a long run out but all was well no light and throttle pedal was as normal 

no chance to get these red circles as traffic and road not suitable also had my daughter in car so I do go very steady 

next week away in Newcastle for most of week so won’t drive Evora then week after will possibly take Evora to one of my sites next door to Chapman estate near Hethel but not sure ? 

Share this post


Link to post
Share on other sites

Oooops!!!

I thought I was meant to have all red circles on all of the time whilst driving to make sure my car is working properly. Sometimes when in top gear a change down just to make sure they stay on constantly.

Am I doing something wrong ??

M.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Drove my car on its once a week journey to see my young daughter over at my ex a 40 mile round trip 

been doing this last few weeks no issues until today , when I parked at my ex I noticed the traction control light was lit up ?

when I drove home a couple hours later no warning light until halfway back ? 
 

any suggestions ? Not serviced the car as we were on lockdown but was serviced last year and done a about 5k 

wonder would be brake disc and pads wear have a bearing ? 

Share this post


Link to post
Share on other sites

Could be the brake light switch playing up. I know that when the one on my Launch Edition intermittently had a moment or few it put on the traction control light and disabled sport mode and cruise control.

There is a reset procedure for the brake light switch in this thread. 

Ultimately I replaced my brake light switch and haven't had any problems since.

Edited by EuropaSman

Lover of everything Lotus Cars and proud owner of production Evora No.75 (2nd UK customer specced car by VIN). Originally from the Far East....of Anglia, I read black box data for a living so that could explain a lot!

Share this post


Link to post
Share on other sites
40 minutes ago, EuropaSman said:

Could be the brake light switch playing up. I know that when the one on my Launch Edition intermittently had a moment or few it put on the traction control light and disabled sport mode and cruise control.

There is a reset procedure for the brake light switch in this thread. 

Ultimately I replaced my brake light switch and haven't had any problems since.

Does it make any difference if I haven’t sports button ? The car seems to drive ok 

I looked at the thread before but was thrown by the sports / cruise control issue ? It says the switch is an easy job but I am next to useless with any kind of spanner but my oldest son will have to be bribed to do it as long as it’s straightforward ?

Share this post


Link to post
Share on other sites

Not having a sport button shouldn't make a difference.

Changing the switch isn't too difficult. Resetting it can be done in situ. It involves pushing the plunger all the way in then pulling out 5 clicks, or as many as you can get before it reaches the brake pedal.


Lover of everything Lotus Cars and proud owner of production Evora No.75 (2nd UK customer specced car by VIN). Originally from the Far East....of Anglia, I read black box data for a living so that could explain a lot!

Share this post


Link to post
Share on other sites

Bit confused took my car out today taken it on a steady journey up M1 and no traction light but did have tyre pressure however put air in the tyre no issues

so with traction warning off is it ok or should I get the car checked but central lotus is still closed ? 

Share this post


Link to post
Share on other sites

If it's any help, PJS Sports Cars not far from where I am in Burton open their workshop from next Monday. If the light comes on again. for peace of mind it might be worth speaking to them.


Lover of everything Lotus Cars and proud owner of production Evora No.75 (2nd UK customer specced car by VIN). Originally from the Far East....of Anglia, I read black box data for a living so that could explain a lot!

Share this post


Link to post
Share on other sites

Ok just had an email from PJS a bit of trek to get to then as used them for before

i am looking at getting the brake all sorted might leave it to my new garage a jag Land Rover who also owns lotus cars ?

Share this post


Link to post
Share on other sites

I just drove my car up M1 at leisurely pace and then just when at my destination the traction light came on ?

its not shown for a couple weeks and I had driven the car during then without any issues ? 

Share this post


Link to post
Share on other sites

That's what they call an 'intermittent' issue. 

It's got nothing to do with where you are driving, how fast or your destination mate. Just take it to a garage and you'll see the problem become a 'non-existant' issue in exchange for some cash, it's not going to go away by itself. 👍


88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Share this post


Link to post
Share on other sites

Cheers Bibs 

I am waiting to get my brakes all replaced the car seems to drive ok 

I guess the code needs to be cleared after what ever checks need to done ? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...