free hit
counters
coolant light - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
pasha2891

coolant light

Recommended Posts

I went on an extended trip over the weekend and my coolant light flickered on, and toward the end of the trip, stayed consistently red. I checked my coolant level and it was fine. I topped it off just to be sure, but the light stil stays on.

I read on some other forums that usually the coolant sensor gets clogged and I need to disconnect it and wash it thoroughly.

Has anyone done this? How do I go about taking it off without breaking anything? Any suggestions would be appreciated, thanks in advance.

Paul

2000MY Black

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Paul,

I just went through the same thing on my 99 V8. What I did was wait until the car is cool, then un-screw the plastic nut on the header tank. Be sure to unplug the sensor before you remove it from the header tank. I believe that there are two prongs that you have to push in to remove the center piece where the float (level sensor) is located from the cap nut. Once you remove it from the header tank you will notice that there are small holes on the end of the tube that holds the level sensor. If you shake the tube up and down it should have movement from with in, almost like a paint spray can. When they clog there is no movement. Simply use WD-40 with the red pipe attachment and spray it into the hole at the bottom of the white sensor tube. After you fill the tube with WD-40 shake it with your finger over the hole, then allow it to drain. I had to repeat this for four times to fully flush the junk out.

Good Luck!

Dan Adragna

99 V8 Silver

Share this post


Link to post
Share on other sites

Fellas,

If that doesn't work for you; there may be air in your system. Add coolant to the system. The air will bleed itself out. what I did was after every drive, top off your coolant system. After some time and if this is your problem, it will resolve itself.


actwon

------

'14 Nike Shox

'12 Range Rover Sport

'01 Esprit V8

'95 Ducati 916

Share this post


Link to post
Share on other sites

Dan,

Thanks for the description, that's a lot more detailed than I was able to find anywhere else. I'm probably going to attempt it this weekend after I get my car back from my navigation system install :huh:.

Nathan,

Thant's a good point, I haven't heard of the light going off because of air. I'll keep that in mind incase the light still stays on after cleaning the sensor. Thank you for your help also.

Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...