free hit
counters
Esprit S2 Blowing or Sucking? - Engine/Ancilliaries - The Lotus Forums Jump to content
DavyJ

Esprit S2 Blowing or Sucking?

Recommended Posts

Hi Guys,

Hope you are all keeping well and staying safe. 

I’m doing some work on my S2 hopefully to be ready when some of the restrictions are relaxed. 
Had her idling today to get engine up to temp as just running in and out of the garage there was some emulsification on the oil filler cap. 
The rad fans kicked in just after temp gauge read 90 but noticed they are blowing air out the front grill not sucking it in through the radiator. 

Is that correct for the S2?

I thought it should be sucking air in as blowing would have an adverse effect on air flow when the car was in motion. 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

I do know that my S3 sucks the air through the rad, not sure why it should be different on the S2 as you say it would be working against the incoming air flow...

 

Share this post


Link to post
Share on other sites

Cheers BigVern,

Will have to get underneath to see if the fans are stock and wiring is correct. 
Only had her a year and still working my way round all these riddles, everyday throws up a new one. 
Trying to put right what hasn’t been done right before. 

Share this post


Link to post
Share on other sites

Are the fans behind or in front of the rad


hindsight: the science that is never wrong

Share this post


Link to post
Share on other sites

Hi Pete,

looking in the grill under the bumper I can only see the tilted rad, so fans are behind. 

Share this post


Link to post
Share on other sites

 


hindsight: the science that is never wrong

Share this post


Link to post
Share on other sites

The fans should definitely be sucking air in. Probably got the wiring reversed somewhere, which makes the motors spin backwards.

  • Like 1

I have made many mistakes in my life. Buying a multiple Lotus is not one of them.

 

Share this post


Link to post
Share on other sites
On 08/05/2020 at 21:40, DavyJ said:

there was some emulsification on the oil filler cap. 

Normally an indication there's water mixed in with the engine oil, maybe condensation if she's been sat for a while, could also be from a leaking head  gasket. 

A leak tester will tell you which. 😀

 


Cheers,

John W

http://jonwatkins.co.uk

Share this post


Link to post
Share on other sites

Thanks Lads!

The car has been laid up for nearly a year while doing some work on her. Once wiped off the emulsification and got the engine up to temp it never reappeared. Hence why I noticed the fans blowing and the reason I started this post. 
 

for piece of mind I might just invest in one of these kits anyway. 
 

Thanks for sending the link Pete! - So from what I can understand from the previous thread is the fans were originally mounted at the rear and sucking air through the rad but were Actually better at blowing air hence why some were mounting them at the front?

Share this post


Link to post
Share on other sites

The fans will work quite adequately either blowing or sucking through the rad but they most certainly should be directing air aft, in harmony with natural airflow of the car in motion. Filip is entirely correct. As for condensation there is a fairly strong correlation between engine output (load) and oil temperature, more so than the link to coolant though they may converge somewhat over time underway. Best practice is always to take a car out for an extended run and put the engine to work for a decent stretch of time.

Cheers

Share this post


Link to post
Share on other sites

Make them suck David. If you have an inclined rad you must have a later S2 like mine (11th to last). What are the last 3 digits of your VIN? These rads, if in good nick work much better than the upright ones which are smaller. I have never had a problem with overheating like many complain of, even in scorching summer temperatures.

Pete


Pete '79 S2

LEW Miss September 2009

Share this post


Link to post
Share on other sites

Thanks Pete,

Yeah later S2 with inclined rad, maybe the wiring was fitted incorrectly by one of the previous owners. Will look at reversing and see if it all works as it should. 
Not had the car for a year yet so I’m still feeling my way into Esprit ownership, everyday is a school day. 
You guys are a great help and top source of info. 👍

Trying to right a lot of wrongs before I’m happy to take her out on the road, the car at least deserves that. 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...