free hit
The mother of all faults on a V6 S - P2170 - Engine & Ancillaries/Gearbox - The Lotus Forums #ForTheOwners Jump to content

The mother of all faults on a V6 S - P2170

Recommended Posts

I'm hoping for some advice here as I've got a massive problem going on with my car, and I need it to be rectified urgently as I'm going to Spain next week.

Details of the car...

  • Exige V6 S IPS (2016)
  • Alias23 pipe fitted September 2019
  • Larini Clubsport backbox fitted May 2019 with extra bluetooth valve control (for manual operation of the valve)
  • The air conditioning compressor is currently not working but I have no idea when this stopped. The condenser was replaced last year but I haven't used it since as we've not really had the weather. This was found by JCT Leeds around 10 days ago, and at the same time, they noticed my supercharger belt was cracked.

On Sunday, I was heading down to a bodyshop and sat on cruise control at 72mph. The car had been behaving fine up until this point, when out of nowhere, the cruise switched itself off and hitting the button wouldn't make it come back on. So I pulled over, turned the car off, and then back on, and the engine management light appeared on the dash.

I was considering turning around but instead, carried on, now in limp mode to the body shop. The car was drivable but obviously limiting the power and revs. It's still got overtaking power like this, but obviously nothing like what it should have.

On the way home, I spoke to a member on here and he thought it could be the Alias23 pipe making things run lean.

The next day, I received an OBD reader and it gave me the following errors>

  • P2170 - Exhaust pressure regulator vent solenoid control circuit low
  • P2170 - Exhaust pressure regulator vent solenoid control circuit high

The car needed a replacement supercharger belt so I'd already arranged for this to be replaced at a garage near Harrogate on Tuesday. It went in to the shop, and I asked him to also look at the reason for the engine light. He found the solenoid had melted, but this solenoid was the one originally on the car, and not the one attached with bluetooth to the Larini. It was left there but the vacuum pipes were placed on the secondary solenoid attached to the Larini Bluetooth control valve module. On further inspection, I think it's melted, but it could also be some kind of resin/glue (photos attached).

We tried replacing the solenoid with a brand new part, but it made no difference. The codes were still showing and so was the engine light.

This morning, I spoke to a garage who were able to fit me in for a Lotus 20/20 diagnosis. Whilst there, they found the main air con fuse to have blown. When they replaced this fuse, apparently all the error codes disappeared, so it looked like we were on to something. The engine light had deactivated and now the cruise control would switch on. Unfortunately though, on driving home, I had to accelerate, and as soon as the car had hit around 4000RPM, the engine light came back on and the car was again in limp mode. This is of course around the point where the car would normally try to open the exhaust valve to release the gases/pressure etc.

When I got home, I called an auto electrician over to my house, and he spent a couple of hours on the car. He re-wired the steering column valve switch in case that was a source of the issues, he swapped around the bluetooth solenoid with the brand new solenoid I purchased this week, he checked the connectors for power (there were some signs of water ingress but they were still showing 5V, he checked the ECU for any water leakage and saw no signs.

Later on, I looked at fuse 7 and found that to be intact as well.

The only other things I could think of were the rear number plate lights I recently changed to LEDs, so I changed these back to standard bulbs and it made no difference (really clutching at straws here), and then I do remember driving back from JCT after they diagnosed the air con, when suddenly a very strong burning smell entered the cabin. I pulled off at a junction but by the time I'd come to a stop, the smell had disappeared, so I assumed it was a car nearby etc.

So that's several technicians and myself flummoxed. I don't know if the solenoid is truly the root cause, or if the air conditioning is playing a part, as the garage today said they once had a car that came in with an air con fault, and it also affected the cruise control. Today's garage has a compressor in stock that they can fit to the air con. The rest of the system is holding gas without any vacuum pressure loss, but they were unable to fit it in today. I'm thinking of going down this route as it's a possible cause, but it's also an expensive exercise.

I've tried to give as much as info as I can think you'll need, but if you have any ideas at all, please throw them in to the hat. I'm pulling my hair out with this one.

The car is back in limp mode currently, and will not go past around 4/5000RPM. Its drivable to a garage, but other than that, it won't be leaving my driveway.


Edited by WayneG
Link to comment
Share on other sites

Upgrade today to remove Google ads and support TLF.

Settings > Camera > Formats > Most Compatible. 

That should fix your photos uploading as Apples silly HEIC format which don’t seem to display on this site.


What OBD codes is the car giving now?

Edited by trcm
Link to comment
Share on other sites

I can't help with your issue, but I would suggest that whatever is inside that solenoid is now coming out of the solenoid. That would be excessive heat causing that.

All we know is that when they stop making this, we will be properly, properly sad.Jeremy Clarkson on the Esprit.

Opinions are like armpits. Everyone has them, some just stink more than others.

For forum issues, please contact one of us Moderators.

Link to comment
Share on other sites

1 hour ago, trcm said:

Settings > Camera > Formats > Most Compatible. 

That should fix your photos uploading as Apples silly HEIC format which don’t seem to display on this site.


What OBD codes is the car giving now?

Apologies, please see JPEGs below






Link to comment
Share on other sites

Wayne, let's take this step-by-step.

P2170 (low) & P2171 (high) are only thrown when the fault is detected on 2 consecutive trips.  The condition is that the valve is commanded and electrical resistance detected from the solenoid (=THE BOTTOM ONE!).

It having melted is not a good sign.

Did you replace it with the exact same part?


Now, on to the interesting stuff: fuse R7 not only controls the A/C valve but ALSO the Air Intake Control Valve solenoid (THE TOP ONE).  An error throws a P1113 BUT this is a non persisent code.  Only present 30 seconds after the fault occured which is resistance is detected when the AICV solenoid is activate at.... 4000 RPM.


I woud advise to measure resistance over an OEM exhaust valve solenoid, disconnect the one you have in now and put a resistor over the terminal for it to mimic the load on the circuit when commanded.

However, I do think there is something funky going on on the intake side as fuse 7 blew.


And... when fuse 7 goes, the A/C refrigerant distribution valve goes out... DISABLING the aircon!

😉  Happy hunting. (+ would loose the bluetooth solenoid to the larini... one simple 12v+ wire to the original solenoid and a switch works too... without any issues)


Seeing your pictures after my post... that solenoid is deffo melted.  See my post above.

  • Thanks 2
Link to comment
Share on other sites

That's correct, the FEBI one is a direct replacement for the Denso unit.


I have been reading your OP several times now, and sorry for me asking again, but just want the be sure and be able to help.

At current, that FEBI solenoid is electrically connected but no vacuum hoses are connected as you run a separate solenoid to control the Larini?  And after connecting the FEBI solenoid electrically, have the codes been erased (as they are persistent ones, they need to be erased).  If yes, you state that they came back?


What if you now erase the codes, drive the car, is it then again P2170 that shows?  


Link to comment
Share on other sites

Yes correct, the solenoid that's melted was just on its own for many months, with the Larini running off a Bluetooth module and secondary solenoid (a Ford solenoid which came with it actually).

Reinstalling either solenoid gives the same code.

If I clear the codes with my OBD reader, all goes back to normal until I hit higher RPMs, when it all goes back in to either pending or limp mode, with the P2170 code showing again.

Link to comment
Share on other sites

Ok, thanks for this clear answer.

Fuse R7 is OK.

IF that Pierburg solenoid (the molten one) is still functional (12v on the terminals will show that) then the resistance is not picked up by the ECU and cabling must be bad (molten?) going into pin CB4 of the ECU.

long shot: IF that Pierburg solenoid is no longer functional, albeit very unlikely, the new solenoid doesn't create enough resistance to be picked up by the ECU.  A 2Ohm - 5Watt resistor over the terminal can rule that out.


Below schematics shows where to diagnose off connector 3 / fuse R7 terminal to ECU pin CB4.  Simple test: Run a testlamp over the connector of the solenoid and rev over 4000 RPM to see it gets triggered.


Will be a simple fix, just needs some fiddling.




Edited by Kristof Thys
  • Thanks 1
Link to comment
Share on other sites

2 hours ago, Kristof Thys said:

Auto electric guy will be able to sort this out with the above schematic.  Without it, it is just guessing.

Thank you so much! 

update: the new solenoid appears to be faulty! 

  • Like 1
Link to comment
Share on other sites

UPDATE: Sincere apologies for not updating the thread. The car issues have basically taken over my life whilst I tried to get them resolved in time for Spain; ironically, that may now not happen due to the new government advice 🤦‍♂️

As stated above, the issue, in the end, turned out to be the replacement solenoid that I bought. I admittedly know very little about the workings of a car sadly, and therefore rely upon garages to tell me what this issue is. However two Lotus garages and an Auto electrician could not source the fault; this was purely because they tested everything but the new part I ordered. I only realised this after the fact, but in my day to day life of IT repairs, I would have tested everything personally.

I was at a loss and called my regular mechanic, but he told me he would be busy until around tuesday/wednesday of the next week. With the impending trip looming, I couldn't really wait that long.

In the end, I called around several local Auto Electricians to find someone else, and one got back to me. He recommended a guy around 1 mile from my house and when I arrived, he tested all three solenoids that I had in my possession and told me "they're all f********" lol. In the back of his garage, he had a solenoid lying around from a Vauxhall Vivaro van. We fitted it, and the limp mode disappeared as soon as I'd cleared the codes. The car let me rev all the way to the red line and cruise control stayed on etc.

It was so obvious in the end, I just had no idea the other mechanics hadn't tested the new part!

  • Like 2
Link to comment
Share on other sites

@WayneG Thanks for the update.  And a good thing it was the obvious thing (the solenoid) being defective. 👍


Comes to show that "the specialists" not necessarily are attacking such issues the logical way.  And that the "non specialist" idiots (like myself 😉) go by elimination.  To start with the replaced part, like you would too.


Edited by Kristof Thys
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...