free hit
counters
Traction light : to be or not to be that’s question - Page 2 - Engine & Ancilliaries/Gearbox - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

Traction light : to be or not to be that’s question


Recommended Posts

  • Gold FFM

Ok 

you guys have convinced me to replace the part !

so do I buy a part from lotus at £60 or is there a part just as good but fraction of cost ? I am little dense but do I order the GM part from a Euro car parts place or ebays etc ? 
I thought I will get someone to fit it otherwise I make a right hash ! 😮

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
  • 2 weeks later...

It will still need setting up, the service letter may say 5 clicks but the reality is 7 or 8.

OK what and I referring to, The white end of the switch is on a ratchet. It needs to be pushed home and pulled back out 7 or 8 clicks

 

 

EVORA Brake switch.jpg

Link to comment
Share on other sites

  • 1 month later...
  • Gold FFM

I am little perplexed my traction light not been coming off or on for the last 4-8 weeks then today came on ?

I am trying to determine why ? I know it could be this faulty brake switch but maybe other factors have a part? 

weather today when driving was wet and damp , the last few weeks I used the car it’s been relatively dry so does the wet conditions affect the switch or some sensor ? 

Link to comment
Share on other sites

  • 1 month later...

My traction light also occasionally comes on, always  in damp weather, and have never managed to find out why. I was thinking that it was possibly water getting into the wheel speed sensors or their wiring, but wouldn’t that mess up the ABS too? Not sure how dampness would get into the brake pedal switch in the driver’s footwell, unless it is water dripping off my wet shoes. I’m going to try the silicone grease on the brake switch trick to see if that cures it.

Link to comment
Share on other sites

  • Gold FFM

I am convinced it’s linked to wet/damp spells ? For the last 10 weeks of recent dry spells no light 

then last couple of days when it’s been raining light appears , it doesn’t feature in OBD reader so I am not going to spend £40 on a brake switch !

Link to comment
Share on other sites

  • 1 month later...

A smear of silicone grease on the brake pedal switch and pulling out the plunger SEVEN clicks seems to have cured the traction control warning light problem for me, so far.

 

For those contemplating buying a new switch, Bell & Colvill / De Roure have this SAAB part listed for £13.90+VAT.

https://www.deroure.com/partinfo.asp?MAK=0&MDL=0&TBL=0&SMA=0&SMO=0&ST=&SC=0&PBID=539239

I think that it is the equivalent to the Lotus part (with a little fettling) and good value, if they can actually supply them at that price. See

https://www.lotustalk.com/threads/traction-control-light-going-off-all-the-time.410002/

Link to comment
Share on other sites

  • Gold FFM

No traction light for the last two days I drove the car back from Scotland and during the hot spell

going to wash the car in the next day and I wouldn’t be surprised to see traction light come back on ? 
I will get brake switch replaced but my lotus garage fiddled about with it a couple weeks and said it was fine ?

Link to comment
Share on other sites

  • 2 months later...

Its recently happened to me too, just had a poke at the brake sensor to see what might be going on...

IMG_7489.thumb.jpg.581ee68d64d7f8b58329ca11aeb57d2c.jpg

Two (the coppery pair) of the four plug blade terminals are shorted when the plunger is up, with the silvery two open. This reverses when the plunger is depressed and those two small silver button shaped contacts are separated.

That red component is a mystery as I didn't want to try and wangle it out to examine it.

I applied a bit of contact cleaner, some contact grease and some silicone lube to the plunger slides and it's gone back into the car, I'll see a little later if that has fixed anything, otherwise I'll be in the queue for Deroure to source the SAAB part from the factory.

 

NB: I fully pressed in and then pulled the plunger out by seven clicks, but when back in the car as soon as the brake pedal was relaxed onto the plunger I heard it click in one notch further.

Edited by trcm
Link to comment
Share on other sites

  • 4 weeks later...
  • Gold FFM

Got in my car this afternoon for school run and hey presto engine and traction light on ? 
car was serviced a few week ago done 570 miles last journey last  Sunday to NEC 70 mile round trip on motorway no issues

Connected my OBD reader as carry in car cleared codes and all seem fine

should I raise it with my dealership as they replace brake switch and serviced car ? Or is it just one of those quirks of lotus or my car ?    

Link to comment
Share on other sites

Their work will be warrantied, as will the parts they fitted be. 

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to comment
Share on other sites

Agreed, it does seem unfortunate, do you know if the garage replaced with the same type (the one with the large D-shaped bulge housing what appears to be an inductor and capacitor as some kind of transient smoothing circuitry) ?

Edited by trcm
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...