free hit
counters
New Evora GT clutch question - Engine & Ancilliaries/Gearbox - The Lotus Forums Jump to content


Recommended Posts

Hello all, 

i have a new 2020 Evora GT with 1400 miles on it since July.  In the last 50 miles or so, the clutch started to feel different.  Instead of feeling really smooth when the clutch pedal is depressed, the clutch has a ”grindy” rough feel to it now.  The grind/rough feel is correlated with speed/load.  It feels smooth at idle when simply depressing to shift into 1st gear, but feels rough at higher RPM when depressing the clutch pedal.    I am about to take the car in for my first ever oil change.   Should I be changing the transmission oil a well?   Anything else that would cause this rough clutch feel?

cheers

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

  • Gold FFM

I would hope the car is under warranty and your Lotus dealer would fix this. 

Justin 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...