free hit
counters
Idling issue - '89 SE - Engine/Ancilliaries - The Lotus Forums Jump to content


Recommended Posts

Hi all.

Loving my SE which I imported from UK to NZ earlier this year.  It has an issue whereby it either idles too high (around 1400rpm) and the revs drop very slowly when taking my foot off the accelerator, or it idles a little too low (800rpm) but the revs drop normally.  It sometimes stalls in this mode.  A probably unrelated issue is to do with hot starts.  Cold starts are fine, as are starts when hot and the engine has been off for less than about 4 minutes.  Any longer than that and it takes about 6-8 seconds cranking to fire up again.  I suspect leaking injector(s) but any input would be appreciated.

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Also sounds like an IACV reset could be in order?

Also sounds like an IACV reset could be in order?

  • Like 1

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to post
Share on other sites
14 hours ago, jonwat said:

Have you read the ECM codes? Always worth doing first. :thumbup:

No, I haven't.  I take it I need to read using freescan or the like?  I've downloaded freescan but haven't yet got the right cables.

 

14 hours ago, Bibs said:

Also sounds like an IACV reset could be in order?

Would this be done manually, just by disconnecting the battery or using freescan?  Gotta get those cables organised!

Link to post
Share on other sites
  • Gold FFM

You really need to buy a cable. The IAC valves are cheap as chips on rock auto and a service item. These were from the GM days any were awful on the cavaliers in the day.

Only here once

Link to post
Share on other sites

@internets is your man for the cables and it's a button in freescan to reset the IACV 👍

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to post
Share on other sites

Thanks for the tip re cabling.  I've messaged @internets and hope he can sort me out.

Re Rockauto:  I've been to their site but there doesn't seem any listing for the iac valve under '89 lotus esprit. Would it be a generic iac valve that I can find elsewhere on the site?  Thanks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...