free hit
counters
Im hating my evora s ips - Page 2 - Engine & Ancilliaries/Gearbox - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

Im hating my evora s ips


Recommended Posts

  • Gold FFM

I don't think this is engine failures ramjet. Not sure what the first engine problem was but it sounds like the second was an attempt to go fast and furious and do the internals to up the power. The problem being that nobody at the garage could get the mapping sorted? So they switched back to a 'stock engine'.

That's how I read it anyway.

When they switched the engine back, did they also switch the ECU/map or are you running some weird map or custom ECU for the modded engine that it's now horrifically confused about?

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
On 28/12/2020 at 14:37, Bibs said:

I'll have a word with the factory when they are back in next year and see if they have any insight that may help. 

I'll be thankful to you if could give me some thoughts about the fixing which could be simpler to me cause im not trusting the dealer here in kuwait 

Link to comment
Share on other sites

14 hours ago, ramjet said:

As this engine is from a Toyota Camry and I have known a lot of people with those cars as well as many people on here would know of those cars as well, the requirement to change three engines just does not seem correct.

MAF sensor and throttle body are things that they should have looked at first. Not after three engine changeouts.

Wait to see what Bibs can find out from the factory in the New Year Khalid.

Was the car running ok when you first bought it?

When i bought my car which had an engine failure after the first 5k km which the dealer here said that was an abuse of my use which was 3 days ago the car was serviced from them that they didn't give any notes just toke from me 260 kd which is around 800$ Only for oil change. 
 

the main question here is it possible that i install an toyota throttle body and the maf sensor for the car or i just stick with the lotus part? Its really easy here in kuwait to find toyota parts cause in my country to buy lotus parts it takes around 2 months minimum for the parts to arrive

10 minutes ago, TdM said:

I don't think this is engine failures ramjet. Not sure what the first engine problem was but it sounds like the second was an attempt to go fast and furious and do the internals to up the power. The problem being that nobody at the garage could get the mapping sorted? So they switched back to a 'stock engine'.

That's how I read it anyway.

When they switched the engine back, did they also switch the ECU/map or are you running some weird map or custom ECU for the modded engine that it's now horrifically confused about?

We tried to make it fast and furious but it didn't happend 😂 nobody could help me for the tuning and mapping the car so we switched back to stuck internals and it didn't run then the dealer told me to change my ecu and tcu and i changed it again!! 

  • Like 1
Link to comment
Share on other sites

  • Gold FFM

I really do hope you get this sorted but it sounds like you tried to do something "blind" and walked into a door!  You cannot blame Lotus or the car for this.

But as I said I really do hope you get this sorted.

I would put it all back to absolute standard. Everything. Engine. Sensors. MAF. Etc. Then start from there.  Best of luck.

  • Like 1

Alcohol. Sex. Tobacco. Drugs. Chocolate.  Meh! NOTHING in this world is as addictive as an Evora +0. It's not for babies!    

The first guy to ride a bull for fun, was a true hero. The second man to follow him was truly nuts!   

Link to comment
Share on other sites

9 hours ago, TdM said:

I don't think this is engine failures ramjet. Not sure what the first engine problem was but it sounds like the second was an attempt to go fast and furious and do the internals to up the power. The problem being that nobody at the garage could get the mapping sorted? So they switched back to a 'stock engine'.

That's how I read it anyway.

When they switched the engine back, did they also switch the ECU/map or are you running some weird map or custom ECU for the modded engine that it's now horrifically confused about?

I agree Stephen. Certainly how it reads. If the first engine blew in 5kms and they blamed Khalid's driving. I'd have been asking to see the ECU dump as proof. You would have to drain the oil and go ballistic to blow an engine up in 5kms.

  • Like 1

All we know is that when they stop making this, we will be properly, properly sad.Jeremy Clarkson on the Esprit.

Opinions are like armpits. Everyone has them, some just stink more than others.

For forum issues, please contact one of us Moderators.

Link to comment
Share on other sites

I do hope you get this sorted, as said above, the main issue here appears to be the tuning attempt combined with lack of expertise from the dealer you are using.

I don’t know what other options you have in Kuwait but I would look to get the whole car back to standard, engine, ancillaries and ECU mappings etc etc.

I know the MAF is a standard Toyota part so I suspect the throttle body is too.

I would also recommend you wait and see what BIBs contacts come back with regards the issues.

Lastly, another avenue may be to speak with Lotus UK RE this dealer, I only know what’s been posted on here from you but they really do seem below par.

Link to comment
Share on other sites

  • 1 month later...

This is an update with the car with the dealer who doesn't know whats the problem with the car after changing the maf sensor which the car as they said became with the normal idle amd suddenly the car stopped while the they was relearning the tcu and programming in the high way and these codes came. 

so any thoughts?

A549EE56-A7EA-4434-86FF-8C68F870EDF3.jpeg

Link to comment
Share on other sites

32 minutes ago, pete said:

Didn't Bibs come up with anything

I have some info which I'll post up tomorrow when I'm back at work. 👍

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to comment
Share on other sites

Can you please check that the battery is correctly connected and good. Also, please check the starter relay. You need to check why the cars are pending the fault code and this does seem to point towards an air leak somewhere.

  • Like 1

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...