free hit
counters
small stone or strange object in brake pads/discs ?? - Ride/Handling/Suspension/Brakes/Wheels/Tyres - The Lotus Forums #ForTheOwners Jump to content


small stone or strange object in brake pads/discs ??


Recommended Posts

Hi

Yesterday I was having fun on some country roads, there was gravel and on the way back home I noticed a "clic clic clic" sound, specially noticeable when braking (the higher the speed the higher it sounds), it is just on the right front wheel, I can't see any scratches on the outer side of the disc, so It might be on the inside, any hits of what it could be??

Here there's a video in which besides the normal sound of the pad rubbing the disc you can also hear the "clic clic clic"

https://photos.app.goo.gl/cErHTijyTpTjYTQX8

Thank you

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

Balance weights all in place ok?

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to comment
Share on other sites

2 minutes ago, gregs24 said:

Even just reversing sometimes does it. 

Normal reversing like to get out of a parking hasn't worked out , I will try a place when I can get more speed on reverse and brake.

Next step is to take the wheel out and inspect as @Kristof Thys suggests 

Last resort....take it to the workshop 

 

The sound has been there now maybe for 30 miles.

Thanks 

 

 

 

 

 

 

Link to comment
Share on other sites

I've just removed the brake pads, span the wheel and there's no sound, I put the brake pads back again and the sound is there again, so I guess is related to the brake pads ... (the disk is ok, not bent, not scratched and there's no steering wheel vibrations) so I will wait as I expect it to go away by itself

I've done a routine odb2 scan and this code came up "Chassis C22C1" not sure if this is related to the sound, so me removing the brake pads or something else, there's no light on the dash (I haven't been able to find anything on the internet) any idea???

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...