free hit
counters
MIL after fitting K&N - Engine & Ancilliaries/Gearbox - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

MIL after fitting K&N


Recommended Posts

Evora NA here, I have very thoroughly followed the service notes and other tips from here, to strip out my air box and MAF assembly completely (I also lubricated the gear cables).   I fitted a K&N panel filter, reassembled everything correctly but now have a MIL light on, which I wasn’t expecting…!

The car drives completely normally and the light isn’t flashing.   It doesn’t go off when driving.  I haven’t made any other changes.

What’s my best bet in terms of a code reader to identify the fault code(s) and hopefully clear them?  Any guesses as to what has triggered it?

If anyone else has had this after fitting a K&N please let me know…

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.

A temporary fault will illuminate the light for 5 on/off key cycles then disappear. It's worth picking up a cheap bluetooth code reader all the same should you have similar again in the future :)

 

  • Like 1

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...