free hit
counters
SSC TVS 1900 watercooled kit broken supercharger belt - Engine & Ancillaries/Gearbox - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

SSC TVS 1900 watercooled kit broken supercharger belt


Recommended Posts

Hello

I recently made some upgrades on my Exige V6 cup R ( you know that old track car that Lotus used to made before the EMIRA :) )

The car was already fitted with an air cooled tvs 1900 and mapped at around 430 bhp, and was working  very well

Then it was upgraded with the SSC TVS 1900 watercooled kit, forged internals, 430 cup throttle body, custom exhaust and custom mapped on the dyno to around 490 bhp

 

The problem is that after just one session the supercharger belt snapped and I m told that on high power cars used aggressively on track the standard belt can brake even if everything is correctly aligned etc...

Maybe with the xtrac gearbox it s even worst?

 

BTW doeas anyone have any suggestions or know if there are some reinforced belts available?

Thanks

 

 

  • Sad 1
Link to comment
Share on other sites

  • 3 weeks later...

Upgrade today to remove Google ads and support TLF.
  • 4 weeks later...

The work was done by a Lotus specialist in Italy they build racing and time attack cars and they know that the belt can be a problem on some applications.

They also offer a specific modification to solve the problem but I tought I would ask on the forums to know if anyone had problems with the belt and if there are other options to look for

as special belts etc...

When it was fitted with the aircooled tvs1900 the belt never broke.

I would say it doesnt look out of alignment but if anyone have pictures or instructions to check alignment and adjust belt tension let me know.

Anyone know the specific belt reference used on the SSC watercooled tvs 1900 kit?

Thanks

 

 

Link to comment
Share on other sites

1 hour ago, Mattmahope said:

My belt broke on my first drive with the TVS1900 kit fitted. Komotec said the pulleys were not perfectly aligned. They fixed it and I have had no problems since. Been using it hard on road and track for over a year now.

Thats interesting

Do you know where I can look at the alignment procedure and if it requires special tools?

 

 

Link to comment
Share on other sites

On 02/08/2021 at 22:53, steveoexige said:

Who did the work? Last year 247 Motorsport upgraded my TVS1900 to chargecooled and noticed that the belt alignment was slightly out. They had to machine the pulley adjuster to fit. Probably worth giving them a call.

Sent them an email thanks

On 03/09/2021 at 11:21, Mattmahope said:

My belt broke on my first drive with the TVS1900 kit fitted. Komotec said the pulleys were not perfectly aligned. They fixed it and I have had no problems since. Been using it hard on road and track for over a year now.

So you are using the watercooled SSC kit but the work to fit it was done by Komotec? Or did they just fix that problem later?

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...