free hit
Pertronix Ignition Tach Issues - Misc including parts cross references - The Lotus Forums - Official Lotus Community Partner Jump to content

  • 0

Pertronix Ignition Tach Issues



Hi Everyone

Finally got my Pertronix ignition and installed it yesterday. Spin

test on the bench showed all was working correctly. After re-

installing the distributor on the car the ignition had no spark.

Scratching our heads and after eliminating this-and-that we

disconnected the tach and she fired right up. After it was running you

could plug the tach back on the coil and all seemed well. Shut her off

but again with the tach connected it had no spark. So why does the

system no have enough juice with the tach connected? The gap between

the module pick-up and magnet may be off a little is all I can figure?

The car has not run since mid-July so I took her out for a spin and it

was nice to be driving the Esprit again.

This is the 3rd Pertronix unit I've tried. The 1st didn't fit. The

2nd was bad and now this 3rd one seems to be working but obviously

needs some fine tuning with the tach issue. One other observation is

that all Pertronix modules are not made the same. On this 3rd unit the

pick-up in the module is off-center making my new mounting holes on the

points plate measured from the 2nd unit useless. So I had to notch the

3rd unit's base plate to the new mounting holes in the points plate.

Any ideas from anyone on this tach issue?

Thank you,


83 Turbo

Link to comment
Share on other sites

  • Answers 3
  • Created
  • Last Reply

Top Posters For This Question

3 answers to this question

Recommended Posts

Upgrade today to remove Google ads and support TLF.
  • 0

Thanks Clay. It gives me hope I will find the solution.

On the bright side it does make one heck of an anti-theft device!


83 Turbo


I had this problem as well. I fix it some how, I just can't remember how. It was just by swapping wires around. Big help huh!!! I'm sorry.


Link to comment
Share on other sites

  • 0

The problem was the engine rev limiter.

I ran a new wire from the tach to the coil and engine fired right up and the tach was working properly. So the problem is in the wiring. Following the wiring diagram the tach wire goes to an alarm and the rev-limiter. Disconnected the rev-limiter and hooked the original wire to the coil and all is well.

Regarding the alarm I've never seen one unless it is buried somewhere darkest parts of the body.

I could replace the rev-limiter but it cuts in at 7100rpm and I'm pretty sure I will never do that, at least not on purpose.


83 Turbo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Upgrade today to remove Google ads and support TLF.

  • Create New...

Important Information

We use cookies to enhance your browsing experience, serve personalized ads or content, and analyze our traffic. By clicking " I Accept ", you consent to our use of cookies. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.