free hit
counters
Speedo glitch - Misc including parts cross references - The Lotus Forums Jump to content
Sign in to follow this  
Brandt

Speedo glitch

Recommended Posts

I've been doing a search for the gitch problem on the speedo of my '83 turbo on the forum, but found none.

The speedo needle gives a bounce (drops down and then recovers) every quater mile! When this happen I can also hear a distinct 'tick' sound form the speedo.

I've oiled the cable but it made no difference. Iv'e also taken out the speedo, and driven it with a drill, but it didn't show the glitch powered this way.

I'm still suspecting the speedo, due to the 'tick' sound. Any advise?

But the way, even though my speedo proudly say mph on it, it has been set up to register Kmph. And the odo also count in km.

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Try to search "speedometer" you willget lots of info on your problem. We all have had it or are having it. My '83 had severed in Canada for som time and was converted to read KM. I had it changed back in a re-build that didn't change the click to which you are reffering.

Cheers

Clay

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...