free hit
counters
code reader problems - ECU/OBDII - The Lotus Forums Jump to content
Sign in to follow this  
M3S2k

code reader problems

Recommended Posts

Hey all,

I just bought the Innova 3100 OBDII code reader that was suggested by lew as a good reader to use for our cars. I today tried hooking it up to my car as my car keeps bringing up the engine light under heavy acceleration only to go away after a few starts. I was hoping to pull the codes this evening, however when i hooked it up to the car I could never get it to successfully link to the car. The reader does turn on as soon as you plug it into the car, but thats it. Ignition on the car was turned to the run position. After I tried it in my Audi and it worked fine. The plug on my esprit appears to only have 4 wires hooked into it, which seems odd for a 16 pin plug. Any insight would be greatly appreciated.

Steve

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

even with a 16 pin plug it is not nesessary to have all 16 pins conectet. The reader protocoll maps (PWM,VPW ,KWP,ISO, CAN) use not all off them. And it depends on manufacturer for some functions

Go to "www.obd-2.de", switch to English Language and read all backround informations about OBD ... .


*********************************************************************

to name the things if I see them, that's what I call integrity..

*********************************************************************

Share this post


Link to post
Share on other sites

I think that the V8 uses the ISO protocol. Have you set the code reader to that setting?

Regards,

Peter.

Hey all,

I just bought the Innova 3100 OBDII code reader that was suggested by lew as a good reader to use for our cars. I today tried hooking it up to my car as my car keeps bringing up the engine light under heavy acceleration only to go away after a few starts. I was hoping to pull the codes this evening, however when i hooked it up to the car I could never get it to successfully link to the car. The reader does turn on as soon as you plug it into the car, but thats it. Ignition on the car was turned to the run position. After I tried it in my Audi and it worked fine. The plug on my esprit appears to only have 4 wires hooked into it, which seems odd for a 16 pin plug. Any insight would be greatly appreciated.

Steve

Share this post


Link to post
Share on other sites

it's right ! Lotus V8 is [iSO 9141] interface protokol

http://www.obd-ii.de/tech_conn.html

Edited by G

*********************************************************************

to name the things if I see them, that's what I call integrity..

*********************************************************************

Share this post


Link to post
Share on other sites

when i plug the reader in it automatically starts rolling through the different protocols looking for which one the car uses. I know it kept going back to the ISO 9141 protocol, but never seemed to link, though.

Share this post


Link to post
Share on other sites

I have the 3110 scanner and it works fine on my Esprit. I use the connector under the dash (on my year and model there are two connectors


JoeyO

2001 V8 - Silver

2007 Ducati 1098

Share this post


Link to post
Share on other sites

@Steven: then your set-up must be incorect, or the code reader or conector port faulty.

Edited by G

*********************************************************************

to name the things if I see them, that's what I call integrity..

*********************************************************************

Share this post


Link to post
Share on other sites

ok, i've had the engine light come on and then disappear about 3 or 4 times over the last couple of months with no noticable difference in performance, but now i would just like to know what is tripping the engine light for peace of mind. I will look to see if i can find the plug-in by the battery and try that. Thanks for all your help.

Share this post


Link to post
Share on other sites

Update, had problems uploading the updated software onto my code reader, but finally got that fixed. Tried scanning the car again and it never seems to be able to link to my cars ecu. Tried both ports on the car. I've used it in my Audi and pulled codes on my mom's Mercedes (also ISO9141) and works perfectly so it must be something to do with the car. Anyone have any ideas??

Share this post


Link to post
Share on other sites

first try out the power ports, PIN's listed in previous link: http://www.obd-ii.de/tech_conn.html

they should have current (polarity) available. The necessary (for ISO) pins are also listet... .

sometimes my code reader makes trouble after i changed some setting to try other options. Look that your settings are not opposite to each other.

And i guess you have not removed the ignition power -/ fuel pump -relays (as i do sometimes to secure my car from unwanted use... :thumbsup: )

Edited by G

*********************************************************************

to name the things if I see them, that's what I call integrity..

*********************************************************************

Share this post


Link to post
Share on other sites

Not much I can suggest, but if you're based anywhere near Kingston, surrey you're welcome to test my reader?

John

Share this post


Link to post
Share on other sites

I had the same code reader from Innova and experienced exactly the same connection problems, so I contacted Innova and after several emails back and forth, they sent me a new, upgraded code reader which utilizes different source software and it worked fantastic. They do know of the problems with connecting to the Esprit, so I would suggest you contact them and see if they can do the same for you as they did for me. All and all I found them to be very professional and had excellent customer service, so I am sure once you contact them, they will have you sorted out in no time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...