free hit
counters
Lack of turbo boost - Induction/Turbo/Manifold/Exhaust - The Lotus Forums Jump to content
Sign in to follow this  
Michaelgh

Lack of turbo boost

Recommended Posts

Been out today in the car running very well, suddenlley turbo pressure gauge shot of the dial, slowed down pretty quick, turbo pressure drop right off.

Set off again engine running ok, don't seem to be get a lot of boost now any idea what I have done.

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

it sounds to me like the diaphram has gone in the wastegate, that or prehaps the locking nut has come off the end of the valve, or it could be locked in place, either way you need to open it up, nothing scary just a bit of a dirty job

ok dont drive the car!! get the rear passenger side up on a jack stand and take the wheel off , there you will see the wastegate cup, there is 4 bolts holding the cup on from the top lip, when undone the bottom cup will want to shoot off as there is the wastegate pressure spring behind it, hold it tightly and let it off gently. when its off you will se the underneath of the diaphram, if you can just see bare threads at the bottom of the valve stemm check if the nut is in the bottom of the cup if it is then re fix it on with some thread lock. if thats ok and not off, then undo it and gently take the diaphram out and see if its ripped, if it is ripped then you will need a new one im afraid!!, i know paul matty has one left in stock and also sj sportscars has quite a few in stock now, replace the diaphram, do not forget to get the two replacement gaskets that go either side of the wastegate!!!! very important you get these and then re-assemble.

i will dig out py pics of mine in bits and being assembled for you too look at.

Edited by bigsi

Share this post


Link to post
Share on other sites

check that any vacuum pipes haven't popped off, I had one go today, right by the cambelt, just age really. The rubber loses its elasticity and is blown off by the change in air pressure. snipped the wider end off and slid on the un stretched fresh rubber, problem solved.

Not saying thats what is wrong with yours, though. have you looked around in the engine bay?

Share this post


Link to post
Share on other sites

Bigsi

You say don't drive the car bit I have just done over 30 miles to get it home, would it do any damage if i keep the rev,s down

Share this post


Link to post
Share on other sites

if the blow off valve is venting you would hear it, its quite a noise when it goes off. keeping the revs right down is good, that way you dont cause further issues

Edited by bigsi

Share this post


Link to post
Share on other sites

Thanks for your help,the engine sounds the same as normal does not appear to be "venting" through the wastegate seal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...