free hit
counters
SE Speedo cable - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
Jonathan

SE Speedo cable

Recommended Posts

Originally going to make this didigtal by taking the speedo from the wheel sensor BUT decided for the time being to go back to the original.

However I know mine was damaged when I got it but has anyone got a detailed photo of the union into the gearbox ?

It has a funny cover but I don't know how it holds the cable in place.

Travis !!?? hehe (I know you've photo'd every square inch of your car !)


facebook = [email protected]

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Don't have a photo to hand, but the end of the cable has a plastic grommet on the outside of it that is a push fit into the gearbox. There is then a metal spring clip that holds it in place.

Share this post


Link to post
Share on other sites

Hi Jonathan

Is that you are looking for ?

Y.Hotta

ups I can't upload picure ?

post-386-1209410629.jpg

Edited by esp88

Share this post


Link to post
Share on other sites

Thanks for the effort - yeah it's the spring clip I guess I have lost, wonder if Lotus have one, if not prefab time again.

Cheers fellas


facebook = [email protected]

Share this post


Link to post
Share on other sites

Here's the clip in my 89SE. This entire hole is not in the casting for the electronic speedo cars...

P3240107.sized.jpg

http://vulcangrey.lotuscolorado.com/galler...amp;id=P3240107

P4240204.sized.jpg

http://vulcangrey.lotuscolorado.com/galler...amp;id=P4240204

Edited by Vulcan Grey

Travis

Vulcan Grey 89SE

My Lotus Photo and Projects Album

Share this post


Link to post
Share on other sites

LOL what would I do without ya !

That little wirey thing (umm the spring) was never on the car, the plate was but I seem to have.....mislayed it.

Gives me a good idea of how to fix it though - great sutff - cheers chappys !


facebook = [email protected]

Share this post


Link to post
Share on other sites

Jonathan, I presume then you've been driving the car without the speedo cable in place, right? Any signs of leaks from there? I wish to remove my cable.

Cheers,

Sanj

Edited by sanj

Visit Sanj's Lotus Esprit Turbo SE pages

Share this post


Link to post
Share on other sites

I made a stainless blank for it but no leaks to speak of - tbh I haven't driven the car much more than a few miles, but when I did it was fine.


facebook = [email protected]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...