free hit
counters
braking problem - Suspension/Brakes/Wheels/Hubs/Steering/Geo - The Lotus Forums Jump to content
Sign in to follow this  
mr.oogieboogie

braking problem

Recommended Posts

hello everyone. took the s4for a run after changing the rad, temp great, charge cooler icey, but the brakes feel like there is no servo very strange abs / handbrake / and low level pad lights are all on, any ideas would be great as im a bit stumped why they would be on as all i have changed is the rad


It's Oogies turn to boogie

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

hello everyone. is there a fuse for teh braking system (any body know where as i cant see anything relating to it) after the rad went i know have all 3 brake lights on (abs/handbrake and low pad) cant understand why pretty sure i havent caught anything but all info i can find show no signs of a fuse for the system - confused.

all the best


It's Oogies turn to boogie

Share this post


Link to post
Share on other sites

Hi,

Sounds like the ABS pressure switch and accumulator.Total failure would point to wiring or fuse.Especially if you have been in the front of the car doing a big job like the rad.

Check the wiring on plug on the end of the pressure switch first and then the relays and fuse.

Failing that you may just have succumed to the common S4 ABS failure. That would give the lights and brake feel you describe and can also happen suddenly.There are loads of threads on this ,but brace yourself for the costs.Some members have actually replaced the whole system with tandem master cylinders I believe now as the ABS is so crap.

R

Share this post


Link to post
Share on other sites

thanks, i found the and replaced the fuses, alsothere was a block connector off on the drivers side near the ball shaped object. lights are still on so i willsee what happens, any ideas where the switch is so i can check the connections. -

well that looks like its solved the problem all lights off and braking restored, thanks to everyone for the advice and help hope i can return the favour.

all the best

Edited by mr.oogieboogie

It's Oogies turn to boogie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...