free hit
counters
Correct throttle / TPS adjustment - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
Jonathan

Correct throttle / TPS adjustment

Recommended Posts

Had a slack cable, and hence lazy pickup on the car.

Adjusted that yesterday visually at 1st so as the cable had a tiny amount of pre-tension (like harldy any) on the throttle.

I could only get 94% throttle even though the throttle was WIDE open to the point where I dont know if the cable is stretching again.

So clever old me decides to adjust the TPS.

In the book it says 0.5v to 0.65v for closed........yes the ECU doesn't recognise voltages below 1v for 1% throttle....OK so I advance it to ~ 0.8v and I get full movement...nice.

However the car is reluctant to drop RPM from 2000. When you start up it idles ~ 1500 and then drops to ~ 1100 but if you rev the car slightly it'll hover to 2000 for a second or so and then drop again.

It's not a HUGE problem as it has cured a lot of popping and stuttering the exhaust used to make, when you put the car through a gear change the rpm doesn't slow enough to get that stutter from pick up and feels a LOT smoother but sometimes it catches the car out ever so slightly and when you go from say 4th to 5th on a long gear change the car lurches slightly as you would expect if the engine was still revving.

The responsivness of the pedal is much more my liking as well - slightest touch and you have rpm, it's just this slow gear change issue.

I have also done an ECU reset !

Now my throttle seems to be fully close and open mechanically and I have full scale on the TPS however it is set slightly high, I just can't see what to do to even things out.

If I turn back the TPS I could lose 100% throttle and get that lag on the pedal that I HATE.

Could it be my IACV ?


facebook = [email protected]

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Listening with interest Jon as this was/is the same as mine. I found I adjusted the cable up until it "felt" right, but then had that horrible high idle problem that is so embarrassing going through built up areas!. I backed off on the cable and it behaved much better, although it does happen every now and then. I still get 100% throttle according to Freescan but like you I prefer more instant response.

I would love for someone to set out the correct procedure for setting the throttle up, ie adjustment under the pedal stop/adjustment at linkage/adjustment at TPS, not least because the cable is such a twat to get to when the engine is hot!!


In the garage no-one can hear you scream 

Share this post


Link to post
Share on other sites

Well it's in the manual - well the TPS setup is and I do have that set high.

Perhaps I'll try it lower and see what happens becuase at the end of the day mechanical throttle is the guvner, if you open then air will come in.

I've tried everything according to the manual, I've reset and might try and take off the IACV and see whether it's bugered or there's something in there stopping it from working correctly.

I guess really I should have set it up so at WOT the cable is at 99.99% extension but of course over 40,000 miles the cable will have stretched somewhat....oh I dunno.......seems to be going around in circles.

EDIT :

Just been out for a run de rapid, I def think it's the TPS, everything else but the MAT is working fine - My MAT got upto 80 degrees :ermm: so it's a safe bet that's not working too well.

Even with that the car seems much more friendly to the foot and considering thats...20bhp down ? :lol:

Looking at WOT the voltage on my logs seem to be 100% @ 4.33v (min) and going upto 4.76v maximum

So taking into account the zero voltage is 0.8 I could back that off to the correct tollerance (0.5-0.65) and still achieve WOT for the ECU...in theory...

Let the old shed cool down 1st and see what I can conjour up, I think this is the way to go though, set the cable up and then look at where the TPS hits max and back off from there.

Just one thing...................WHO the heck decided to fit cross headed screws to the TPS :)

Edited by Jonathan

facebook = [email protected]

Share this post


Link to post
Share on other sites

I haven't needed to but IIRC it's possible to adjust the opposite end of the outer cable near the footrest. There's another clamp under the carpet there. That will then give you more leeway on the adjuster over the manifold. Loosen the front clamp, reset the TPS, set the threaded adjuster to it's midpoint and fine tune from there.


DanR

Share this post


Link to post
Share on other sites

Mark, after re-adjusting the cable that high rpm thing went away again.

What it seems is that there is a slight back lash in teh cable, if you pull it the throttle will open and on closing it stays partially open for a few seconds before the vacuum takes hold in the intake and helps it shut. So the idea being that you set it about right and then test by pulling the cable and letting it go a fw times, the end stop on the throttle should stop with no creep afterwards. Works for me and I have a very nice throttle response now :lol:


facebook = [email protected]

Share this post


Link to post
Share on other sites

That could be due to a crimp in the cable guide (the large plastic tube from the engine bay through the firewall). If this tube kinks then it can put alot of friction on the cable, enough so that the cable won't slide back when you release the throttle.


Travis

Vulcan Grey 89SE

My Lotus Photo and Projects Album

Share this post


Link to post
Share on other sites

It's just sooooooo minute though, however on no-load the smallest throttle opening will rev the thing.

It's seriosuly 1/2 a turn on that throttle adjuster between silly high rpm and fine.

The important thing is I have rpm the moment my toe goes near the pedal which is what I like (brakes are working this week too !!)


facebook = [email protected]

Share this post


Link to post
Share on other sites

I have had my GT3 for four years and all of that time it has had an erratic idle speed and throttle response. You definitely want to remove the IAC and clean the pintle on the end and make sure the machined hole in the inlet manifold is clean. If it has never been cleaned it will have a lot of dirt around it. This bit is just maintenance.

The TPS should be set as per the manual, around 0.5v, using Freescan. I did this several times, but the idle speed was still unreliable. In the end I changed the TPS and now everything is perfect, all throttle and idle problems gone. It is not surprising the TPS gets worn out - just think how much movement it constantly gets over the years.

If you do remove the TPS you will have discovered the ultra crap cross head screws. Once you have them out, throw them away and replace with a decent socket head screw, spring washer and plain washer that you know will be easily removable in the future.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...