free hit
counters
Check engine light on - ECU/Freescan/Espritmon - The Lotus Forums Jump to content
Sign in to follow this  
internets

Check engine light on

Recommended Posts

Since I put my car back together after the C service I keep getting a CEL when the car has warmed up and I boot it. If I switch off the engine and back on the light goes out. If I drive it normally its fine. The car appears to drive as normal with the CEL light on. When checking the trouble code in Freescan its '13-02 Sensor open circuit'

I tried some switch cleaner on the connector and re connection but seems to make no difference. As far as I can tell its an OEM 02 sensor.

Any thoughts, before I shell out on a new one?

Edited by internets

1982 DeLorean DMC 12 #16327, 1999 Lotus Elise, 1998 Lotus Esprit GT3 #2272, 2011 Lotus Evora S, 2013 Lotus Exige S,2016 Lotus Evora 400

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Replaced the O2 sensor and been fine since :)


1982 DeLorean DMC 12 #16327, 1999 Lotus Elise, 1998 Lotus Esprit GT3 #2272, 2011 Lotus Evora S, 2013 Lotus Exige S,2016 Lotus Evora 400

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...