free hit
counters
inlet manifold to head studs - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
giorgio67

inlet manifold to head studs

Recommended Posts

Hi,

does anyone know the right measures of the studs to mount the inlet manifold to head?

I'm sure they are 8mm but I don't know the overall lenght and the thread lenght.

I can't find mine in my workshop.... and I want to buy stainless stel studs.

Thanks in advance.

Cheers

Giorgio

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

They are M8.

I've just fitted a new exhaust manifold, I couldn't find the length either so removed the old studs and cut the new ones to the same length with an angle grinder and tidied up the threads on a belt sander.

I bought my studs from http://www.namrick.co.uk/

Cheers

David

Share this post


Link to post
Share on other sites

Hi David,

thanks for the link, but I don't think they are Stainless steel.

Just found these: http://cgi.ebay.it/ws/eBayISAPI.dll?ViewIt...em=230328247240 and they are available in 8x45mm, so perfect fit for the job.

Cheers

Giorgio

Share this post


Link to post
Share on other sites

Hi Giorgio, good to see you - I've been hopelessly busy for the last few months.

That engine of yours will be looking good.

Iain :)

Share this post


Link to post
Share on other sites

Runs like a dream - the head is smooth and I found the overheating problem was a blocked up radiator from bits of sealant. The engine mounts and cross bar you made fit like a dream. :) Nicest part of my engine.

Next up for me is a prep and paint job (yuk).

Iain

Share this post


Link to post
Share on other sites

Have you fitted my engine mounts???

NO report?

No pics?

Nothing????? :band:

Please...some pics of the job..... :fun:

Pete had some problems fitting them, but I suppose were the engine legs and not my mounts... :)

Ciao Iain

Giorgio :animier:

Edited by ghe67

Share this post


Link to post
Share on other sites

heh heh heh :) - that was a quick response!

I'll take some pics my good friend and post them in the right topics.

Iain :animier:

Share this post


Link to post
Share on other sites

Hi IAIN,

a little out of topic but I'm still waiting some good pics of my engine mounts fitted!!!

PLEASEEEEEE, I'd like to see them after such a job. :P

Ciao

Giorgio

Share this post


Link to post
Share on other sites

HI Giorgio,

Sorry I never fitted your mounts. I was a bit uninsipered afetr the 'legs' problem and I also wanted to see if the standartd mounts would help fix my vibration problem - which they almost have. When these ones wear out, I'll fit yours to see they make a difference.

Iain - what do you think so far?

Pete

Share this post


Link to post
Share on other sites

Hi Pete,

.....The engine mounts and cross bar you made fit like a dream. thumbup.gif Nicest part of my engine.

Iain words....anyway I'm still waiting also about your problem as I want to help you to solve any problems about my mounts.

The Iain mounts fit perfectly so I think the problems as you said is in the engine legs I have had made for you.

Just let me know how I can solve the mistake.

Ciao Pete.

Giorgio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×