free hit
counters
ECU CEL Behaving Strangley - DUFF ECU? - ECU/Freescan/Espritmon - The Lotus Forums Jump to content
Sign in to follow this  
CarlC

ECU CEL Behaving Strangley - DUFF ECU?

Recommended Posts

After all this time and work putting my car back together I've fallen at the final hurdle....

After four evening's working with the ECU to try and get it working, I'm stuck with the conclusion that it is duff.

Here is what is now happening.

First time switch the ignition on - No CEL showing.

Leave the ignition on for a minute or two and the CEL comes on.

Try the ignition, engine turns overs may just about starts but dies quickly.

CEL remains on at all times.

Ingition off and turn back on and the CEL lights immeditely.

But same result as above.

Try Freescan or the A/B contact short on the ALDL and the CEL does not display code 12 or respond to Freescan.

I have run through the two ECU service note fault diagnoses procedures which report ECU Fault / Failure.

I have checked all gounds on the 4 ECU couplings - they are fine. I have checked the ALDL gounds and ECU gounds - all fine.

I have checked ALL fuses and they are all fine.

So any final suggestions or has any got a ECU for sale or recommend where I can get my fixed or re-con'd ?

Any help greatly appreciated....

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

Hi Carl,

You seem to have checked all the grounds, have you checked the 12v supply (at battery & ECU)?

Regards,

Peter.

Share this post


Link to post
Share on other sites

I dont know what work you have been doing, but........

after i replaced my clutch, it wouldn't start, well started and then died

Turned out to be anj earth wire (well several) that terminated in a ring crimp. The ring had become detatched from the rest of the crimp. They should have screwed to the bellhousing area near the crank sensor I think. Have a look. There should also be another crimp at the front near the thermostat?

Hope this helps

What work were you doing??

Glyn

Share this post


Link to post
Share on other sites

<OT ON>

Glyn, sorry for the quick off-topic but... could you resize your avatar please ? The picture of your Esprit appears to be a high-res file weighting 1.3MB !! :-O

It shouldn't need to be more than 10 or 15KB since the avatar dimensions are 150x150 maximum. I even wonder how you managed to upload the file, since the forum pretends to refuse files larger than 250KB.

I am gone...

<OT OFF>

Edited by troutrou

Share this post


Link to post
Share on other sites

Hi Carl,

I had a similar problem with my S4s and a badly seated chip in chip holder. Have you checked this our on your car? Try the OEM chip or a lower chip if you have one. It also could be a dry joint on your chip holder to circuit board rather than the chip intself or a faulty ECU.

If it's a hardware fault then I can get it fixed for you. Give me a ring tomorrow.

Pete also has an ECU that you may be able to borrow to rule an ECU fault out?

David

Share this post


Link to post
Share on other sites

Thanks for the tips guys. Un-usually, I've actually been no wear near the engine during this round of restoration but the whole front of the car has been off. I've been back to check the power from the battery and to the ECU and that seemed fine. I've checked with stock chip and both chips exhibit the same result. I've tested every contact through the chip holder to the memcal and even chip holder to ecu contact pin with good connections right through. To be fair the service notes are pretty good on the diag side of things and unfortunatley it all points to a knacked ECU. :)

Thanks for the offer Dave, I did recall an early conversation about ECU's with you, So I'll give you a quick shout tomorrow and get that bar tab ready again!

Edited by CarlC

Share this post


Link to post
Share on other sites

Replacement ECU arrived on Friday, so I got it on the car with the existing memcal, but the Fans come on after about 5-10 seconds and stay on. Swaped back to my ECU and this does exactly the same. Tried the ECU without the Memcal car still does exactly the same things, Fans on after about 5-10 seconds, car will start but runs rough. However, I could not get any error codes from the ECU. The service notes state that the ECU should flash a fault code if it cant read the chip/memcal but I dont get any CEL response from shorting the A/B pin or from Freescan.

Checked my plugs and they had a heavy deposit of carbon on, so Ill get these cleaned up while I try and source or test my memcal/chip combination as it appears the ECU may actually be ok.

:)

Share this post


Link to post
Share on other sites

Hi Carl,

See my previous reply. I had a bad chip and/or holder and this did exactly the same. Do you have your stock chip?

I bet you it's down to the chip or holder.

When this happened to mine, I could get a reading off freescan and there were no engine check light on.

David

Share this post


Link to post
Share on other sites

Hi Dave,

Thanks for your reply. I sort of pelased to report that what you describe is exactly what the car is doing. So that is of some comfort if its just the chip thats gone duff. However, I have tried my stock chip and that exhibits the same situation. :wallbash:

I've had some further assistance and I've sent of my chips and memcal to be tested. Fingers crossed its just the chips as I dont fancy trying to track down a spare memcal... :)

Share this post


Link to post
Share on other sites

Thanks for all the input guys.

Basically the chip and mem-cal were sent away and tested. It came back that the chip was fine but the problem occured when the chip was inserted into the chip holderand into the mem-cal. It is believed that there is a bad or dry joint between the chip hold and the mem-cal. Looking at the state of the connections in the mem-cal I could see this would make sense. So I was basically organising to get the chip holder neatly soldered to the mem-cal.

Then by chance noticed the updated Chip upgrade notes on Lew written up by Russell Bosier using the WC Engineering Chip holder! - My thanks to Russell for taking the time to do this. The chip holder by-passes the connection on the mem-cal and instead takes the data from the chip holder on the adapter board. Perfect!

So rather than letting loose with a soldering iron and a very delicate and rare electrical item I have ordered the adapter board which will heopfully get me back on the road very very soon!

Really big thank you to Dermot for the assistance and sending the replacement ECU so promptly to help me out with this problem, and also SuperDave for being ready in the wings to assist if things went really wrong!

I'll update the thread once I've got the adapter board installed and hoepfully my car running again!

Thanks all.

Share this post


Link to post
Share on other sites

Those WC adaptor boards are worth their weight in gold :D

Edited by internets

Share this post


Link to post
Share on other sites

I got myS4s Memcal from John Welsh a few years ago also. I am pretty sure he was the only source of new memcals, but I think he sold out quite some time ago now.

Glad the rightup was of use Carl. I always wondered how the board would fit in reality, so took some pictures as I am sure others may have been wondering also.

Share this post


Link to post
Share on other sites

After what has felt like an age, the Memcal adapter arrived from John at WC Eng.

Fitted the chip to the adapter board, attached the Memcal to the adapter, plugged it back into my origonal ECU and....

It fired up first time with no ECU errors reported !!! :) Phew!

So it was simply the bad connection between the chip holder on the Memcal and the chip. To look at it, the connection looked perfect but as with all things electronic it only takes a dry joint or poor contact to stop it all working.

Big thanks as always to Dermot and SuperDave for there assistance and input into helping get to the bottom of this issues, not to mention the guys on the forum who responded with ideas and suggestions. A potentially very costly issue to investigate and resolve in the end only cost me $30 for the adapater and a few more beers on the tab for Dave and Dermot.

If you've got a chip or thinking of getting a chip for your 4pot, the memcal adapter is essential. With memcal's nolonger easily available and the need to at times switch chips, the adapter board removes any need for de-soldering the origonal or resoldering the new chip or chip holder and removes the chance of damadging the Memcal.

Share this post


Link to post
Share on other sites

Another source of memcal adapters is www.moates.net

There is a single chip version, the 'G1', and a switching one, the 'G3', that would allow for things like valet mode, low boost or high boost modes etc :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×