free hit
counters
Cost of a S2 engine rebuild - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
chrisS2esprit

Cost of a S2 engine rebuild

Recommended Posts

I have been restoring my S2 Esprit for donkeys years and have never driven it, but for this year decided to get it on the road. Having started it for only the third time in all these years i have been greeted with quite a lot of blue smoke from the engine. It has only done 45,000 miles which i believe to be correct but if it is worn out does anyone know of an approximate cost of an engine rebuild ie rebore, new pistons, reground crank, head overhaul etc. I am ok doing bodywork but engine stuff is beyond me so i would need it to be built for me and reinstall it myself. Could someone recommend a specialist or engineering firm in the North Wales area that could carry out this work for me? I would be very grateful for any info as i really would like the car on the road for this summer, thanks Chris

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

My S2 had a top end engine rebuild by PNM engineering by a previous owner (Mat K, one of the forum moderators). They are in Wallasey which is that neck of the woods. Cost for that was

Edited by Nelly9000

Share this post


Link to post
Share on other sites

Yep that's me! Can't speak highly enough of Pete at PNM, a real diamond. When I lived in Manchester with the car, he did all my work. If the engine was delivered to him and you reinstalled, then I'm sure that could potentially lower the price.

He does work on his own so you need to factor in lead time, its not a job he could take on I think at very short notice, as he's usually inundated with work.

Good luck with it.

Share this post


Link to post
Share on other sites

This engine problem has really set me back. I have only started it about three times since i have had the car and not encountered this amount of blue exhaust smoke before, although i have ran it for longer this week. When i bought the car it was a non runner so i changed the oil, GTX

Please bear with me, just pressed the wrong button, i'll get the hang of it soon! The oil i used previously was GTX mineral oil but has now been changed to Shell 10/60 fully synthetic and i now seem to have this problem. Apart from rebuilding my own engine i am considering buying a used engine but again i may run into more problems, i have seen a 2 litre engine on Ebay which is from an Eclat, has anyone got any comments regarding the suitability of this engine for my car?

Edited by USAndretti42
Bye bye to the quote of the previous post

Share this post


Link to post
Share on other sites

It's not a straight swap as things are slightly different to allow for front engine Vs mid engine layout, such as water pipes going in different directions, but fundamentally it's the same engine.

If you consider a swap (you'll end up with a non-original engine), you might as well go for a 2.2l. It is a slight increase in torque and should make the car more user friendly. It's not too far off from original, but that's for your taste to decide as you'll then have non-original engine of a slightly larger capacity.

Share this post


Link to post
Share on other sites

If its only started after you swapped oils, it might be the oil. When I had mine it was super sensitive to which oil I used. I tried 10/60 and it literally drank it for breakfast. When I changed to Millers 20/50 (the manual specifies 20/50) it made a big positive difference. I got my oil from Paul Matty, but I think Pete at PNM can get Valvoline 20/50.

Share this post


Link to post
Share on other sites

Thanks for the replies, i'll change the oil first and get it trailered to the local rolling road and get the problem diagnosed, hoping the oil is burning from the valve guides and not worn rings/bores

Share this post


Link to post
Share on other sites

Hi Chris,

Probably not what you want to hear but a full rebuild will be around

Share this post


Link to post
Share on other sites

Hi Chris,

I agree with Pete about contacting Mike at lotusbits. I work on the same estate and know he now has an onsite engine rebuild capability,using the man who built the works Lotus Sunbeam engines. Not much better pedigree than that!

Andy.

Share this post


Link to post
Share on other sites

Thanks Pete, Andy. I'll ring lotusbits and PNM on Monday to see what used engines they've got, they might take my engine in exchange, it sounds sweet as a nut and has good oil pressure just seems to be burning oil!

The engine on Ebay is looking like one solution at the moment, i cant really afford a rebuild but an engine swop seems the way to go. I used to have an Eclat Sprint years ago which had the later E-camshaft type engine but i dont know if the 504 Eclat had it fitted, has anyone got any info on this? or got a good 2.0/2.2 Esprit/Excel engine they wish to sell me!

Chris

Share this post


Link to post
Share on other sites

I read somewhere that it may not be a good idea to use synthetic in older engines as it will seep past worn rings and seals. You may find your smoking problem is just related to the oil. Change the oil to mineral and see what happens.

Share this post


Link to post
Share on other sites

Hi Gavin

I've changed the oil filter and engine oil to Mobil 15/40 and run the engine upto temperature but still got the blue smoke when reved which is very frustrating after all the work i've done recently.

Chris

Share this post


Link to post
Share on other sites

I really think you should try 20/50. Its what the owners handbook recommends..........................

Share this post


Link to post
Share on other sites

The owner of the car I am about to buy told me that synthetic oil will put a film on the metal and that might actually clog up some of the small spaces the oil needs to go through hence leaking into the cylinders and smoking up you exhaust. He told me only to use the cheaper mineral oils as their viscosity are what the engines were built to run on.

/R.

Share this post


Link to post
Share on other sites

Hi

If your engine is the original one I would keep it ! any CC907 ***** block like yours should be is well worth having. I would not swop it with anyone

I would do a almost hot engine compression test and post up the results here, also post up it's oil pressure almost hot in a couple of rev ranges.

Is there much valve tapping or bottom end rumbling ?

Shame your not nearer to me I would pop and take a look

Best Wishes

Matt

Share this post


Link to post
Share on other sites

Hi Matt

I changed the oil to 20/50 and started the motor briefly today before it was trailered away to my local rolling road and there did seem to be an improvement i.e. less blue smoke, i will know how good or bad it really is tomorrow

Chris

Share this post


Link to post
Share on other sites

Hope it all goes ok for you ................ Cheers Mike

Share this post


Link to post
Share on other sites

Hi Mike

thanks for that, i've had some good news on the engine front, i replaced the engine oil with 20/50 and Pete at Balmuir garage in Wrexham and after an initial check he assures me the engine is fine. It always sounded good, reved well with no rumbles or rattles but recently had this blue smoke problem and i'll know more after the rolling road session. He is also doing the wheel alignment and i'm getting it back on Tuesday after the bank holiday.

Chris

Share this post


Link to post
Share on other sites

Thats great news.Cheers mike

Share this post


Link to post
Share on other sites

Just a quick update on my S2, i've got it back from the rolling road and although i've not run it for too long it starts and runs vey well. Theres plenty of small jobs to do and i'm getting a new windscreen fitted Thursday. On the subject of the screen could someone post a picture of the wiper blade and its mounting exiting the body, i cant remember how its all assembled and i seem to have misplaced the securing nut for the blade.

Share this post


Link to post
Share on other sites

Hi Chris,

Sorry about the blur! Hope these help...

DSCF6075.jpg

DSCF6078.jpg

Pete

Share this post


Link to post
Share on other sites

Pete

Thanks for the pictures, just what i needed. I seem to have lost/misplaced the nut and black plastic spacer, looks like a scrap yard visit and find something similar or has anyone got these parts they would like to sell?

Chris

Share this post


Link to post
Share on other sites

I use an oil from Penzoil that is for "older engines" 20/50. It is an SM rated oil which is obout the best you can get in mineral oil and much better than the SF grade common when the car was new. SF is among the cheaper oils now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×